Drobo

Yet Another Performance thread...

So, I’m trying to test out my Drobos performance. I just got it, plug it in, threw a HDD in it, and I’m trying to test speeds.

I tried coping a 12 gig file to it, I get about 10MB/s.
The same file between two computers on my network 54 MB/s.

So I’m guessing the issue lies in Drobo, but I can’t figure out why? I see plenty of “boost your Drobo’s speed” threads, but all of them contain tweaks for the computers connecting to the Drobo and not the Drobo it self.

I played around with different MTU sizes and am seeing 0 speed differences.

Is it because I currently only have one HDD in it? I just can’t seem to figure this out.

You need to wait at least 24 hours before the speed is stable.

24 hours…for what?

In any case, I should have been more clear, I popped the 3TB HDD in it about 3 days ago, today is just the first day I’ve touched the drobo since then.

EDIT: Read performance seems good enough for me tho, even with only one drive. I can stream a 12 gig, 1080p rip of Avatar to 3 PC’s at once while coping data to it, and no stutter.

Wait a minute, you have only one disk in there?

As of right now, yes. I am waiting on tax return to purchase another 4 3TB HDDs, and figured if it was going to take 3 weeks to copy all my data over, I might as well get started with what I have.

I assume that you are aware that in this case every write is performed twice, since the Drobo just duplicates the data on the disk as there is no other place to mirror it?

It would not be surprising at all if it is at least twice as slow than other devices, if not more since it is probably doing synchronous writes (the only thing it can do to ensure persistence).

You speak truth, it would be mirroring itself, wouldn’t it? You make a very good point. I can’t believe this fact flew over my head. Well, that would explain it for sure!

but…why would it do that? Doesn’t make much scene to do redundancy to its self tho.

EDIT: In fact, the more I think about it, the more this doesn’t make sense…why would it do this? In fact, the How is my storage being used section shows I have 1.33 for data and the reset is “reserved for expansion” with 0B used for protection.

You need to find out what MTU size your router, computer and any other thing you have on your network, before chaning MTU sizes. Unless all the devices support a certain number it’ll end up as a slower transfer.

Like I said, my transfers between computers is fine, it is only between the computer and the drobo where it is lacking. I have tried it at 1500 (which is what my computers and router are all set at) and tried turning jumbo frames on for everything. I didn’t just randomly start playing the the MTU number hoping for better speeds, lol.

I guess what I’m getting from these replies is my only hope for a speed increase is to add more hdd’s? I will be purchasing the rest of the HDDs around the 11th/12th. Hopefully thats all it is (tho I still don’t understand why, I’m assuming the Drobo uses, or at lest mimics in some why, a typical raid 5, in which case adding more drives would decrease my write speed (over just a single drive) but increase my read.

I guess I’m just confused as to why the Drobo is getting such more transfer performance while everything else on my network is fine. I understand its not a power house or anything, but when I log into it and check top its not using even 50% of it resources during a transfer. In the end, I can live with it I guess, once I migrate the massive about of data (9+TB) that I need to it, I will only be adding data in 800MB->15GB chunks after that most likely. Anywhere from once a day to once a week. Read is the most important to me, and it seems to be doing that fine.

Overall, I’d probably give the drobo a 4 1/2 stars out of 5. I’m not here to complain, just curiously inquiring if I’m missing something.

My impression is that a single disk would be the worst performance, due to the duplicated writes.

More than two disks should also have a performance impact, since with 3+ disks BeyondRAID kicks in.

I think the best performance ought to be with 2 disks, since as far as I understand it just does mirroring.

My point was that if your router or switch doesnt support a 9000 mtu that youll be getting a slower transfer between drobo and your computer.

Wow, if the drobo only has 1 drive it will mirror the data on itself? That’s kind of pointless. It would be better if that feature was only enabled with 2+ drives. If that’s possible.

I understand, I was just assuring you I knew how to properly configure it. I don’t think the mirror actually occurs. From what I see it reserves that space, not actually uses it for a mirror, I seriously doubt the would have coded such a over sight into there beyond raid tech, mirroring data to the same drive its on if no other drives are present.

EDIT: Just tested my read (Drobo->Computer) at its 11mb/s. So thats 11mb/s write (computer->drobo) and 11mb/s read.

Seems a little odd both of those would be spot on like that. Heres to hoping for better results when I have the rest of the HDDs installed.

Well, I checked on the drobolator, and it says “reserved for expansion”, so I might have misunderstood it.

But writing it twice to the same device is not as pointless as it looks. If you get a bad sector, you’ll be glad the data is on another area of the disk as well. Of course it does not protect you from disk failure, but sector failure protection is better than nothing.

So, since I will most likely be ordering the new HDD’s with in the next day or so, I decided to mess around more to see if I can improve my file transfers.

  1. I tested my speeds as normal, still 10-13mb/s (up and down)
  2. I plugged the Drobo FS directly into the PC using the network cable, still 10-12mb/s
  3. I switched Drobo FS back to router, but changed the cable. BAM. 50mb/s.

The cable my drobo came with must be defective. I get AMAZING speeds with a old cat6 cable I had laying around my house. I can not believe that the network cable that CAME with the drobo could be defective in such away the my transfer speeds go from 10mb/s to 50mb/s, but it is.

Under more testing, while my READ has greatly improved, it seems my WRITE has actually dropped, on a single, 12 gig file, the speeds start out horridly slow now (under 1 mb/s) and slowly increases to about 12.2 over the course of about 3 mins. Really odd behavior.

Under even MORE testing, it looks like it might not be the cable.

I have a WND3700 Netgear router and a DGS-1008D D-Link switch.

If the Drobo is plugged into the router, I get 10-13mb/s transfer rates, from any other device, plugged into the switch OR the router.
If the Drobo is plugged into the switch, I get 50 mb/s reads (transferring data from the Drobo to anything else on the network), but HORRIBLE writes, as described above.

WUT?

Seriously, what? Everything else on the network has no issues talking to each other. What is causing these crazy transfer rates?

Does anyone recommend a switch that is guaranteed to work nicely with the Drobo? Something cheap please, preferably under 100. Was looking at:
http://www.newegg.com/Product/Product.aspx?Item=N82E16833127325

Which seems to be the updated version of mine. Also picking up:

http://www.newegg.com/Product/Product.aspx?Item=N82E16833106033

So I have proper jumbo frame support between the two devices for the initial transfer from HTPC->Drobo. After that transfer tho, I will most likely turn jumbo frames back OFF. I have over 13 devices that are on my network, and trying to either upgrade them all or get jumbo frames working on all of them would be a nightmare.

I have a WNDR3700 as well. What does the ping test tell you the max size is?

Something sounds really really weird…
Turning JF off for everything would help simplify the diagnosis process.

Well the WND3700 Doesn’t HAVE jumbo frames, also, I have it off on everything for all of the tests I listed above.

If the WND3700 is the same as the WNDR3700 (I couldn’t find info on a WND3700 on Netgear’s site), then mine supported well over 8000-byte packets through the ping test. But yeah, keep JF off, fewer variables is better. :slight_smile:

Getting the exact value again will have to wait until I get home, but I do recall it not supporting over 9000.

WNDR3700, latest firmware. If you try to change the MTU to anything higher then 1500 in the firmware, it tells you it is not supported. It may pass those packets on thru anyway tho.

Either way, everything on the network is set to NOT use jumbo frames during the testing.

As long as the Drobo is plugged into the Switch and not the Router, I can retrieve data from it at 40-50 mb/s.

Coping data to it is all KINDS of crazy. It starts at like 20, for maybe 2-3 seconds, then it drops to 10 for about 3 seconds, then down to 2-4. Then slowly ramps back up to about 10mb/s. THIS IS ALL ON ONE LARGE (8gig) file. I am NOT transferring more then one file.

I get the same results from ANY computer on the network, plugged into the router or switch. Have changed the cable going to the Drobo about 5 times to make sure thats not it, and have changed some of the PC cables as well.

I am utterly lost at this performance.

More testing.

If I have PC and DROBO plugged into switch, and switch plugged into router, the performance is terrible.

If I unplug switch from router, I get steady, 20mb/s transfer rates coping data to the Drobo.

So the issue lies in the router somewhere. The router works fine for the other 13 devices on my network, and transfer rates between all of them are also fine. So there must be something the router does that the drobo does not like. If anyone could give me some insight on this it would be great.

HERE IS A RECAP OF EVERYTHING I HAVE DONE SO FAR AND THE RESULTS:

[code]Heres the equipment:

Router - WNDR3700
Switch - DGS-1008D

Now on to the issue. (when I state tested, I mean I tried it with a variety of computers and cables on the network)

If I have the Drobo FS plugged into the router, all my transfer rates to and from the Drobo are 10-11mb/s. I have tested this with computers also plugged into the router, and computers plugged into the switch with the same results.

If I move the Drobo to the switch, all computers can read (data transfer from Drobo->PC) at about 50mb/s. Tested with computers plugged into the switch or router. Tho, when I try to transfer data TO the Drobo, the speeds are awful. They start extremely low (2mb/s) and slowly creep to maybe 10mb/s.

If I unplug the router from the switch, and just have computer plugged into the switch and the Drobo plugged into the switch, everything is GREAT. 20mb/s write, 50mb/s read. As SOON as I hook the switch back to the router tho, next transfer from PC->Drobo is back to terribad.

JUMBO FRAMES are OFF across the board, all MTU’s are set to 1500 where applicable. [/code]

Wildly asymmetric write vs read performance across a network can indicate a duplex mismatch somewhere.
I have no idea how that could be happening in your setup, but check your hosts for retransmits anyway.
“netstat -sn” and compare the total segments sent to those retransmitted. There should be relatively few retransmits.

On a managed switch (eg. Cisco 3750), I would look at errors to see if a buffer is getting overloaded. Not at all sure you can do that with your switch, though.

Unplugging the switch and plugging it back in seem to get me more steady speeds. Now I’m trying to diagnosis ANOTHER issue, which is by far, the oddest thing I have EVER seen when it comes to networking.

My primary computer works great. I use it for torrents, MMO’s, transferring data back and forth to my HTPC, everything.

The Drobo is self is now working great. I get 20mb/s when sending data to it, and 50mb/s when reading data from it.

When I read data with my primary computer from the Drobo, it works fantastic.

If I try to SEND data to the drobo from my primary computer, everything goes CRAZY. It errors out, AND THEN MY NETWORK CONNECTION RESETS. Internet drops, the whole thing. It ONLY happens when transferring data from this computer to the drobo.

It blows my mind. Its not to much to worry about tho, Wednesday my new mobo gets here (last part I’m waiting for on my new PC), and this computer is going to me reformatted and re-purposed for one of my kids. If the problem still exists after a reformat, I have a extra NIC card floating around I can throw in it.