Drobo

yes yes yes - DD 1.5.1 - fw 1.3.4 - more speed !!!

Hi all
this is just a quick check
i copied only 10 GB - two times

i was on firmware 1.3.0
Jennifer advised 1.3.3 (4 hours ago in my other thread)
meanwhile it is 1.3.4

previosly my activity monitor tells me in the little graphical output
a heavy sine curve with a peak every 30 secs to 30 MB/s and next to 0 MB/s

since the actual firmware
the curve is not so extreme

max still at 30 but min is at 15 MB/s

overall speed impovement is factor 2

will say old version 18 min - new version 9 min


as said this is a first quick test
all values are approx !!! so dont nail me :wink:

hi

am i the only one experience this ??

with the Aja test with a 1 GB file
only two narrow peaks close to 0 MB/s

previously the curves hit so often the bottom (0 MB/s)
that it was hardly possible to watch tv
every few seconds (10 to 20) a hickup

visually seen the ups and downs looked like a almost solid fat bar

I hope this is true. I’m moving my drobo to a back up-back up + off site and to server off movies/proggies at my work.

Yes. For my config (see signature) it is true.
I tested it with AJA System Test (recommended by DRI) as well
i can see the improvement

there is an improvement as well while rebuild (maybe drobo stops here)

so good luck for you as well

Confirmed Improvement with me as well.

OSX10.5.8
FW800
DD 1.5.1
DF 1.3.4
4 X Seagate 1.5TB

I’m curious - the firmware 1.3.4 release notes doesn’t say anything about a speed improvement. The release notes says:

" Fixed compatibility issue with Second Generation Drobo and Mac OS 10.4 when using the FireWire connection"

The release notes also mentions “Previous Fixes from 1.3.3”.

So, the 1.3.4 release notes doesn’t say anything that implies that there should be a speed improvement.

JoeWa upgraded from 1.3.0 to 1.3.4, so I’m not sure what was in 1.3.1 or 1.3.2 that may have given a speed improvement.

scaryfast, you said you saw a speed improvement. What firmware did you have prior to 1.3.4?

I’m just wondering what to expect when going from 1.3.3 to 1.3.4, and whether it’s worth it, given that the release notes say that it’s to fix a compatibility issue with Mac 10.4. However, I have 10.5.8, so at face value, doesn’t look like I’ll get any benefit by upgrading from 1.3.3 to 1.3.4.

Thanks.

@randman
check my other thread:
Dashboard 1.5.1 and the disconnection issue

so do the update

I did not made the AJA on firmware 1.3.3
but i copied a lot cause i wanted to see what had changed
subjective spoken i did not realize a big difference
but after upgrade to 1.3.4 i realised an improvement
so i made the test
and then i opened this thread.


maybe DRI do not have 150 computers with all possible configurations and os versions
so if in the release notes is something like … issue … osx … firewire …
you might give it a try
and again read my other thread i mentioned above


I am not payed by DRI
I was not happy when bought drobo
I was complaining a lot
now I (me - and and least scaryfast as well) realised an improvement

so i made this thread !!! thats it

if someone is afraid of updating (maybe there are other bugs …)
so its up to them

i do not want to force or convince someone
i just mentioned what i realised

Greetings
JoeWa

Mine is still abysmal.

Mac Pro 2008, FW 800, Drobo v2 with 4xWD10EADS
AJA System Test:

Dashboard 1.2.4/ Firmware 1.3.1:
Write: 11.3 MB/s
Read: 15.1 MB/s

Dashboard 1.5.1/Firmware 1.3.4:
Write: 11.5 MB/s
Read: 15.3 MB/s

what os you have ?? 10.5.8 as well ?
did you make the AJA with file size of 1GB ?

unfortunately i have no idea why you have 11.5 and 15.3 and me 31.1 and 46.3
i do not believe that the wd10eads is so much slower than the wd20eads
please ask Jennifer …

or maybe
do you have daisy chained some other drives?
did you disable file system cache (in AJA) ??

as mentioned above my max speed results on small test files sizes are the same
the massive dropouts (performance) are gone.

so if you take a look at your clock while copy a big bunch of files you shall find an improvement (or use a higher file size in AJA)

Greetings

I updatet to FW 1.3.4 - nothing special to mention yet.

Has 1.3.4 been pulled by DRI? …as the FW1.1.2 for DroboPro was?

I can’t find it any more.

Still listed:
http://www.drobo.com/support/updates.php

[quote=“JoeWa, post:9, topic:326”]
what os you have ?? 10.5.8 as well ?[/quote]
10.5.8. No other firewire devices are daisy chained to the Drobo.

Let me just show you the screenshots:

1.2.4/1.3.1

1.5.1/1.3.4

I’ve had 2 tickets open with Drobo since Jan. and Jun., respectively, with no resolution. Believe me, I’ve been over everything for hours on end, testing and testing and big files and small files and plug this device, try that cable, replace this power supply, swap the Drobo.

Edit: Just did another test to verify. This time got Write: 8.5 MB/s, Read: 11.0 MB/s. Went to Dashboard to do a Diagnostic dump after the test, and the Drobo rebooted itself after I chose “Get Diagnostic Information.” I don’t know whether to laugh or cry.

TheBang

before my results looked like yours
now only a breakdown once a while…

i took the same Video res as you and my results are this:
(i did this while recording something with eyetv)

TheBang - just to confirm, the Drobo is the only Firewire device you have connected?

OK
you got me
i have two more drives attached
one sata and one ide

and youre right
when Mac - sata - drobo - ide = its worse (but better than before) 22 and 41 MB/s and higher amplitude but not below 5 MB/s

usually i do not use the ide drive very often and its loud so my conf is:

Mac - sata - drobo = its like the result i’ve posted before

Greetings

Interesting. I asked because (at least in Firewire 400), Firewire is repeater-based and the bus throttles down to the slowest attached device’s speed (which may be slower than the connection itself supports, for example, S100 or S200 devices run at 100 or 200 Mbps, respectively).

So having other devices attached to the same bus (even if not daisy-chained to the Drobo itself) could affect performance negatively.

Brandon

that is right
and is also true for FW800 as i do not use FW400 (and usb)
and (im not so sure about that) it depends on the case and the integrated chip as well
at the moment i do not have the time to extensiv drive and case swapping
(maybe later)

JoeWa

I find this “explanation” absolutely retarded (I’m not directing this at you personally, bhiga). I have, of course, seen this mentioned several times during my troubleshooting. Why should I have to jump through all these hardware configuration hoops in order to get even halfway decent speeds out of my Drobo? The speeds I posted above can in no way be explained by having a Firewire 400 device on the bus and having the bus operating at 400 Mb. In fact, you can see the peaks of my speeds are pretty much equal to what bhiga achieves. The peak write is about 38 MB/s and the peak read is about 53 MB/s (which exceeds FW400 bandwidth). It’s just the constant, non-stop drops to sub-10 MB/s make the overall performance horrendous.

Here are the results of a Firewire 800 external hard drive that I have connected to the Mac at the same time as the Drobo! Note, I’ve never had to do numerous firmware updates or other cable, power supply, or device voodoo to this hard drive to get decent performance out of it. I’ve never had to question whether my firewire bus is defective or if another device is making it slow. I just plug it into my Firewire 800 bus, and it works fast, regardless of any other devices that are plugged in. That’s what I would expect from my Drobo too.

But, just to humor everyone, I’m disconnecting EVERY firewire cable from my Mac except my Drobo. (That is, I’m disconnecting the FW800 drive above, and disconnecting the FW400 cable that goes to my Cinema Display hub (no devices attached)). Here are the results:

Ooh, yeah, we’re doing awesome tonight. I believe what AJA is telling me too, because tonight, I tried to copied a 5.52 GB DMG file from my Drobo to a USB drive. Took 26 minutes.

And here’s what the firewire bus looks like for that test, just to confirm nothing else is hooked up:

Actually I’m not getting any speeds right now… But Firewire is a repeater-based technology, so you’re subject to its limits.

There is some buffering, so unless you’re getting instantaneous speeds (which just about nothing software-wise reports), you can get bursts above the theoretical bandwidth due to timing and math.

That said, I do agree with your general point of “It shouldn’t be this difficult” to get reasonable performance.

So the question then becomes why you’re getting poorer performance compared to others.

What drives are in your Drobo?

Also, I’m a bit curious to see what your USB performance is. If it ends up around the same as your Firewire 800 performance, then it’d point to some kind of slowdown/bottleneck at the Drobo side rather than the interface medium.

And, of course, if you have access to another computer that you can run a test on, it’d be good to see that as well, to determine it might be something on your computer’s end. Given that your non-Drobo Firewire drive is performing reasonably, I suspect it’s not your computer, but it’s still good to have a comparison.

Brandon

As mentioned in my first post, I have 4 x WD10EADS. But I’ve actually had numerous drive configurations in there since I got the Drobo in Jan., and they’ve all been equally bad. I started with 2 x 1.5 TB Seagate. Thinking the slowdown was the Seagates (cause this is when the whole firmware thing blew up), I returned them and went with WD. I had 1 x WD10EACS and 2 x WD10EADS. Later, I added a 300 GB Maxtor (don’t know model anymore). The Maxtor was later replaced with another WD10EADS. And finally I replaced the WD10EACS with a WD10EADS in the vain hope that having all identical models would help. In fact, I even managed to get all 4 WD10EADS in there now in identical model revisions, so they’re as identical as possible. But in all configurations, performance has been abysmal.

I don’t have any graphs at the moment, but USB performance was similarly horrible. Believe me, I’ve tried all the troubleshooting left, right, upside-down, and sideways.

The only thing I haven’t done is try another computer, because THIS is the computer I want it on. And why shouldn’t it work properly on this computer? My other Firewire drive is fine. That said, as fate would have it, this 2008 Mac Pro is actually getting replaced permanently with a 2009 Mac Pro in about 2-3 weeks time, so I will, in fact, be able to eliminate the computer as a variable soon enough.