Drobo

Windows XP 64-bit - can't format above 2tb

Hi again,

More Dell / Drobo issues. The Drobo S and Dell are now playing nice (albeit via Firewire 800). However, when I go to format the Drobo via the Drobo Dashboard, I can’t create one large partition (I have 4 1.5 TB disks in there). I’m forced to have 3 partitions of 2 TB each.

I thought Windows XP 64 bit could handle disks above 2 TB - is this wrong, or am I missing something?

http://www.microsoft.com/whdc/device/storage/gpt_faq.mspx

“Can Windows XP x64 read, write, and boot from GPT disks?
Windows XP x64 edition can use GPT disks for data only. Only Windows for Itanium-based systems can boot from GPT partitions.”

I’m guessing that drobo wont let you do it since it simply sees “xp” and stops you from creating a GPT partition.

in theory you could connect your drobo to a vista/7 system to create the large volume, then connect it to the xp x64 box to use it.

Yeah, tried that - formatted it on my Windows 7 box and connected it to the XP 64 box - Drobo Dashboard detected the drive, but I couldn’t see it (not in My Computer nor using the logical disk management service).

XP no matter what version, will not mount any volumes larger than 2TB.

XP 64-bit is evil incarnate. Really, it is. The drivers are iffy-compatible with Vista/7 64-bit, and most installers and apps just don’t recognize it. Also, .NET Framework is buggy on it. I had the exact same app with the exact same .NET Framework version installed on Vista 64-bit and XP 64-bit on the same machine - XP 64-bit had odd errors while Vista 64-bit worked fine.

If you can, upgrade to Vista or 7. I really can’t think of any reasons to run XP 64-bit - and I ran it for over a year.