Windows Shares Inaccessible

I have a Drobo 5N which has been rock-solid since I purchased it in 2014.
I use SyncBack to backup several Windows 10 PCs, and my backups are now failing due to “Network Error - Network name no longer available”.
During this time, I can still ping/telnet into the Drobo, but I can no longer access it in Windows via my mapped shares.
This must have been occurring since the last firmware update (currently v4.3.1-8.126.117497), and I just didn’t notice.
If I connect with the Dashboard, it wakes, but my mapped shares are still not accessible.
If I restart the Drobo, Windows can then access the shares again.

I’ve attempted various solutions posted here and around the web:

  • Enable/disable SMBv1 in the Drobo.
  • Enable/disable SMBv1 in Windows.
  • Change shared folder names.
  • Change user/pass.

Changing the Drobo user/pass is the only thing that worked, but only for about a week, as I just noticed that last night’s backups failed again. Restarting the Drobo resolves the issue as before, but only until it sleeps again.

Current config:

  • SMBv1 disabled in Drobo.
  • SMBv1 disabled in Windows.
  • Shares were renamed, then changed back to original names when that didn’t resolve the issue.
  • Have not changed the user/pass again.

Should I roll back to the previous firmware? Is that even possible, and/or will it break something (i.e., 64TB support)?
Should I disable Disk Drive Spindown? I’ve always had it enabled, and never had a problem before.
I currently have 5 x 10TB drives installed, and concerned about having them spinning 24/7.

I think I also read somewhere (can’t find the link now) that Drobo had a problem with starting SMB???

This used to be a set-and-forget scenario which just “worked”.
Now I’m concerned, and wondering if I need to look at other backup options, particularly since Drobo’s future is questionable at best right now.
Any help or advice would be most appreciated.

UPDATE

Found Drobo FW 4.1.4 broke SMB (for me). What is your experience with 4.1.4? - #17 by djdoornink and am now rolling back to the 5N v4.1.3 firmware linked there. Will report back when completed and tested.

Since I was on v4.3.1, I actually wound up rolling back to v4.3.0 instead, thinking v4.1.3 might be too far back. SMBv1 is still disabled, and I did not roll back the Dashboard, but I don’t see why Dashboard would have anything to do with this problem, as I rarely launch it.
Link to v4.3.0: http://files.drobo.com/webrelease/5N/Drobo5N_Firmware_4-3-0.zip

Hello there!

The difference between firmware 4.3.1 and 4.3.0 should be very small and would likely not affect SMB. The big change happened in 4.3.0, where Samba 4.10.6 was added.

Here are the cumulative release notes up to 4.3.1:

You’ll notice that firmware 4.3.0/1 are no longer available on Drobo’s download portal. According to Drobo support “firmware version 4.3.1 was pushed back with our engineers at the moment since we are fixing something for this update.” Nothing specific, but since you’re on this now no longer available firmware, maybe you could try opening a ticket with support to see if you’re affected by whatever bug they’re fixing?

Regards,

Dom

Thanks for the reply. What 5N firmware would you recommend running if not v4.3.0/1?

I will see if I can get a ticket started, but in the meantime, I wanted to document everything clearly for anyone else who might be experiencing this problem (as well as myself).

That said, things are still OK with v4.3.0, but need to give it at least a week, as that’s about how long things were stable with v4.3.1 after changing my Drobo creds.

I really have no recommendations with respect to firmware versions. I updated to 4.3.1 when my Dashboard recommended it and have had no problems that seem to have been specific to this firmware.

For your particular situation, I would either go with the current field tested version that Drobo is recommending, which is 4.2.1, or the last known good configuration that worked for your use case, which would be 4.1.3. That said, I don’t know if Drobo will allow you to install previous versions of firmware or what effect that might have on your data. :confused:

Hopefully Drobo support can give you more guidance.

Regards,

Dom

Issue resurfaced with v4.3.0 again after a week.
Now rolling back to v4.2.1: http://files.drobo.com/webrelease/5N/Drobo5N_Firmware_4-2-1.zip
Where is the information about what Drobo is recommending?
The downloads page does not have that version for the 5N.
Thanks again.

When I said that Drobo recommend version 4.2.1, I mean that it’s the version proposed on their download site, here:

Despite a newer version existing (4.3.x), they are not promoting it on their site.

For version 4.1.3, you can find it here:

http://files.drobo.com/webrelease/5N/Drobo5N_Firmware_4-1-3.zip

You just need to modify the links manually to match the wanted firmware version. They’re all still available on Drobo’s servers.

Any luck getting some answers out of Drobo support?

Regards,

Dom