Drobo

windows "delayed write" failed ($mft) caused v1 all 4 solid red lights (in prog)

hi guys, just posting here to let you know what recently happened…(v1 drobo) maybe just coicidence but unless i post it patterns might not be spotted :slight_smile:

hopefully it will help any others who come across a similar scenario know what i experienced (just be a bit more patient than me, as i have a 2nd drobo and might make me take slightly less time on certain steps)

status= v1 at 86% used capacity, (v2 at 84%)
and v1 has top solid red light (or yellow in dashboard) to show getting low on space.

yesterday i was preparing for some v1 to v2 backups… eg chkdsk to make sure all is ok, and then do the backups/synching etc.

each drobo has 2 volumes, (1 big, 1 smaller)
i ran chkdsk /x on all volumes on the v2 = all ok
i ran chkdsk on the smaller v1 volume = all ok
(i was using the larger volume as have firefox installed on it and was using browser so i didnt do the chkdsk there).

then later in the day (several hours later) i installed skype, and also a usb headset (which windows detected perfectly and i was pleasantly surprised at how good and smoothly it went. (maybe a bad sigh LOL :slight_smile:

it wored fine but i noticed several applications/browser windows etc were fighting for cpu power, including drobo dash/ddservice, and including skype. (my pc is fairly old so maybe it couldnt keep up with compression on the fly etc for skype)

the skype lasted a few hours (give or take a couple of reconnects etc) but the sound got a bit choppy from time to time, so i set skype to have a higher cpu priority than normal, and the sound seemed to clear up.

then after that finished (not immediately after but say within 30 mins), i suddenly got a windows alert popup (bottom right systray) saying something like “windows delayed write $mft” cant save a file please try again or something.

at that point i noticed that my v1 drobo letters would appear in the system, and all files and folders would remain visible but if i went into one, it was empty, and if i tried to open a text file for example, notepad would launch, but then say file doesnt exist and ask me if i want to save and create one (which i cancelled)

“hmmm” i thought… ive had this problem before (not with skype but that delayed mft problem), so i tried to see if chkdsk would run in read mode but even chkdsk couldnt see the v1 volume (only tried one of the volumes)
… so i decided to do a full shutdown of windows…

the v2 went to standby mode as per usual, but the v1 was still running. (as far as i can remember, it looked the same, eg top solid red, 3 greens below, and 9 blue leds) - it just wasnt shutting down into standby even when the pc was off.

i waited approx 30mins, and couldnt feel any vibes from the unit - just the fan, so i removed the USB cable from it. no change after another 30mins, so i powered it down.

gave it a few mins and then powered back up
= all 4 solid RED lights, and no startup sequence (or drive access noise) - just fan.

“hmmmm” i start to look a bit worried :slight_smile:
i do the same, wait and power down and power it up
= no change.

(then i remember, i had this in the past and i think i had to simply leave it powered off for longer…

… so this morning, i power it back on, and i get all 4 RED light - =worried look on my face x2 :slight_smile:
but just only for 5 seconds… and then it starts the usual LED capacity sequence…

then it got to about 5 leds (from middle to right), and halts…
= worried look on my face x3 :slight_smile:

then it continues, completed, and goes into standby mode (since the pc is actually still switched off).

so i start to launch windows, only to find that the v1 is still in standby, and the v2 has woken up ready to use.
= worried look on my face x4 :slight_smile:

then i remember that the USB cable is not plugged in (doh)
so i powerdown windows, and put the cable in, and then power windows back up.

v1 wakes up, v2 wakes up
windows starts loading
v2 = all blue leds reach 8 and is green and ready,
but v1 goes through the motions, all green lights but Only shows 3 LEDS (making me think its only 30% full)

hmmm (have i lost data? is it only now able to find/fix 30% of it?)
= worried look on my face x5 :slight_smile:

then windows loads up, and all leds (up to 9) are lit, phew i think…
then the top light suddenly goes RED (solid)
= worried look on my face x6 :slight_smile: (at this rate ive got more wrinkles in my face than a famous TV Chef!!) :smiley:

then i remember that its ok, because i know im low on space LOL

  • so now im currently running CHKdsk on the largest volume (with plans for the rest of them and will then do my backups)

fingers crossed the scans all go ok…[hr]
Items Of Coincidence

[list=1]
[]getting low on space (even though am below the 90% mark)?
[
]using chkdsk on another volume earlier in the day (intense chkdsking?)
[]using a USB 2 headset (plantronics) (even though it seemed to work fine)
[
]installing Skype (which force installs browser plugins and webpage popups)
[]using skype for 3hours and setting it have higher cpu priority (effectively lowering dashboard cpu availability?)
[
]keeping firefox open for whole duration (which skype also added plugins) on the volume which had the $mft error)?
[*]easter gremlins?
[/list]

still havent pinpointed it - maybe its just windows but interesting enough - drobo is looking like its recovering :slight_smile:

The type of the file system is NTFS.
Volume label is DROBO.

CHKDSK is verifying files (stage 1 of 3)…
File verification completed.
CHKDSK is verifying indexes (stage 2 of 3)…
25 percent completed.

fingers crossed…[hr]
CHKDSK is verifying indexes (stage 2 of 3)…
Index verification completed.
CHKDSK is verifying security descriptors (stage 3 of 3)…
5 percent completed.[hr]
CHKDSK is verifying security descriptors (stage 3 of 3)…
Security descriptor verification completed.

there seems to be about 1598 files (more than my last Cathy catalogue - so all is looking well)
now to pick a file at random… it works :slight_smile:

COOL :slight_smile:

3 out of 4 backups successful so far…
working on 4th and final one…

all backups complete - even installed a new game on it and played it :slight_smile:

still not sure what caused the disconnect/write failure - maybe skype and usb headset overloading the usb bus but while that mystery continues… i’ll play another game and plan out my Upgrade Path from 4xWD10EADS into ultimately 4xWD15EADS

If you have a self-powered (one with a power plug of its own) USB hub, try plugging the headset into that. A lot of systems have marginal USB bus power and the bus will go crazy if the power draw exceeds the available.

My desktop is like that… so I plugged a powered hub into it and all is good.
I guess I have a reasonable USB draw though - Bluetooth dongle, USB card reader, M-Audio FastTrack, bus-powered speakers, bus-powered KVM… yeah, probably the FastTrack takes some power, heh.

interesting Bhiga, i have a usb mouse, keyboard, usb hd enclosure, gen1 drobo, gen2 drobo, a powered hub(7-in-1) with wireless ‘net’ connector, 2nd hd enclosure, M-audio (midi connector), temporary mp3/digicamera connector, and temporary headset for when using skype - LOL maybe its overloaded :slight_smile:

someone suggested a soundcard headset (eg using 2 jacks instead of usb)[hr]
whats the fastrack? sounds funkay

@Paul - if your powered hub is of the 7-port variety, that might be a source of craziness.

Many, but not all, 7-port USB hubs are actually two 4-port hubs cascaded internally. Usually it’s not a problem, but I’ve had numerous issues with devices on the “second level” four ports of these. It’s 3 primary ports (on the main hub), and 4 secondary ports (on the cascaded hub).

There are 7-port hubs that are single-chip hubs though, as NEC makes a 7-port USB hub chip.
So far I have found two 7-port single-chip hubs - Cyberpower CP-H720P and the Inland model 08334.

I found the Cyberpower one at a retail store by carefully looking at the internals - score one for transparent cases, which I’m normally not a fan of, heh. The Inland one I just found by coincidence.

Happened to embark on this journey because my Silex USB device server doesn’t support cascaded hubs, then ran into issues with cascaded hubs on my desktop machine as well. Note that many 7-port USB expansion cards are also do the two 4-port hub thing.

M-Audio FastTrack I can’t really make music, but I have aspirations, haha. :slight_smile:

Personally I think anyone that uses a wireless USB hub has a death wish :slight_smile:

I’m kidding but my experience is that anything wireless = trouble, at some level. I’ve never tried one of those new fangled wireless USB devices because I don’t have a death wish, but what do I know? :slight_smile:

I think Paul meant he has a wireless adapter plugged into the hub… but I could be wrong. I too have far more faith in the hard wire. :slight_smile:

ah oops i meant wirelesss net connector :slight_smile:
(the 7-in1 is a powered and wired usb)

thats interesting, i’ll have to find out what make mine is, as am not sure if its 2x cascaded 4’s, but i often get popups saying “this device could work faster if plugged into a usb 2.0 port” message.

the actual Drobo’s (v1/v2) both go straight to the back of the computer’s usb ports

(just fyi, over the last couple of months ive been using drobo with games and skype for several hours and the issue hasnt been seen again - even with the same usb headset… still havent pinpointed the main issue but just to update this post).

Interesting… Another data point to add…

USB issues can sometimes be software-related.

Case-in-point…
Over the weekend I nuked my WHSv1 machine and installed WHS 2011 (aka WHSv2 aka Vail).
At some point, I decided I was clever and tried to enable “Optimize for Speed” in the Device Manager properties for the Drobo.
The system sat at the hourglass for a minute or so. I thought “Hmm, this is odd.” And I unplugged the USB.
Drobo’s lights went dark.
A few minutes later the system was still hung, so I rebooted it (through normal Start menu, not a hard reset).

Drobo’s lights came back on, but with 3 green, and the bottom solid red. “Hmm, this is VERY odd.”
Waited for Windows to come up…
Drobo Dashboard says No Drobo detected.
“Uh oh…”
Unplug Drobo, plugged it into a different USB port. Showed up as “Unknown USB device.”
Did a pin reset on the Drobo (I had already backed up its content).
Same deal.
Tried a different USB port.
Same deal.

Finally tried a different machine.
No Drobo detected. Bottom light solid red still.
Power cycled Drobo.
Drobo came up fine - all green lights.
Drobo asked to be formatted (proving the pin reset had worked).
Formatted the volume.
Shut down the machine and rebooted Drobo.
Came back up fine.
Did it again for good measure.
Came back up fine.

Connected Drobo back to the original machine.
Unknown device and red light at bottom.

Concluded I had somehow, some way, really messed up the USB device enumeration on the machine. What surprised me though, was the fact that somehow, connecting Drobo to this “messed up USB machine” put Drobo into an undefined state that only a Drobo power-cycle could clear.

Cleared and reinstalled WHS 2011 from scratch again, being careful not to be clever and change anything in Device Manager this time…
Drobo is fine. Drobo has been fine.
I’m fairly convinced that had I skipped the pin reset, disconnected Drobo from the “problem” computer, power cycled Drobo, and then connected it to another machine, it would’ve been fine.

Moral of this really long story: DON’T mess with the device’s performance settings in Win7!

yikes - its a funny feeling when you start thinking of the “uh-oh’s” :slight_smile:

sometimes its also worth powering down the windows machine, (which should stop usb signals going to the drobo) and then to restart windows (or powercycle both) i wouldnt have tried the pin reset at all just yet but that is just me) :slight_smile: