Drobo

Windows can't boot after update Drobo S to 2.1.0

Hi, today I decided to update my Drobo S (1st generation only USB2.0) plugged with eSATA to the last 2.1.0 firmware, it rebooted, everything was ok, later I shut my computer down (Drobo S went standby). In the afternoon I booted up my computer (windows 7 x64) well it was stuck on the “nice” windows logo and the activity light of the Drobo S was solid (colorwise), no blinking, no noise from any drive (drobo or computer) so I just switched off the Drobo S by pressing the switch…and oh my windows continued to boot, then I switched on the Drobo S and it came online in windows.
So I decided to do it again (4 times…yes I have time to waste) and wait longer but after 30 mins windows didn’t boot up, so I did the same thing (switch off Drobo S, waiting for windows to boot and switch on Drobo S)
Is there a way to downgrade???
Does somebody has the same problem???
I read on the forum that some people have a looping problem, can it be related??
It’s very annoying, I need to crawl under the desk each time…

Thanks for you answers :slight_smile:

Which version of the Drobo Dashboard r U using?

The last one :slight_smile: 1.7.30095
But why does it matter? the problem is before Drobo Dashboard launches itself. The problem is at the boot, during the starting up of windows (when you see the windows logo glowing)

So nobody has a clue?

It sounds related to the same delayed startup problem that happens on USB connection with my Drobo v2.

Strange thing is, the delay is different depending on what machine I’m hooked up to.

Back on my Vista x64 desktop (now retired) it took 20+ minutes. On my WHS machine, it takes about 15 minutes.

It seems to depend, at least partially, on the speed of the machine.

Is your Drobo S provisioned as a 16 TB volume?

Yes it’s a 16TB volume, but it was booting very fast, let say in a delay that is acceptable, but after the update…stuck, I waiting 30min+ but nothing…
Thanks for sharing your experience :slight_smile:

Just tried out to boot on a fresh Ubuntu 10.10 release and guess what??? yes stuck too at the boot screen (Ubuntu with the dots going on and on)
The activity light is solid green on the Drobo…well at least now I’m sure it’s the update that is creating the problem…

Is there a way to downgrade???[hr]
By the way no prob at all with USB…well little bit slower to boot up but at least it’s booting up!!

Here is a fix for you.

In your computer’s BIOS set the disk type from “IDE” (default)
to “AHCI”
or
if using an Intel motherboard “Raid” (recommended
by Intel for greater flexability).

This will also cause your sata contoller to use a different
driver so be prepared. It is recommended to re-install the O/S.

You will have to assess your need vs re-install, however this will
fix your boot problem.

Linux will automatically detect the change, no problem.

Windows will not, and will hard lock / blue screen on boot.

The preferred way is to reinstall Windows, but this is not necessary. You can make the change manually in the registry.

The methods and changes are a little bit different based on the version of windows you are using, but for Windows 7 you do it like this:

  • run regedit.
  • go to HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Msahci
  • right-click Start in the Name column, and then click Modify.
  • In the Value data box, change the number from 3 to 0, and then click OK.
  • exit the registry editor.

Reboot the machine and enter your BIOS. Change the BIOS setting to ACPI, then let the machine boot back up into windows 7. Windows 7 will detect all your drives and reinstall drivers for them. After another reboot it will be all set.

I did this when I needed ACPI (for a different reason) and hadn’t installed it the first time around, and it worked beautifully for me. I don’t know if it will solve your freezing problem on boot, but it might be worth a try.