Windows 10 - Unable to get Drobo 5D going via USB 3

I have spent the best part of a day trying to get my Drobo 5D working

My Drobo 5D started life as an HFS+ system on my old Hackintosh

I just migrated to Windows 10 and wanted to format it to use on this system

The Drobo Dashboard can never format the unit as NTFS - I get the “formatting failed, try again if this doesn’t work restart” error - this never resolves

I tried formatting using disk management and both assigning a drive letter and also not assigning a drive letter

Either way if I can see the drive I can’t copy anything to it - or worse even - I can’t even see the volume in Explorer.

I have the latest firmware on the drobo and I am running dashboard 2.8.5

I can’t seem to find any install guide anywhere in these forums or outside for how to setup a 5D on Windows 10

Can anyone help?

thanks in advance

Further to this I have done an erase and complete restart and initialisation of the Drobo - this gets me a volume I can see in Windows but I cannot copy to it.

If I try to copy a folder then the root folder gets made but after timeout nothing is copied into it. I get a message “An unexpected error is keeping you from copying the file Error: The Semaphore timeout period has expired”[hr]
Solved my own issue

Took a look at the back of the machine where the drobo is plugged in and realised I had plugged it in to a USB 3.1 socket - not the 3.0 sockets - hey, it’s dark back there - swapped it out for a 3.0 socket and it’s happy as anything.

I’ll leave this here in case anyone else makes this silly mistake

hi jack thanks for posting your latest issue and its good that you were able to fix it.
(hopefully no more coldsweats) :slight_smile: - but cold sweets could be nice :smiley:

I have the same problem of not writing data to the Drobo 5D. I can copy from the Drobo 5d to any other internal drive in my windows 10 machine but can not write data to the Drobo 5D. Why Not. Is it a security issue with the drive or what?

I can confirm that this is true. When connected to 3.1 USB ports you can not move files to the Drobo, but can read from it. I just spent 2 days trying to figure out what happened with my Drobo. I was ready to return my unit (that I had just bought a week ago). Finally, I stumbled upon this thread and tried switching it to a standard USB 3.0 port, and everything is working now.

I contacted support and they said that 3.1 ports are still usable, but that the transfer speeds would be the same as 3.0 speeds. There is obviously more going on than just that. Clearly, something in the 3.1 architecture is preventing them to read/write properly.

Hopefully. someone will look into this and correct it soon.

Also, I have Thunderbolt ports on my Windows system and am hoping they will add Thunderbolt support soon for even faster transfers.


hi according to this page, and if i didnt misunderstand it, usb 3.1 does seem to have the same max speed as usb 3 (though they refer to it as gen1)
i think it might have been a bit easier to have usb 3.0, usb 3.1, and usb 3.2 (rather than usb 3.1 gen 1 referring to usb 3.0 as its all a bit confusing).

a lot of computers or port have the connector in Blue, (to help define if the usb port supports usb 3.0) but not all manufacturers are required to have blue ports officially.
can i check if your port is blue, and if there are any symbols or logos for it that you can see?
(i think superspeed means usb 3.0 / 3.1 gen 1, and superspeed+ means usb 3.1 gen 2 though am not 100% sure)

depending on your operating system, can you see in device manager or another equivalent tool, to see if your computer is recognising the drobo on a particular usb connection, and in case it is showing any incompatibilities or errors?

there is an older page with some info for windows for finding device manager here that might help too:

Hi, I’m experiencing something like this here. Moving from Mac OS X to a Dell XPS 15 4K with Windows 10. Software and firmware are up to date, but the system can’t hold a stable connection. It connects and disconnects a few times per minute. I already reset the Drobo and it’s all green.

The cable and everything is alright, because it works perfectly fine with the Mac.
The Dell only has 2 USB3-Ports - One doesn’t at all with the Drobo and the other one has the problems mentioned above. Both ports work fine with USB-Sticks or an external SSD-Drive.

Probably I’ll have to try a hub or an adapter, because the Dell has an USB-C-port I could utilize for that. Or does somebody has another hint or solution?

Coming back to Windows after 8 Mac-years. Didn’t take too long to experience serious problems :frowning:

Thanks in advance,

Problem solved kinda like jackscoldsweat did:

Bought an adapter to transform my USB-C-Port into a blue USB3-Port and now it works.
Thought USB is there to be a “standard”.


thanks for your input bj0ern