Drobo

win server 2008 hangs on eSATA boot

Got my new eSATA setup going with a Windows Server 2008 box fine when I hot-plugged it in and set it up, but now when I reboot the box it hangs at the black logo screen indefinitely. I let it go for as long as 12 hours so far, just in case it was some kind of initialization problem. The drive works 100% fine if I plug it in after rebooting, but being a headless server this is obviously a big problem. Any suggestions?

Change boot order in BIOS. Make sure your real boot disk is the first.

I should have been clearer: I get past the BIOS boot and it gets stuck at the Windows boot screen. (The boot drive is already first in BIOS)

Hi Coreyh, I’m getting the same issues.

My boot priority is set to use the internal HDD, then OD, then esata - it seems to skip the first 2 and go to the esata connection first, even if the bios is told to use the others before. I have to wait for it to work out that it can’t boot from that drive before I can hit F1 to move on. Frustrating.

I’ve tested it on 2 net-tops and both do the same thing. Asrock Ion 330HT if it helps.

Cheers

Sometimes “Internal HDD” also maps to the SATA/eSATA.

Check to see if there’s a preferred option inside/behind the Internal HDD setting.

Cheers bhiga, I’ll have another look-see and report back.

EDIT:
Negatory Batman.

1st boot priority was set to internal HDD ST250315AS
2nd was set to DVD drive.

No 3rd or 4th option, no option to disable esata boot (or enable it). There is also no option to choose which sata device has priority (aside from the 1st and 2nd boot listed above). I swapped the boot order in an attempt to confuse it into “Nope, no DVD in the drive, i’ll go to the next HDD in the boot order” etc.

Disconnecting the Drobo S means it boots much quicker and with less mashing of the f11 boot option key.

If you see this pic taken ( http://i45.photobucket.com/albums/f74/Bennamin/photo.jpg ) it mentions the 4th disk, primary HDD as number 1, optical drive as 2, spare sata port internally as 3 and esata (i’m assuming) as 4. I have no idea where to go next aside from harassing the guys at Asrock.

More bios screens can be found page 35 of the manual:
http://www.asrock.com/nettop/manual.asp?Model=ION%20330HT

…Starting to think I should have started my own thread.

Cheers

If there’s an option for “Boot Other Device” try disabling that.

Looking at your BIOS screenshot, it sounds more like the SATA controller is in Legacy IDE Emulation mode and is somehow looking for an IDE Slave drive?? It’s confusing…

I would tell you to switch your SATA controller to Native AHCI mode, but that’ll still end up with you not being able to boot into your Windows install as it won’t be able to find the boot device and you’ll get a BSOD with INACCESSIBLE_BOOT_DEVICE error.

Last one… In the Main settings of your BIOS (where you set the date/time), what is the “Halt on Error” set to? Try setting it to None, but keyboard/mouse or None. That should skip having to hit F1 to continue, though it won’t get rid of the delay in it “finding” the error. Enabling Quick Boot might get you past it, though I believe Quick Boot still does the device detection, where I think you’re getting hung up in.

Eureka!

Enabled AHCI by doing the regedit trick from here:
http://www.ithinkdiff.com/how-to-enable-ahci-in-windows-7-rc-after-installation/

Enabled AHCI in BIOS and now it boots fast without even trying to hit the DroboS.

Just FYI, there is no option to disable other boot device, one of the first things I looked for as i’ve been stung before with that :slight_smile: Thanks though.

You’re a star bhiga. Thanks muchly.

You’re very welcome. Glad it’s solved.