Drobo

why wont it rebuild

drobopro, single disk redundancy

was 5 x 1.5tb + 3 x 2Tb

i needed to “borrow” a disk, so pulled a 2tb drive

now its

5x 1.5tb and 2 x 2tb

4.99 TB used (58%) and 3.62TB free (42%) - 8.62Tb total

so why isnt it rebuilding to a safe state on the remaining 7 drives

jennifer?

it just says “your data is at risk add an additional drive”

Is it rebuilding at all? or just taking forever?

no, its not rebuilding

thats why it says “your data is at risk”

if its rebuilding it says “protection in progress”

all the lights on the drives are a solid green,with a red light in the 8th slot where it wants me to add a final disk.

the pie chart showing how much space i have is red

Have you tried rebooting the DroboPro?

yes, several times, and the pc,[hr]
i suspect its probably related to the post i made elsewhere where it cant recognize what partitions it has, i think although its less than 50% full it probably doesnt realise!!!

see here http://www.drobospace.com/forums/showthread.php?tid=548[hr]
during startup it initially shows the correct amount of used space in the pie chart (this is before any partitions show in windows)

then as it starts to mount partitions, it shows totally free… then the amount of used space grows for each partition it mounts

however dashboard can only see one partition properly for some reason (and even then - as in my other post - it doenst have the details right!)

the other two partitions dont show (in dashboard) as having drive letters, or volume names and the used space is just shown as “-” and the partition sizes are wrong

curiously windows explorer sees everything fine and it all passes a chkdsk and the files playback fine

im just going to remove all the data from drobo and do a reset on it, that should sort everything out (i hope!)[hr]
ok so having removed a bit more stuff, and restarted again (both DP and my PC!)

drobo has 4.36 TB of stuff on it and 4.25Tb of free space

and STILL wont initiate a rebuild

i think what is telling though… is that briefly after it restarts the pie charts shows that it has 7.5TB of data… before it falls back to the correct setting (it really does have 4.5tb on there) so i thikn it is confused about how much space it has, for some reason?[hr]
and now that i put a bit of load on it - the pie chart has stopped reocgnising onf of my partitions - and thinks i only have 970GB of stuff on my drobo (again the “missing” partition is still working perfectly in explorer and im watching a movie off it right now!)

ok someone explain why this isnt rebuilding:

http://picasaweb.google.co.uk/lh/photo/mxFtloQ1iWIpwPCZ5U92IQ?authkey=Gv1sRgCP-8s8aD_8_vuwE&feat=directlink

Did you try running Chkdsk on the unit? I’m wondering if the volume bitmap is out of sync and that’s confusing things.

chkdsk wont complete on volumes of 8TB or 16TB (for me at least)

i have no idea why.

I think… the only way left for me to trouble shoot this, is i will make a new volume, move everything from this volume (which drobo doesnt recognise correctly) to the new volume

delete the suspect volume

and see what happens!

I’ve never seen chkdsk not work with 8 or 16TB.

interesting, its never worked for me on win 7, x86 and x64, iscsi and USB

what do you think of my screenshot ?

http://picasaweb.google.co.uk/lh/photo/mxFtloQ1iWIpwPCZ5U92IQ?authkey=Gv1sRgCP-8s8aD_8_vuwE&feat=directlink

surely that should be rebuilding by now?

You were never prompted to format your 2nd volume?
Can you format that unallocated space in disk management?

i did have a second volume, but like the first it was not detected by drobo correctly, so in an effort to prove to drobo that it had more free space i deleted it via “manage volumes”

Disk management does see several other volumes, all “uninitialised”, if you try to initialise them, it says they failed CRC check.

ok well to put an end to this story, i tried to format the addition volumes in disk management and it caused my drobopro to reboot…
and hang…
it woudlnt finish booting
even from totally cold power off
and without being plugged into any computer or network
it got to the 8th blue light of the booting sequence, then hung there, for hours

in the end i simply gave up, did a reset, lost 3.5TB of data (the stuff i can replace - im not stupid!)

so from a factory reset ive put my 3 volume back on it, and im now busy refilling it.

For future refrance if your going to pull a drive pull a smaller one. By default larger drives are used for relaying processes. Hence why when you slap a smaller drive in 9/10 it won’t relay any data.

did you read what i posted??? it would make zero difference, it had plenty of space left to relayout!

and its not 9/10… the whole idea behind drobo is that if a drive dies or you remove one - as long as it has the free space, it will automatically re layout back to a safe state. since i had over 4tb free it could have easily relayed out.