Why is 800FS so slow on AFP

Yes, I have read all the posts here, but it is still slow.

Why does an upload crawl to 8KBs/sec?
I’ve run netstat and like but there is nothing wrong.

I’ve got 6x 3T in it with fixed IP. I’ve tried changing MTU auto, 1500, 9000, nothing seems to budge it.
What are your experiences?

I’ve noticed mine goes about 40MBs - 80MBs (highest I’ve seen is 115MBs)

but the speed really depends on a lot of things.
8KBs - 60MBs if transferring a iPhoto Library (most likely due to the thousands of small files in an iPhoto Library)
60MBs -90MBs transferring a compressed file

I also tried the MTU settings to see if they’d help but unfortunately I don’t know enough about that to probably set it up properly.

For what its worth all my drives are SATA III and 7200rpm. Those speeds posted above are all from external USB 3.0 drives to the B800fs.

I upgraded (thought it was an upgrade0 from a Drobo Pro to a 800fs.
The 800fs is a lemon, its taking days to transfer 250gig I’m two days in and its only about 1/2 way.
Any thoughts its directly connected to my Mac Pro (2015), has the latest firmware etc.
I’m about ready to throw the thing away and wonder if the 800i would have been a better option.
Trouble is the “find the drobo for you” part on the drobo website suggested this unit.

Hi just wondering what OS you are using (Apple, Microsoft) also what version of dashboard, and did you load a iSCSI initiator at all?

im interested too, on windows i can only get between 30 and 50MB/sec at the best, can AFP protocol be used on windows?