Where is Dropbear?

I just purchased a Drobo 5N. According to the Drobo website, Dropbear is included in the dashboard. But the Dashboard doesn’t list Dropbear among its apps. It only lists 13 of the 18 apps shown at http://www.drobo.com/drobo-solutions/drobo-apps/

Where can I get Dropbear, or another SSH daemon?[hr]
Never mind, I just found the OpenSSH app.

yes, OpenSSH is located here.


Dropbear can be accessed from this link.


Drobo Support

I dropped OpenSSH (openssh.tar) from provided link into the DroboApps folder (with Mac OSX Finder). Then rebooted. DroboApps folder now not there.

What happened? How to get back? I did a full factory reset, and still not there.

Somehwere are there simple instructions to install DroboApps. I bought this box as it appeared from web site that it was simple to install these things. It appears no different (except harder) than if I had put onto my Linux server.

I’m finding it to be a bit of a learning curve. Some of the apps are easier to install than others. I had to do some fine-tuning to get sudo to work, but rsync and openssh dropped right in.

Make sure you download openssh.tgz, not openssh.tar. The tar file is the source code, the tgz file is the compiled binaries. Drop it into the DroboApps share, reboot the Drobo, then you should be able to SSH in as ‘root’. Default password is ‘root’ - be sure to change that right away.

I put *.tar into the DroboApps folder. Sigh. I didn’t know there was a difference!! Didn’t pay much attention. Geez.

I rebooted, result was disappered Droboapps folder. I can’t tell if it is invisible, or is deleted. Cannot connect to the Share, nor login.

I’ve now reset to Factory Settings (twice) and still no return of DroboApps folder.

I found the DroboApps folder. It was “hiding” from Finder. I could see it from a Windows machine. So i changed the Admin password to somthing I knew, then in Finder (on Mac) connected to smb://Drobo5N (with no share specified) “as” Admin, giving pasword, then in invited me to connect to either Public or DroboApps. So connected to DroboApps.

I recall before all these issues that the DroboApps folder was not hidden, but maybe it was. Dunno.

Now I will go install openssh.tgz (not *.tar) file…

(I really got the impression from Drobo adverts – MacPowerUser, especially – their web site, and the Drobo Dashboard, that these Apps were trivial to install. This is why I bought the thing. Fooled again).

Well, to be fair the apps available from the Drobo Dashboard are pretty simple to install.

“pretty simple to install” … agree, if you put your mind set that you use “simple” Linux/Unix type installs. I have that knowledge and experience and was hoping to avoid all that by just buying a Drobo and click on the Apps on the Dashboard.

Ok, Crashplan may be the exception. My experience with the others was pretty straightforward.

Are there pros/cons to using either OpenSSH vs. Dropbear?

Crash plan seems to not work any more. It looks like they updated to 3.7.

Dropbear is included with the firmware, and is very small (i.e., uses very little memory). OpenSSH is a third party app, it includes everything that you could possibly want from an SSH server, but it uses a bit more memory.

I am new to Drobo and am having a bit of trouble getting sudo to work, myself. Could you please elaborate on how you resolved this?

Thanks in advance.


Hi Ricardo, I am looking for the script: root_passwd which was in the dropbear app. I can’t find that.

Sorry, I don’t know where the script is gone.