Version that works with MacStudio?

The current Drobo Dashboard installer 3.6.1 crashes on launch on a new MacStudio Pro. Appears that current runtime libraries are newer. Is there an update for newer Macs running 12.3.1?

My understand is this issue has been resolved, correct?

Yes. I noticed in the crash log that there was an issue with the versions of libraries installed. I also noticed the build number of the MacStudio version of the OS was different than my old MBP, which worked fine. I booted into the recovery partition and reinstalled 12.3.1 and then the Dashboard installer was able to run and install Drobo Dashboard.

Thank You for the details, much appreciated!