Drobo

using rsync?

I’d like to use rsync to backup a client to a droboshare via ssh. I’ve installed the ssh and rsync apps on the droboshare. SSH is fine, but I can’t seem to get rsync to work on the droboshare. Where would I find the rsyncd.conf file to edit? Is anyone doing this now and is willing to share the command to do this? My client is an OS X 10.5 system running rysync 2.6.9

What about using keys to automate SSH logins on the droboshare?

Thanks.

Here is the error I’m recieving on the client:
rsync error: unexplained error (code 255) at /SourceCache/rsync/rsync-37.3/rsync/io.c(452) [sender=2.6.9]

While running this command on the client:
rsync -aEe ssh --delete --progress /var/root root@192.168.100.229:/mnt/DroboShares/Drobo1/test

where 192.168.100.229 is the droboshare

What am I doing wrong?

There is an error in the rsync conf file that is packed in the droboapp distribution. It is read only, you need to edit it to allow writes. I sold replace a Drobo/Droboshare with a Drobopro, so I don’t know it I have the fixed conf file. Let me check, it will probably be sunday before I have time.

Here’s what’s in my rsyncd.conf file. I edited it based on instructions from:
http://www.backupassist.com/blog/support/howto-configure-a-drobo-droboshare-as-an-rsync-server-for-remote-internet-backups/

/mnt/DroboShares/Drobo1/DroboApps/rsync $ cat rsyncd.conf

[code]uid = root
gid = root
pid file = /var/run/rsyncd.pid

[drobo1]
path = /mnt/DroboShares/Drobo1
comment = Drobo Share 1
read only = false

[drobo2]
path = /mnt/DroboShares/Drobo2
comment = Drobo Share 2
read only = false
[/code]

Seems like there are a lot of people looking for a solution for remote backups to the droboshare. Rsync is the best option, but I can’t get it to work. I’ve tried ftp remote mounting the droboshare using macfuse and macfusion, but am running into multple FTP errors, so am assuming pureFTP is too lightweight to do this. I can’t do it using SSH…

Has ANYONE managed to get rsync to work? Has ANYONE managed to backup to a droboshare across an Internet connection?

Most other NAS solutions have these options, and they work. I’m starting to get discouraged…

Okay, guys. I got RSYNC to work.

Background: I’m trying to rsync files from one drobo to another, both connected to the same DroboShare.

Here’s what I had to do:

  1. Install Dropbear SSH so I can SSH into the DroboShare: http://www.drobo.com/droboapps/downloads/index.php?id=18.
  2. Set up the rsync.conf file. I added read only = false after each drobo entry and add the correct path for each of my Drobos.

Here’s the entire file:

uid = root
gid = root
pid file = /var/run/rsyncd.pid

[drobo0]
	path = /mnt/DroboShares/Drobo
	comment = Drobo
	read only = false
	
[drobo1]
	path = /mnt/DroboShares/HAL9000
	comment = HAL9000
	read only = false
  1. Modify the rsync-start.sh file. I had to add the app directory. Here’s the entire file, as modified by me:
#!/bin/sh
APP_DIR=/mnt/DroboShares/Drobo/DroboApps/rsync
nohup $APP_DIR/rsync --daemon --config=$APP_DIR/rsyncd.conf --log-file=$APP_DIR/rsyncd.log > /dev/null &
  1. SSH into the Drobo using Terminal on my Mac. Info about SSH here: http://lmgtfy.com/?q=ssh.

  2. From the command line (SSH’d into the DroboShare), run the rsync-start.sh file to start the rsync server. I had to use the ENTIRE path to run this, i.e., /mnt/DroboShares/Drobo/DroboApps/rsync/rsync-start.sh.

  3. Run rsync with the ENTIRE path/to/the/app. (I know, there’s some way to add the /path to the terminal environment, but I can’t remember how to do that.) In my case, the command looked like this (all one line):

/mnt/DroboShares/Drobo/DroboApps/rsync/rsync -vrh --stats --progress /mnt/DroboShares/Drobo/Archive /mnt/DroboShares/HAL9000/DroboBackup

To learn about the rsync options I used (and all the other options available), see: http://www.samba.org/ftp/rsync/rsync.html.

Feel free to post any questions you may have! I’m not an expert, just a guy who got it working.

Best regards,
Andrew


Shinn Photography
site: www.shinnphoto.com
blog: www.shinnphoto.com/blog

I’ve edited my file, but when I run the above command, I get:

/mnt/DroboShares/Drobo1/DroboApps/rsync $ /mnt/DroboShares/Drobo1/DroboApps/rsync/rsync-start.sh -sh: /mnt/DroboShares/Drobo1/DroboApps/rsync/rsync-start.sh: not found

sigh…

But nice work non the less, I’m jealous. What I’d really like is to be able to rsync via ssh to a remote host (or have the remote host rsync via ssh to this droboshare)

Thanks for the post.

Have you opened the rsync-start.sh file in a text editor and added the path to the application, so it knows where to find everything?

Also, when you are in that folder (/mnt/DroboShares/Drobo1/DroboApps/rsync) and you run ls, you DO see the rsync-start.sh file, right? I’m racking my brains to make sure I didn’t leave out a step. I documented it all after the fact when I knew it worked, instead of writing stuff down as I went.

I haven’t gotten too fancy with transferring stuff quite yet. I’m just moving files from one Drobo to the other. Actually moving files from or to a remote host seems a little more complicated, but I’m sure it’s possible working step by step.

Good luck,
Andrew

Yes I edited the file, and yes the file is there. No clues as to what is wrong…

Frustrating. Thanks for the comments.

Thank you Shinnphoto, your info was very useful to get it working.

I make the backup starting rsync from a linux box to a drobo machine like this:

rsync -av --progress --rsync-path=/mnt/DroboShares/Drobo500/DroboApps/rsync/rsync -e ssh /var/www/webs root@drobolti:/mnt/DroboShares/Drobo500/wmelon

Its very important to specify correctly the --rsync-path

Greetings

Thanks, this helped me out too.

Hello,

I am trying to use rsync http://www.drobo.com/droboapps/downloads/index.php?id=12
According to shinnphoto post I edited DroboApps/rsync/rsyncd.conf and added read only = false
In addition I edited the DroboApps/rsync/rsync-start.sh to put the full path APP_DIR=/mnt/DroboShares/Drobo/DroboApps/rsync

The rsync daemon is up and running, if I nmap the droboshare I get 873/tcp open rsync

But if I rsync -avz tmp/ root@drobo:/mnt/DroboShares/Drobo/test
sh: rsync: not found
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: remote command not found (code 127) at io.c(600) [sender=3.0.6]

What am I doing wrong ?

Thank you

That seems way more elegant than the way I specified the RSYNC path, Felipbou. Thanks for sharing!

  • Shinnphoto

[quote=“felipbou, post:10, topic:500”]
Thank you Shinnphoto, your info was very useful to get it working.

I make the backup starting rsync from a linux box to a drobo machine like this:

rsync -av --progress --rsync-path=/mnt/DroboShares/Drobo500/DroboApps/rsync/rsync -e ssh /var/www/webs root@drobolti:/mnt/DroboShares/Drobo500/wmelon

Its very important to specify correctly the --rsync-path

Greetings
[/quote][hr]
Hi, Lauren,

Did you try specifying the full path to rsync? I did that by referring to it by the full path, (/mnt/Droboshares/Drobo/DroboApps/rsync or whatever) when I invoked the command , but Felipbou suggested using: --rsync-path=/mnt/DroboShares/Drobo500/DroboApps/rsync/rsync as a flag, which seems way more elegant.

I hope this helps!

  • Shinnphoto

Hello Shinnphoto,

Yes it is working great now thanks.
I just would like to know how can I,

  • rsync from remote machine to droboshare rsync demon w/o password prompt ?
  • rsync incrementally ? (i am currently reading some documentation about that but for instance --backup option does not seem implemented with droboshare rsync, right?)

Thank you
Laurent