Drobo

Using Drobo FS with Linux

Greets all!

New to the world of Drobo but a fairly experienced Linux user… Recently purchased a Drobo FS and am so far using it happily with Linux. I am wondering if there are any other users out there in the forums that are using a FS with Linux and, if so, wondering if they’ve encountered any issues/gotchas.

The only issue I’ve run across so far was, of course, not having a Linux-native dashboard app. However, installing it in an XP Virtualbox instance did the trick. Has anyone tried it with Wine? =]

Anyway, great job, Drobo folks, on making a nice product! Looking forward to countless months of happy Drobo FS ownership.

i run my FS in a multi-platform household and have it mounting onto a few linux boxes just fine via SMB. haven’t seen any problems yet moving files back and forth to it.

I recently tried to access my Drobo FS from a Linux machine, but it was unable to do so. It appears as “SFTP File Transfer on DRobo-FS” in the Network, however the connection was refused when I tried to access it.

Do I need to format the drives in ext3? If so, would this allow for cross-platform access?

My Drobo FS automagically set itself up as EXT3… I created one share and mounted it using samba like I have done with other shares on my home network. It worked just like a typical samba share for me. I’m fearful of that “16TB vs actual size” thing tho. Might have to set up some sort of cron job to keep track of things and remount read-only after passing some threshhold…

I’ve tried using Dashboard with Wine, however the connection screen never appears.

When I tried running it in a XP Virtualbox, it displays the connection screen but never locates the Drobo.

That’s a bummer about Wine … Wonder if there’s an easy fix/workaround… Unfortunately I’m lacking in in Wine hacking skills.

Regarding getting it to work in VBox, try setting your network adapter to ‘bridged’ mode.

That did it! Thanks for the tip, I might be too tired to be working on this now…

Sure thing. Please post if you figure out how to get it working in Wine. Until there’s a decent web admin tool, it’d appear we’re stuck with Dashboard via VBox. =|

Good day fellow tux users…

This is a good start and maybe we can get a sub category going just for “linux” users. My background… I run nothing but linux at home… moving from Mandriva, to SUSE and currently settling on Ubuntu 10.4. I hate winblows and refuse having to rely on it. I bought the Drobo FS because of its simplicity and because it uses a linux OS… what I did not know was the lack of linux support if you will…

Any ways, what I currently have set up on my Drobo is the following: Firmware 1.0.4, 4x 1 TB Hard drives (running dual redundancy), loaded droboapps with apache web server, droboapps admin, ssh and nfs.

Biggest thing I did not like about the Drobo FS was that for being a “networked” device… there is no web based admin page. That is a huge fail. Instead of relying on the “dashboard” program (which currently is only for winblows and mac), they could of had a web based admin page that could be managed by any OS (although I have read some people have gotten together to build a possible web based admin page… hopefully this is going well).

My current work around for relying on the “dashboard” program is to ssh into my drobo and execute commands… which I was wondering if any one else has been doing the same???

Otherwise, this little box is working great. Plug drives in, lights go green, I can access my files and stream. Still working on rsync though. DroboApps is also a HUGE plus for this little box and the fact it is a linux OS makes things easier for me to go in and admin things through SSH (which would have been nicer to have a web based admin page… can’t get everything i guess).

Any ways, wondering if any one else admins the drobo through SSH??? any one know the command that will actually shut the drobo off??? halt seems to shutdown the software, but the lights and fan still stay on…

Jim!

Hi all!

I got my DroboFS up and running yesterday. I have installed ssh, fuppes and ftp on it so far.

I must say I agree with preacher. It really should have come with apache pre-installed and a web based admin tool. Instead I had to go through the hazzle of booting Windows in VBox to get started. Is it at all possible to set up this wonderful little box in a Linux only environment? I mean - to get ssh up and running you’ll have to enable droboApps, but it might be a setting for this somewhere which can be reached via samba?

Maybe “someone” should write a Linux & Drobo HOWTO? How to set things up and configure it without using the Dashboard (if possible). F.ex. the samba config seems to be under /mnt/DroboFS/System/samba/conf/smb.conf, but is it safe to edit shares etc. in this file, and will the results be as expected?

I haven’t found any way to shut it down through ssh, but it seems that just flicking the powerbutton shuts it down - if it’s done in a proper way, I don’t know… :slight_smile:

Does anyone know the status of drobo-utils and support for DroboFS?

  • Håvard

I don’t think it’s possible to setup the FS without going to dashboard at least once. The only share available initially is Public and you can’t do much with it. I haven’t looked into the API much, but I would suspect it should be fairly easy to create a command line utility for linux that simply enables the DroboApps feature and probably sets the default admin password. Once you do that, you could install apps, manage quite a bit manually over SSH, or potentially add a 3rd party admin if we make one.

yes that file controls only samba but it’s a generated file that will get overwritten.

you are correct, the shell commands don’t work for shutdown, only reboot, but the power button should be safe. If you are concerned about your apps, you can always issue the apps stop command which stops all apps before you power off.

I have already been keeping track of items for a drobo shell guide so I just posted it on my site. It’s not exactly a “setup on linux” guide, but already had your questions so I just elaborated on the samba details for you.

http://drobo.jhah.net/guides/drobofs_shell_faq

It’s really too bad that one HAS to use the Dashboard at all. I really hope that data robotics will consider to make the necessary changes to enable people to start using/configuring it right away - even if they don’t own a Windows PC or a Mac.

Thank you very much! Your answers are most helpful…and your FAQ is as well! :slight_smile:

Hi All,

I also run Linux as my primary machines at home and have been looking at way to enhance the ability of my drobo. Currently have my apache configured to be able to run CGI applications, next thinking of getting some mysql client libraries so I can connect to a remote mysql database.

f you plan on using the command line to do task with the drobo I recommend creating a .profile file in the /mnt/DroboFS directory and the creating alias to the scripts you want to use.

I have included a sample of one I use

alias perl=‘LD_LIBRARY_PATH=/mnt/DroboFS/Shares/DroboApps/perl/lib perl’
alias file=‘LD_LIBRARY_PATH=/mnt/DroboFS/Shares/DroboApps/arm/lib /mnt/DroboFS/Shares/DroboApps/arm/bin/file -m /mnt/DroboFS/Shares/DroboApps/arm/share/misc/magic.mgc’
alias lsof=’/mnt/DroboFS/Shares/DroboApps/arm/bin/lsof’
alias strace=’/mnt/DroboFS/Shares/DroboApps/arm/bin/strace’
alias tcpdump=’/mnt/DroboFS/Shares/DroboApps/arm/bin/tcpdump’

One thing I have noticed is both OSX and Linux appear to drop the connection to the share if left for a while, even if you have a file open. Anyone else noticed this??

Good point :slight_smile:

Yes, it happens to me too. And the most irritating issue (with Samba) is that I’m sometimes unable to connect. But if I try it several times, it suddenly works. Seems a bit unstable…or maybe it’s a compeletely different problem (like with the network connection from my workstation to my switch).

I don’t use Samba to tranfer files anyway - I’ve found that FTP is reliable and a lot faster.

My linux connection has dropped it, but I thought it was a fluke because it doesn’t happen often. I have also noticed that the network light on these things is flickering like crazy even when totally idle. I’ve got some assumptions about why, but haven’t had time to do a packet capture to see for sure. I’ve been curious if this has something to do with the drive spin down issue on the FS as well?

Good to know I am not the only one that has noticed the connection issue. When I do some more investigation I may raise a support ticket.

In regards to the network light going crazy I have read in a few other posts about lots of broadcast packets for the dashboard to find the device as well as show it’s latest status. Have not confirmed this myself but could explain it.

I assumed it was broadcast traffic for dashboard too which sucks since I don’t run dashboard 99% of the time.

Has anyone ever found a fix for NFS reporting 16TB total size?

That is not an NFS bug, since the filesystem does report that total size.

And the reason the filesystem reports 16TB is called thin provisioning.

In other words, “not a bug, it’s a feature”.

To further Ricardo’s suggestion that it is a feature, not a bug, the direct attach Drobos behave the same. Windows, for example, would report a 16TB volume, and as I understand it a Mac too.