USB 3 connection dropping to Drobo S

Having trouble with my Drobo S in that it drops the connection after a while, and then the dashboard cannot find the Drobo

A re-boot helps in that I can get it connected again, and it will either work for a short while, or sometimes a few hours

The Support Team basically said “get a new Drobo” which is fine, but I see that connections issues are everywhere in the forums.

My Firmware is up to date, my Dashboard is up to date

I uploaded a Diagnostic to be told “Your Diag File shows that the Drobo itself is the Problem”

When pressed, I was sent this

It seemed to be a problem with the Mainboard.

Wed Nov 11 08:19:24 2015: ELM: Boot Drobo3 TDB1052A0677, bat OFF, ver: 5.41.62910(2.1.5) NODEBUG BUILD (GCC) (DB-MV78200-A-BP LE MMU ARCH 5)

Wed Nov 11 08:19:25 2015: RebootReason: PMU reports Power Switch Shutdown
SystemManager Initialize failed - rebooting

To me this looks likes me re-booting the thing - not a diagnosis of the problem

I know a lot of you have connection issues - and the only help on the site is “make sure firmware and dashboard are current”

I will buy a new Drobo if I have to, but the support was so vague -

(no I dont have a firewire port on my PC … YET) - I will get one if it will help, but tired of guessing

In my mind the problem has occurred since latest update - but I may have that wrong

LATEST - I have changed the USB Power suspend settings to DISABLED - to see if this helps - I will report

hi mike,
i wss wondering if you had discussions with support and are still covered by waranty then maybe you could get a free replacement, especially if they diagnosed the drobo unit as the problem?

for the connectivity issue, a few things to check could be these:

  • to try a different usb cable
  • to try a different usb port
  • to “not” use any usb hubs or adapters, if you were (eg to just plug directly into the computer usb slot)
  • to check overal power settings (when to sleep, are you hibernating the pc etc, and to set it up in always on mode (just for a test).
  • to try a different drobo psu wall socket
  • when you usually finish using the computer and drobo, could you help me to understand what you do then?
  • which windows is it btw?

Am doing this on my phone so excuse if incorrect how it is being done

Changed cable, changed port, changed everything…

My latest theory of usb power settings (hidden in Advanced Setting in Power setting) is proving hopeful… no drop out for a few hours…

My main annoyance was with “Support” who just suggested “buy a new one”… but why would I buy a new one if I think there is an issue? It may be the PC so that’s another 500 quid wasted…

I can see how a Drobo might lose the connection if the USB power drops, as my cache is set to 50gb in lightroom… so the drive is not spinning… I will have another day with it, and update this thread to help others…

The only “help” offered is

  1. Update the firmware (difficult if you can’t connect)
  2. Update the dashboard

My Firmware and Dashboard are up to date so the “support” basically said “buy a new one” cos the diagnostic showed a reboot, but it was me that re-booted it to get it to connect"

I think the USB Power issue may be it, but will see tomorrow…

Oh… and I ordered a LaCie Raid to back up the Drobo if it keep connected that long… will do it in stages…

Windows 10 BTW…

Back tomorrow with updates… this may help everyone who has this issue and provide a better answer than “buy another one” which would do exactly the same if it is the USB Power issue…

close down is either via dashboard - then disconnect … or leave alone overnight … switch off in morning … crank up pc … switch on drobo

Mike

ok thanks for the info mike,
lets see things go…

Ok here we go

This may all be total rubbish, but it seems to have worked for me …

Since changing the power settings on the PC in Advanced Settings for anything relating to USB as well as PCI Express for good measure to DISABLED for any power savings, I have had no trouble with the Drobo at all and the connection doesn’t drop. I am also able to Shutdown Drobo via the Dashboard (which I orefer at night so when booting it doesn’t search all attached drives - but may change that in the F2 Boot setup if I can work it out !)

It appears to be a standard default setting in Win 10 that USB selective suspend setting as well as PCi Express Link State Power Managerment are enabled.

Being connected via USB3 - it appears that the port is given less power after a period of time to help you save 10p per year

Had I bought a new Drobo as suggested by “support”, I would probably have had the same problem. There was no way I was going to buy a new one, mainly because

1)I was not convinced that “support” was actually listening,
2) was just copying and pasting standard links in to a message,
3) and was just guessing (which I can do on my own thanks very much !!)

I am sure migrating to a new one is simple as it says … BUT not if you CANT CONNECT to make sure firmwares are up to date.

As it happens, Drobo lost out this time, as I bought a LaCie Drive to make sure I could back everything up as an extra safety-net. My main worry was that I could keep the Drobo mounted long enough to copy the files over.

There are issues with mounting volumes/drives/drobos all over the forum, and its probably time that this issue wa dealt with better than “update your firmware” (which you can’t do if you can’t connect to the drobo) and update dashboard. No one seems to know what to do after that …or any ideas in the way it connects with the PC/Mac …

Would I buy another Drobo when my new LaCie is filled up ??

Will think about it …

hi mike, im glad that changing the power settings seem to have fixed your problem, (despite the 10p extra cost which i didnt know about).

i think its actually good that you bought an extra device to backup the data on the drobo, because in general, it is always a good practice to not only have 1 copy of the data.
(when i got my gen1, i actually bought another drobo as a backup, eg my gen2, to also have a compatible chassis in addition to a backup, but that was me)

can i check do you have any mounting issues currently? if so if you can post a bit more about that, me or others can try to help too.

No mounting issues after running it all day, either in use or not in use…

I always copy my drobo volumes to external hard drives which go in a safe… but the LaCie will mean I will use that for a year or two instead of the drobo

For info none of my volumes exceeds 2TB and are copied individually throughout the year… as will the 12TB LaCie next year

I just feel a bit annoyed at the basic help offered by Drobo… they need to learn how the Drobo interacts with different Operating Systems and not just say “if firmware and dashboard are up to date then all is well”

I may come back to Drobo when I have filled up the LaCie next year, we will see if they have progressed a little more by then.

Thanks for being interested tho,

Mike

As an addendum … Of course the Drobo is not my only storage device, and everything is backed up to other drives of different manufacture throughout the year.

The point is that if it doesn’t stay mounted, then I am hardly likely to back it up to another Drobo, when no one appears to offer more than “update firmware” (on a non-connected drive) as advice…

I repeat myself in that Drobo need to know more about how their product interacts with different operating systems.

In addition, to say “buy a new one” (when I can’t migrate, as the firmware has to be up to date on the non-connected Drobo, as well as the new one) is rather pointless … unless someone knows how to update firmware on something you cant connect to…

The support has been “copy and paste” links to the help files, which offer very little apart from “update firmware and dashboard” -

In summary, I have enjoyed the Drobo until recent events, but recent events (and lack of knowledge within Drobo) mean I am hardly encouraged to buy another.

thanks for the info and thoughts,

the issue of the usb 3 connection dropping is not new
.
I bought my drobo S 4/20/13 and called support on 8/9/13 with this problem
.
They said it was my computer.
.
I’ve put up with this until now but the lost connections are now becoming more frequent so will need to find another company’s product
.
I first called Drobo’s tech support on 8/9/13. It was very disappointing - especially now that I can see many others have the same problem. My warranty expired 5/20/14 but even though I reported the problem while it was in warranty I was not aware that this is a common problem so tended to believe tech support’s saying that it was my CPU.
.
I now have connected four 5tb Seagate drives via USB 3 with no problems so am in the process of transferring the files - which will take days.
.
I do have drobo 5n also which doesn’t seem to have any problems but the lack of good support has driven me to other sources for my next box.
Frank

hi frank, if you still happen to have the drobo s, it might be interesting to see what happens if you try another cable?
(you might have already tried it, but sometimes if can be the cable, and trying another one, or dofferent ports can help)

my drobo s goes straight into my usb slot (i had an esata/usb slot but couldnt get that work work properly though i did have a few motherboard update options that i could have tried, but ended up being happy with another slot)

you may not have any adaptors in the mix, though just to mention that some convertors/adaptors or hubs can add extra problems of slowdowns too. (as can auto scheduled antivirus scans, other programs, and search indexing catalogues etc)

Hi Frank

Hope you are managing to copy over to your Seagates without it dropping the connection. I agree that there is a denial on this issue, and whilst I appreciate nothing lasts forever, it is disappointing when you encounter the “copy and paste links” service offered by the support…

My issue of connection dropping hasn’t been solved really, even after changing the default of Windows powering down USB’s - although it is much less frequent.

I back a new folder up each time I add a new folder/job (am a photographer) so I have other copies, but that is not the point. I use Lightroom and bought the Drobo so I don’t have to chop and change drives

My argument that Drobo should know why this is happening (possibly after a software update) … and they should know how the Drobo interacts with at least the latest versions of Windows and Mac software. I use Windows 10 for info …Bog standard setup

Everyone is guessing, and like you, I am hardly likely to buy another one as the same thing may happen with that if it is the interaction with Win 10 that is the issue… If this is the case, it doesn’t make it the fault of a generic PC, it makes it the fault of the Drobo software. So “Go buy another” isn’t an answer if I can’t be sure it will work…

Same issue here, and it has starting happening every day.
May be Windows, may be Drobo. Either way I am looking for a new device. Drobo support has not been helpful so I am looking elsewhere. Any suggestions?

Well I bought a LaCie Drive as I was disappointed with the knowledge from Drobo.

I am still using the Drobo S (with mega backups) as it seems to have improved … It is potentially a Windows issue, as since recent updates, it has cut off hardly at all … This was my point with Drobo that they need to understand issues that go further than their own box - in that how it interacts with the OS

I won’t buy another Drobo until I am 1000% convinced that …

a) I get more helpful support than “go buy another” or “click this link which you have probably read before”
b) It is compatible with Win 10

Potentially Drobo is the best in the business - but support is “go to site”, " buy a new one" … “here’s a link” where we have all trawled the simple help files which is basically “make sure your software is up to date” (which you cant do if you can’t connect)

I don’t rely on the Drobo at all now, and just use it as a working drive

Maybe LaCie ??