Drobo

USB 3.0 not working with Drobo 5d3 on Ubuntu

I have a Drobo 5D3 that I’m trying to get to work with my machine. Connecting via USB 2.0 works fine: I managed to format the drive as ext3 and can copy to it. Unfortunately, USB 3.0 is not working so well. While I can mount the drive and look at its contents, I can’t do much else. When I tried to format the drive via USB 3.0 it always died at the step: “Writing superblocks and filesystem accounting information”. After successfully formatting the drive via USB 2.0, if I try to copy to it via USB 3.0 it hangs indefinitely. Any suggestions?

Here is what the logs say. Looks like a reset is being triggered.

Jun 16 14:04:55 -desktop kernel: [ 50.257377] usb 6-2: new SuperSpeed USB device number 2 using xhci_hcd
Jun 16 14:04:55 -desktop kernel: [ 50.278311] usb 6-2: New USB device found, idVendor=19b9, idProduct=3533
Jun 16 14:04:55 -desktop kernel: [ 50.278315] usb 6-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jun 16 14:04:55 -desktop kernel: [ 50.278318] usb 6-2: Product: Drobo5D3
Jun 16 14:04:55 -desktop kernel: [ 50.278321] usb 6-2: Manufacturer: Drobo
Jun 16 14:04:55 -desktop kernel: [ 50.278323] usb 6-2: SerialNumber: D0C181302600623
Jun 16 14:04:55 -desktop kernel: [ 50.340678] usb-storage 6-2:1.0: USB Mass Storage device detected
Jun 16 14:04:55 -desktop kernel: [ 50.340895] scsi host10: usb-storage 6-2:1.0
Jun 16 14:06:06 -desktop kernel: [ 121.721979] usb 6-2: reset SuperSpeed USB device number 2 using xhci_hcd

I am having the exact same issue on a newly purchased 5C3. Did you ever get it resolved? Does anyone have a Drobo connected at USB 3 Gen 1 or 2 in linux?