Upgraded from Gen 2 to Gen 3

I have recently upgraded to a Gen 3 when my Gen 2 quit working or booting into the Drobo dashboard. When I received my new Drobo, I followed all of the instructions and everything was going great. I backed up my old disks to a WD MyBook 3 TB and then re-formted my disks since I still couldn’t write to my drives. Once I got the disks all formatted, I started trying to copy back to my Drobo.

I left the house for 6 hours and when I returned, I had multiple messages on my iMac stating that the disk did not eject properly. I cleared them out and tried to do it again. This time I got the not ejecting properly message in about 2 to 3 minutes. I have tried resetting my Drobo as well. I have removed the Drobo Dashboard and rebooted and still no luck. What am I doing wrong here?

Any help would be greatly appreciated

hi, it could be something to do with the powersaving settings on mac, or maybe it goes into hibernation/sleep mode, and settings might need tweaking, but can i also check how you are connecting the gen3 drobo to the mac?

for example, is it via the usb cable that came with it, or is the gen 3 going through some other adapters or hubs etc?