Drobo

Unreliable Mounting/Visability of Drobo Gen 3 (USB3) Since Upgrade to Big Sur (11.0.1)

Since updating my iMac to Big Sur 11.0.1 my Drobo Gen 3 has become unreliable. I will usually see one of the following:

-On restart I’ll get an error “Eject Drobo before disconnecting or turning it off” and Drobo will not have mounted. Disk Utility sees the Drobo ok as does Drobo Dashboard. Unplugging and plugging the USB 3 back in corrects this.

-On restart the Drobo will mount and is visible through Finder but Drobo Dashboard cannot find it. The capacity LEDs go from 3 (normal operation) to 5. Once I unplug and plug the Drobo back in Drobo Dashboard can discover the Drobo and after a few moments the capacity LED settles back down to 3.

On occasion (twice so far) restarting and unplugging/plugging the Drobo back does not change the condition. A complete shutdown/reboot of both the Drobo and the iMac was required to restore operation.

-No other external USB 3 drive I’ve tried has caused any problem and operates normally on restart.

This all worked fine under Catalina.

I am being safe and have disconnected my Drobo units until we hear a decent response from Drobo. Hopefully I will live that long. I suggest you sit tight and protect your data.

I’m also seeing problems with my IMac hanging when I try to restart. Issues with Chrome autoloading even though I’ve removed it from login items, closed the app before restarting, and unchecked to reopen apps on restart…basically I’m not super comfortable with Big Sur or all the apps running on it yet. I’m still isolating those issues but I may revert to Catalina. In the meantime, Drobo is unplugged. Are you seeing similar things with Drobo or DrobeDashboard as I described above?

There are no known issues with USB 3.0 and Big Sur. You may try running Disk Utility First Aid on the Drobo.

The Drobo volume tests fine with Disk Utility.

I’ve been doing additional testing and can reliably reproduce the following:

-on reboot or restart of the Mac the Drobo volume will mount but the capacity LEDs will be higher than normal. I normally see 3 LEDs lit for 2.74TB used space in the 16 TB volume but the Drobo will have 5 LEDs lit. Drobo Dashboard (DD) will not detect the Drobo.

-Finder and Disk Util (DU) see the volume and all is ok. Files can be written and read on the volume. The capacity used reports as normal with Finder and DU (3.02 TB used of 17.59 TB capacity).

-after ejecting the volume, disconnecting the Drobo USB cable, and then reconnecting the cable, DD will detect the Drobo and show the correct capacity. The correct number of capacity LEDs (3) on the Drobo are lit. Just ejecting and remounting the Drobo volume does not resolve the issue. Unplugging and reinserting the USB cable is required to allow DD to discover the Drobo.

-when DD is unable to discover the Drobo the desktop icon for Drobo is the generic external drive icon macOS uses for any USB drive. When DD is able to discover the Drobo this is replaced with the Drobo desktop icon.

-it takes a minute or so for the LEDs to change after reboot to go from 3 to 5. Even when the LEDs are 3 at this point DD cannot discover the Drobo. It will then take a minute or so for the LEDs to go from 5 back to 3 after unplugging and reinserting the USB cable.

This behavior does not happen with other external drives but then again external drives don’t have DD or capacity LEDs.

Hi. I believe Valorie is saying that Drobo does not support using a Drobo unit with Disk Utilities. You should be using Drobo Dashboard instead.

The purpose of running Disk Utility First Aid is to check for any permissions issues.
Also by any chance are you using WD SMR drives?

Oh, I wasn’t aware that Drobo did not support the use of DU. Having said that the First Aid test did pass as “ok”

I do not have any WD SMR drives.

My Gen 3 is also unreliable after a clean install of Big Sur 11.0.1. While I have exactly experienced some of what Drobospace documents, I have found a repeatable workaround that seems to keep the Drobo happy and Drobo Dashboard as well.

Most of my problems were on shutdown or restart of the computer. But IF you can get the Drobo mounted on the desktop and DD 3.5.1 sees it (a shutdown of the Drobo via the toggle switch on the back and then restarting via the toggle switch worked for me) and all seems normal , I have repeated the following and had good results:

  • Drobo mounted (with Drobo icon) and DD sees it and files can be written normally, I am able to log out and put Mac to sleep. When it wakes, the Drobo appears on the desktop and all is well.
  • If I have the need to restart or shutdown the computer, I unmount the Drobo in the finder and unplug it from the USB port.
  • After restart and log in, I plug the Drobo back into the computer and it appears fine with Drobo icon and DD can see it.

Also can confirm that there are no Drobo Gen 3 or DD issues under Catalina. All worked fine.

Just wanted to add to this. I came here looking for answers and found one of my problems documented in this thread. I have not tried to plug/unplug scenario yet but will. I also have a Drobo 5N and that also shows the above behavior. After a reboot I see all my drives as expected. I do not let my computer sleep but in the morning I find that both the 5N and the Gen3 are both unmounted and the error message at the top pf this thread about the drive not being safely ejected is on screen. I have backed out to Catalina for now until this can be resolved. I do hope it is resolved. The thought of replacing the drobo hardware is cost prohibitive. I would probably go with Synology.

Here’s hoping for a fix from Drobo.

btw - has anyone tried Dashboard 3.5.2 to see if that helps? I know it is supposed to be for thunderbolt issues which neither of my drobos are.

Scott

I have not yet seen the eject before disconnecting error message unless either I pull the USB cable prior to ejecting the drive from Finder or unmount using Disk Utlity (and on the odd occasion on a reboot).

Usually on a reboot or restart the volume on the Gen 3 will mount just fine with full read/write capabilities. The issue I’m seeing will be Drobo Dashboard not seeing the Drobo and the capacity LEDs being too high. At this point I’ll eject the drive and then unplug/re-plug the USB and everything will be normal (volume mounts, DD sees the Drobo, capacity LEDs show correct number).

None of this happened with Catalina but because my Drobo still has capacity available and it seems I can safely read/write to the volume after restart/reboot I will stay on Big Sur. My other non-Drobo external USB drive works fine on Big Sur.

I’m hoping the issue is not a Drobo issue and might be resolved in 11.1 (currently in beta) because I’ve no faith Drobo/StorCentric will acknowledge this issue or resolve it (if it is actually their issue) in a timely fashion.

You describe a slightly different issue in that you are apparently seeing your drives as expected after reboot (do you mean Drobo Dashboard sees the drives normally, that Finder/Disk Utility does, or both?). In addition, you are seeing nightly improper eject error messages even though you have not rebooted your Mac. This last one seems odd to me. Have you checked what your uptime is in the AM? Maybe your system is rebooting overnight and reopening apps that were open when the system restarts. (you can tell what your time since last boot is by going to the Apple logo on the top left of the screen, clicking on “About This Mac”, then clicking “System Report…”, and then on “software”).

It still is very possible, and actually highly likely, that our issues are closely related but showing slightly different symptoms. Let’s keep our fingers crossed and hope for a speedy recognition of the issue and resolution.

Well, just tried the update to 3.5.2

Can it get worse? Yes it can. Still can’t see the locally attached USB3 drobo. The screens on the dashboard are a total mess. Text overwriting itself… Man. I wonder if I could just sell these 2 devices and get something else… Sadly both devices are flawless under Catalina. Will just keep trying and watch the boards. Boot off the external drive in to Big Sur and if it eventually works, i will switch to the new OS… At least I will have a new laptop coming that will let me play around with Big Sur. Thought about a Mac Mini but that would probably be even worse!

What a pain

Drobo Dashboard 3.5.0 was making the Finder in Big Sur hang allll the time. 3.5.1 corrected it, but then, I was getting frequent notifications that the drives had been incorrectly ejected (sometimes leading to Finder crashes) and the Dashboard app itself failed to detect the Drobo most of the time.
Drobo Dashboard 3.5.2 reverted back to having the Finder hanging all the time to the point where the Mac was completely unusable and I had to power down the unit.

I guess we’ll have to wait for a version 3.5.3 :-\

Corentin

I can say that is my experience exactly. I am going to do a fresh install of Big Sur with nothing but drobo dashboard and see if there is something else conflicting. I hope I still have 3.5.1

Yeah, I’ll stay on 3.5.1 for now. At least I know that on reboot/restart of my Mac that Drobo gets mounted reliably (even if the LED indicators show too many lit…what’s up with that anyway?). I also know that I can eject the volume, pull the USB cable, plug it back in, and Drobo Dashboard can see the Drobo and everything is normal again (with the correct number of capacity LEDs lit). Perhaps someday this will get sorted out.

Updated Drobo Dashboard to 3.5.2 and rebooted. Sadly, my Gen 3 showed up on the desktop with the generic icon and DD could not find it. I held my breath and shutdown the Drobo with the toggle switch in the back. Then toggled it back on. The normal Drobo icon came up. Drobo Dashboard was also able to find it. I guess I’ll have to continue my workaround of having to unmount the Drobo from the finder and unplug the USB cable before doing a restart. Then plugging the USB cable back in after everything is back up. All seems to be normal at that point.

But you are still able to use the work around reliably? Whew! I’ll still wait to see if Drobo responds here and if they have a proper fix coming before moving off of 3.5.1.

Whew is right. But yes, all seems to work reliably for me using the method I describe above. Crossing my fingers for 3.5.3!!