Drobo

Unable to use Firewire in Windows 7

Hello,

I just finished talking with Data Robotics support about my problems using a 16TB-formatted 2nd-gen Drobo connected over FireWire to a Windows 7 64-bit machine.

The case (091130-000121) ended with the following text:
[size=x-small]“I am sorry for the inconvenience yes we do not support using the Drobo with Windows 7 connected fire wire until the issue is resolved.
You could submit a support case to Microsoft, perhaps they could keep you updated on when there will be a fix for the issue.”[/size]

Saying that drives connected over Firewire will not work in Windows 7.
I’ve tried two different firewire cards (the FW400 port on my foxconn mars motherbard, and a SIIG 800 DV card) with both the Microsoft Drivers, the Microsoft Legacy drivers, and the Unibrain drivers.

In every situation, I can read off the drive just fine, but whenever I try to write to it, it crashes.
Rebooting the computer does not fix this crash, I need to reboot the Drobo by yanking the power, which in turn has left with a corrupt index!

The event viewer is giving me errors like:
“An error was detected on device \Device\Harddisk4\DR9 during a paging operation (EventID 51)”

And there was en error reported with the sbp2port saying:
“The driver has detected a device with old or out-of-date firmware. The device will not be used (EventID 25)”

When this happens the Drobo still appears in the device manager, but there’s a yellow exclamation mark and an error message that says: “Windows has stopped this device because it has reported problems. (Code 43)”

I’ve tried the recommended firewire cards on the knowledgebase and they failed, I tried the unibrain drivers that the knowledgebase recommends for use with Windows 7 and those failed, and tech support told me that I need to wait for a new driver, rendering my favorite hard drive useless until…?

And so I turn to the forums :slight_smile:
Has anyone had any luck getting a 2nd-Gen Drobo working in Windows 7 over a firewire connection?
Failing that, does anyone know exactly what I need to wait for here?

Thanks for any help you can provide,
-guyinco6nito

I’d try it, but I don’t have a Firewire-enabled machine with Win7 yet. My only Win7 machine is connected via USB.

But, it sounds like either the sbp2port driver is saying your Firewire interface needs a newer firmware. I could be wrong, though.

Do you have a regular Firewire hard drive that you can test with?
I suspect it might be an inherent problem with Win7’s SBP2 driver.

Does the same Drobo work OK via USB?

Hi,
Thanks for the reply!

I do have a regular firewire hard drive, and plan to test that one out tonight using the same cable i hook up to the drobo.
If it fails I guess I’ll know that firewire is windows 7 is broken through no fault of data robotics, but if it works it would be even more disturbing.

I’m wary to connect a 16-terabyte formatted Drobo over USB, since I don’t think USB can handle drives bigger than 2TB. That said, as part of my recent tests I offloaded all of the data from the drive and formatted it over USB. It created three volumes that were each 2TB, and those worked out just fine. Is having a single 16TB volume a luxury I should abandon?

Thanks for the tips,
-guyinco6nito

16TB works over USB with no problems.

Volume size is independent of the data connection method (for DAS, at least).

As Jennifer says, 16TB works over USB fine.

16TB thin-provisioned Drobo on USB in Win 7 Professional x64 is what I’m running. :slight_smile:

Thanks so much for the tips!!!
I’ll try out the USB connection tonight crosses fingers
How do you mean thin-provisioned?
Did you format through Windows Disk management or the Drobo tool?

This ability to format your volume larger than available disk space is called “thin provisioning.” It allows you to grow into a single, large volume over time rather than needing multiple smaller volumes.

Currently I have 8 TB of actual storage (5.5 TB usable after protection), and when larger drives come out, I’ll be able to increase my storage capacity and not worry about additional drive letters until I exceed 16 TB of usable space.

It Worked!!!
Good sweet lord it worked.
Over USB I can write to the Drobo without crashes, and I just did a checksum hash (using torrents to confirm that my data is accurate) and it can read the data over USB perfectly.

Someday a person will get rich inventing a system that allows you to buy a person a beer (or celebratory beverage of their choice) over the internet. Until then, let’s just say I owe you one :slight_smile:

I would be upset and wonder why support didn’t tell me to try USB at any point over the last year of troubleshooting difficulty, but I’m too excited that it’s working to care.

Thanks so much again.
Wishing you to have good ones forevermore,
-guyinco6nito

Extraneous Tale of Ennui:
I got a 2nd-gen Drobo as soon as it came out (since my 1st-gen was nearly full). I was excited to create a partition 8 terabytes big because I could expand my data for years without formatting or bringing the drive down at all. At the time, I was told that USB could not handle any partitions over 2 terabytes (I cannot remember where from exactly) so I thought that I had to use firewire to make a big partition.

So I moved all of data off the drives (plugging in a series of externals and praying that they didn’t fail when I needed them) and hooked up the drive to my motherboard’s firewire port back when I was running Windows Vista. My motherboard maker didn’t have any drivers online, so I used the default windows drivers. The drive couldn’t format and was crashing like crazy whenever I wrote to it. I contacted tech support, and after being escalated to the higher tier of support, I was sent a series of firewire drivers. None of them worked. It was then decided that the unit had to be faulty, so I had a replacement one sent out. I was told specifically that the credit card reserve necessary to have a unit sent out before I sent the broken one back would not be a charge, only a reserve. Unfortunately my credit card company wanted to make interest on the reserve, so they considered it a charge, pushing my card over the limit and giving me a slew of fee’s while hurting my credit score. After getting support to cancel the reserve and just trust me, I was excited to get the new unit, but once it arrived, it had the exact same problems.

I was convinced that it had to be either the drives, or a corrupt format of the disk pack, or my firewire card. I bought both of the recommended firewire cards on the drobo knowledgebase, only to find that FW800 connections could not even find the drobo, and that the FW400 connections didn’t work with the unibrain driver, and over the Microsoft Driver (Texas Instruments…) the drive crashed whenver I wrote to it. I reformatted several times, and it failed under most drivers, but under the Microsoft ones I got a format to work (after using a paperclip to reset the drobo). Same problem. I got replacement hard drives and switched them out one by one (waiting the 20 hours for the data to rearrange itself) and the problem persisted, meaning it wasn’t the individual drives.

Getting frustrated, I asked tech support to send out a DroboShare thinking that if they’ve already cost me $160 (for the two firewire cards) trying (and failing) to get Firewire to work, a NAS accessory would be a good testing step. Unfortunately it was painfully slow, and a 1.01TB directory of DVR’d TV shows (I love BeyondTV :slight_smile: takes ~75 seconds to load over the droboshare, but just 1 second to load over firewire. So I stuck with firewire, and found that if I just wrote small amounts of files to it (~500mb) I could get it to not-crash. For months I moved over small packets of data, and rebooted the Drobo whenever it crashed and disappeared.

After upgrading to Windows 7, the problems over Firewire continued, and I contacted support asking why the Unibrain drivers recommended in the knowledgebase weren’t working for me. I was told that we had to wait for new Microsoft drivers instead, so I couldn’t use my drobo.

At no point in the YEAR that I’ve been working with Data Robotics on this one, did anyone tell me to try hooking it up over USB. I’d be extraordinarily annoyed if I weren’t so ecstatic that it’s working now.
Thanks again!!!

@guyinco6nito

Can you private message me your previous cases?

I only ask because if someone has issues with FW the very first step in troubleshooting should be switch to USB and see if the problems persists. I would like to find out who never suggested USB to you.

I’m curious, as a new Drobo 2nd gen. owner, on what configuration of FW800 1394b card, drivers and under Windows 7 64 bit are supported. This thread scared me into using only the slower USB 2.0 connection until I’m convinced that Firewire under Windows 7 64 bit is a non-issue.

@MDK

We are sorry you are experiencing this problem. We have found that FireWire is working inconsistently with Windows 7 in general, not specific to DRI products. This is due to a number of factors, such as your specific computer-FireWire hardware combination and drivers. This shows up as inconsistent connections, failure to complete formatting, etc. Until this problem is resolved, we recommend using the USB connection or the iSCSI connection (DroboPro only). Data Robotics, Inc. can only support USB and iSCSI connections to a Windows 7 computer until the issue is resolved.

A (long) side-note about Firewire and Windows…
In the Firewire world, the bus can run at 100, 200, 400, or 800 (1394b aka Firewire800) Mbps, and the attached device reports its supported speed as S100, S200, S400 or S800 (again, 1394b aka Firewire800). Since Firewire is repeater-based, the entire bus slows down to the speed of the slowest connected device.

I started using OHCI-compliant Firewire back in Windows 2000. Prior to Windows 2000, there wasn’t real standardization for Firewire stuff, with Consumer DV (aka Sony i.Link) camcorders being the first Firewire devices.

It was fairly OK in Windows 2000, except for an early-model (circa 1999/2000) TI-based Firewire card that was sold in various forms branded as Media100 IIRC (I could be wrong on the brand). That particular chip, the part # escapes me, had major issues with device recognition and speed. So beware “bargain bin” Firewire cards unless they’re 2005 or newer. :slight_smile:

It was better in Windows XP. Except that shortly after the release of SP1 or SP2 (can’t remember), some OEM manufacturers somehow started installing Windows images with broken Firewire drivers! When you hooked up your DV camera, you’d get a 61883-class device (number might be wrong) instead of a recognized DV camera. Uncertain whether this also affected Firewire storage (SBP2 devices)…

Which leads to my once-upon-a-time 16-drive JBOD array consisting of 8 daisy-chained Firewire-IDE bridge boards (2 drives per board) connected to Windows XP Professional SP2. That didn’t work so well. Windows would randomly lose drives. Never figured out whether it was lack of power (I had 2x400W PSUs), some conflict between bridge boards, or Windows itself, but that didn’t last long.
It worked much better with fewer Firewire devices.

On the other hand, I have another machine with 4 Firewire cards in them (it was the only way I could get drive letters to “stick”) with 8 optical drives - again 2 drives on each of 4 bridge boards. That machine runs fine and I can use all drives simultaneously (it was a makeshift CD duplicator). Also Windows XP Professional… So go figure.

Sadly, post-Vista, Firewire fell by the wayside. There are Firewire camera devices (Apple’s original iSight, some security cameras), Firewire audio devices, a few Firewire scanners, Firewire storage devices, and a whole bunch of DV/Digital8/HDV Firewire devices.

In general, Firewire400, when it works, it faster and less CPU-intensive compared to USB 2.0, but the tricky part is getting it to work. Firewire is just more “picky” about stuff compared to USB in general. Could be the simple fact that there are way more USB devices out in the wild so USB host adapters get way more exercise and testing - who knows…

I think in the long run, outside of camcorders, which are moving toward HDD or solid-state recording anyway, Firewire will be replaced by eSATA, not that they really serve the same purpose, but since the majority of Firewire devices are storage, it makes some sense.

yeah it is a shame, i have fond memories of my first DVD writer (about $600… + $20/disk) which was an external FW one, from lacie in fact, and it had two “huge” firewire hard disks in matching boxes, to they all made lovely little stack…

I was actually using Firewire on my Drobo S with Windows Small Business Server 2008 successfully for months until I popped in my 5th drive a week ago. Now it runs fine for a while and then goes completely offline with the following message in Device Manager: “Windows has stopped this device because it has reported problems. (Code 43)”

I guess I’ll be switching to the slower USB 2.0 connection, but I can’t say I’m happy about it.

open a support case, send them your logs, they should be able to tell you what drobo is doing

quote:
Someday a person will get rich inventing a system that allows you to buy a person a beer (or celebratory beverage of their choice) over the internet. Until then, let’s just say I owe you one :slight_smile:
quote:

that exists :slight_smile:
its called Virtual Voucher - all pubs have it , and you got to a website and click on a button which pays with paypal.
then when you get to your local pub you swipe your card and get a free beer.
well - thats my idea - you heard it here first… if you get rich quick, share some with me :slight_smile:

Micro$oft products and firewire don’t play well together…unfortunately.