Drobo

Unable to format Drobo on Windows 7

I’m unable to format my 2nd gen Drobo on Windows 7 to NTFS filesystem. I’ve tried different disk combinations, different dashboard versions etc, but nothing seems to work. I’ve recognized two different cases. One is that dasbhoard just gives error message that it’s unable to format, and recommends to reboot Drobo and try again. The other case is that dashboard enters some kind of never-ending loop and hangs to “formatting” dialog (waited for several hours with no results).

Everything is working fine on OSX. I’ve tried to reset Drobo with no effect. When I tried with older dashboard, it looked like dashboard gives “unable to format…” message just after Win7 explorer recognizes Drobo and dialog asking if I want to format a new drive appears.

Any ideas how do I format my Drobo?

I (almost) always get error message in Win7 with all of my Drobo v2 units. I just run Disk Maangement (diskmgmt.msc) and format from there. Just be sure not to mess with the partitions or anything else. Just format it. Be careful to make sure you’re clicking the correct disk. I recommend disconnecting anything that isn’t necessary to avoid confusion and error.