Two drives failed in two days! Any chance of recovering data?

Two days ago drive 1 (of five) in my Drobo FS failed and the Drobo alerted me and started moving data around to compensate for the lost drive.

Horrifyingly, yesterday, drive 5 also failed before the data had been completely rebuilt.

I now have two solid red lights on failed drives 1 and 5, with drives 2,3,and 4 blinking red. Drobo Dashboard is telling me to “reinsert” the “ejected” drive so it can continue to rebuild the data.

Of course I didn’t have double redundancy checked; never thought two drives would fail within a few hours of each other after years of chugging along calmly.

Any ideas for recovering my data? My Dashboard and firmware are both updated to the latest versions, I’m using Mac, Windows, and Linux (all latest versions), and have already ejected all the drives, cleaned the contacts, blown out the Drobo housing, etc with no change in symptoms.

Any assistance would be greatly appreciated. And just in case anyone is wondering, I had two Seagates, two WDs, and a Hitachi. Both Seagates (2 TB and 3 TB) were the failed drives. Never again, Seagate…

Will I ever see my data again?

hi macblade,
unfortunately in any device, a 2nd drive can fail (sometimes even more if really bad drives or luck etc)

i think there are probbaly a few ways to try to get data back, but i think in order of importance it would be these:

  1. to raise a ticket with the support team (which i believe can still be raised as a paid for incident if you wish)

  2. the above may lead to certain steps and recommendations regarding what actions to take (or not take) in case doing something might prevent a recovery if possible later.

  3. it will probbaly be recommended to fully block clone the drives before trying any further tests or repairs etc, whereby certain procedures with support could be tried out using the clones - basically its like having a snapshot of the drives to try and continue with, and if any repair process does more harm than good, the source drives could essentially be recloned again, for more clone processing.

  4. there is another process that has been useful for others in the past (though usually for those with reboot loops), which is to try putting the drobo into a read-only mode, to see if it can still access any data: im doutbful here, especially if 2 drives have failed, though after the above it is probably worth trying.
    for example as mentioned here:

i think some users have been able to access things after a block clone, though the last full thread i remember with yerry was not able to find a working solution in the end. (some useful info can be found there in general too though) http://www.drobospace.com/forums/showthread.php?tid=144867

btw is this the same drobo from here?
(if so, and you have a mac, i think the readonly process should still work in a similar way)

Thank you very much for the reply. I’ve ordered some replacement drives that should arrive tomorrow. My plan was to try to clone them and see what I could generate. My plan is to use Data Rescue 3.2.4 for the Mac - any better bets than that that you’re aware of?

I raised a ticket with Drobo but they pointed me straight to the forum since I’m out of warranty. Not much help from those guys at all. I suppose I’ll go with a paid ticket if my cloning doesn’t get me anywhere.

I did try the Read-Only mode when it first occurred - no change there.

And yes, it is the same Drobo (only Drobo I’ve ever owned) - eventually got it to show up on the Mini but I forget what I did. I suppose I should, like you, have a Drobo backing up my Drobo…

Thanks again for taking time to help me.

ah no problem, we all try to help each other

for the actual cloning, i havent done any cloning for this context. (i did have success with acronis on windows but that might work differently for block cloning)

one thing to be very careful of, is that sometimes, when there are problems or lots of things to do, there can be a sense of urgency to do something, and in your case, please do try to remember to double and triple check which way the clone will go, just in case the program happens to select the blank drive as the source, and a diskpack drive as the destination… which can unfortunately happen.

for the data backups, yup that process worked very well for me, like in my sig, except that recently my gen1 failed after about 5-6 years so i now have some other backups set up in a different way, but that mini project is not yet complete and still in the works too