Drobo

Trying to revive DR04DD

I’m going to try and make this simple but it’s not.

OK, my tower is an old Mac Pro (2010, 2 x 2.66 GHz 6-Core Intel Xeon, running 10.13.6). For this story I’ll call the four drives in my DR04DD, top to bottom, 1, 2, 3 and 4.

It’s 2014 and my DR04DD has 4 2TB drives and is working fine. One day I see the top drive, drive 1 shows a red light. I eject the drive but realize it’ll be days before I can get a replacement. I reseat the drive. Lo and behold, it starts rebuilding. After a couple of weeks, it seems to be back! All is good. I’m using my Drobo again.

A year later drive 4 shows a red light. After my experience with 1, I decide to eject and reseat. All lights go red. I unplug the Drobo, change jobs, move, change my life, forget about the Drobo.

Recently, I’m looking for something and I realize it’s on my old Drobo. I plug it in and again, the bottom light, drive 4, flashes red. I buy a new 4TB drive (Seagate Barracuda Internal Hard Drive 4TB SATA 6Gb/s 256MB Cache 3.5-Inch (ST4000DM004)) and replace 4 - the bottom drive. The three lights above flash green and yellow. No light next to 4, the new drive.

I wait two weeks.

Still flashing green and yellow. I decide, for the first time since lighting up this old Drobo to plug it into my computer and see if the Drobo Dashboard will recognize it. No. Nothing. Doesn’t show up. Dashboard doesn’t see it. Disk utility doesn’t see it. I tried replacing USB cables. Tried using Firewire instead. Nothing.

I just don’t know what to do next. Why doesn’t my computer see the drive? Are there any tricks to get my Mac to see this drive? Is there any chance of saving the data?

OK - is there any data you are trying to recover from the array? or are you able to reset?
Also, your new HDD is a new consumer SMR drive, which Drobo does not recommend. Background here:

Yes, I’m trying to access files on the disabled Drobo. I don’t want to reset the unit.
Does the unit seem to be doing the right thing now? Should I let it go or stop and start over?
Is there a chance the Drobo might not be rebuilding itself because I chose the wrong drive? Might the Drobo start rebuilding if I load a different brand drive?
Thanks.
Peter

If your Drobo had normal redundancy, in theory you should be able to remove the new drive, and whilst it will report that a drive is missing, you should be able to still read the data on the original drives. All lights will be blinking green/yellow during that time. Normal.

If you can then copy off what you need, you can then look at a full reset.
Personally I would avoid SMR drives completely.

OK, so I just want to review a little bit here.
When the drive slot (4) first blinked red I removed that drive and inserted the SMR drive. The light next to the SMR drive never lit up at all. The other three drives (1,2 and 3) have been blinking yellow and green since that day.
I have not been able to see the Drobo at all: not by USB or Firewire or on the Drobo dashboard. I’ve tried restarting a couple of time and tried the Mac Disk Utility.
At this point your suggestion is to remove the SMR drive and replace it.
Here are my questions:

  1. If the Drobo is happy with the new replacement, will I see all four drive lights flash green and yellow? Is there any external indication that the unit is successfully rebuilding the fourth drive?
  2. Is there any trick I can try to get the Drobo to appear on my computer or the Drobo dashboard?
  3. Do you have any reason to believe that if I replace the SMR drive with a better drive that I will be able to see the Drobo either on my computer as an external drive or on the Drobo dashboard?
  4. As it stands now, can I unplug the Drobo without doing any further damage? (I’m trying to move my desk and trying to avoid powering the Drobo down has become an issue).
    Thanks again for your time and attention.
    Peter

My suggestion was to remove the SMR and with your 3 remaining drives blinking green/yellow, access the array and copy-off your data. However if you are unable to see the drive on your computer or via the Dashboard this is still a concern.

To answer your questions:

  1. yes - it takes about 2 min for the new drive to be initialised before it is integrated into the array, so hold tight. you will hear it spin before you see it flash
  2. this is the one I don’t know yet and without the drive operating normally, I’m hesitant to suggest anything just now.
  3. this is probably my next suggestion, as it appears the SMR has not been accepted into the array, so there is a better chance to replace it with a regular drive.
  4. as long as it is powered down, you can move it. I would suggest you take the SMR drive out of the array at the same time.

Your computer not seeing your Drobo may resolve itself after it successfully initialises the new drive. Check back here with your progress.

Good Luck

Thanks for your response!
The three remaining drives are all 2TB. I was hoping to replace the dead drive with something bigger. Do you have a suggestion?

Given the current uncertainty in your situation, perhaps a big investment is not immediately warranted, however prices on 2-5TB drives are quite reasonable. Just check on line about whether they are SMR drives first. If they are now all SMRs, you may need to got to 5-8TB to avoid them. I would.

Use the Drobo Choose Drive for specific recommendations:

Yeah, I don’t want to spend tons if Im never going to get this unit to work. But, I do a lot of video editing so I can’t really cheap out too bad. I’ll try the drive selector. Thanks.