Transmission daemon for DroboFS

I made a build of Transmission for DroboFS, available here:

New version!
[]Based on Transmission 2.00
]Supports starting and stopping correctly

Hopefully it installs correctly, and it should have the web interface available at http://[drobo-ip]:9091/transmission/web/
or you can install and use the command line app transmission-remote to connect to it.

By default, it downloads to the Public share and has a capped upload rate of 100KB/s.
There is no security enabled so don’t set this up on a public IP until you’ve changed the RPC password or at least bound to a local IP.

For settings that you can’t change from the web interface of command line, you can edit settings.json in the bundle.

Nice, I’ll have to try this out once I get home.

I gave this a try, but my DroboFS didn’t install it, the file was just deleted from the DroboApps folder, after rebooting.

I’m not sure why I had to try installing twice, but I’m glad I did. The second attempt worked for me. Thanks hatstand.

Great work! I’ve never used the web app before, but I use the Mac client all the time. It’s really nice to be able to leave torrents run on my Drobo without having to leave my Mac on all night. Thanks!

So far it’s working great for me, though I noticed that the script cannot stop the service since no PID file is created. It looks like transmission-daemon has no option to write a PID file. I’m guessing it’s different from the standard Linux build? I also found that it doesn’t fork off with the same process number. Adding & after running the daemon and adding echo $! > ${pidfile} to the start function gives a PID file, but the actual PID, from ps, seems to be +1 of that in the PID file. I’m not sure why this is the case (transmission-daemon must run in the foreground but fork off another process as the actual daemon), so just adding 1 to $! may not be reliable, but you could always use ps to get the proper PID:

sleep 3 # wait a few seconds for the daemon to run and fork to the new PID
echo ps | grep [t]ransmission-daemon | cut -f1 -d" " > ${pidfile}

Thanks! Worked great first time for me.

Perhaps foolishly, I tried first to install a version of transmission from another Forum thread, modified the startup script with the correct path, and it did start… it just didn’t work. This one worked fine with no modification necessary.

Can’t wait to try this.

i’m having trouble adding a htpasswd and have no idea where to start can some please assist me? thanks!

Just installed this… loving it!!
Much better than the ctorrent/torrential setup I had before. Saves me having to brush up my php and fix torrential!

Many Thanks.

I am not sure why this wasn’t included to begin with, but if you add just a couple of lines to settings.json it makes this release a ton better.

"watch-dir": "/mnt/DroboFS/Shares/Downloads/Torrents",
"watch-dir-enabled": true,

Of course change the part after /Shares/ to what ever folder you want. Just download a torrent to the torrents folder and forget about it. Transmission will autostart the download.

I must say this is a very good DroboApp and really should be on the official page. I like it a lot and it works well with the ability to check current status on my ipod touch etc but…
Three or four times now the whole drobo has stopped responding when i am loading transmission with too much download (around 3-9 torrents and a total dl speed of 7 mbit). It wont respond to ping, ssh or web requests, all shares taken offline and Drobo admin won’t find the unit either. Only way to kick it alive again was to use the switch in the back. That powered the unit down safely and back up again.
Limiting torrent download speed to 2.5 mbit have worked for a while now so it’s definitly related somehow.

Have anyone else seen this?


I’ve had a similiar problem running torrent downloaders on NAS devices before, specifically Buffalo Devices. The problem was always the CPU/RAM. I dunno if the released CPU/RAM for the Drobo FS but it would be nice to run some test to find out what the breaking point is.

I have done some basic tests and 5 mbit download seems to be ok (not crashed yet) but 7-8 is over the limit.
I’ll post again when i have done some more tests.

ok so I just download the transmission from the first page and use the web interface, thats it, i dont have to change anything or modify anything right, I can also change the folder for new downloads too?

I downloaded some torrents but dont know where the files downloaded to, I checked the drobo fs and there is no public folder, can someone help?[hr]
there were two torrents that I remembered to change the dir but what do I do for the others I left to download to the default folder

I suggest you update the download dir. What i did was create a share called Downloads and then edited settings.json (found in DroboApps\transmission).

    "download-dir": "/mnt/DroboFS/Shares/Downloads", 
    "watch-dir": "/mnt/DroboFS/Shares/Downloads/Torrents", 
    "watch-dir-enabled": true

I also created a Watch directory, so i just download a torrent file to the torrents folder and Transmission will auto start the download.

Thanks for the update! Working great, but how do i start/stop from command line?
Nevermind found it :slight_smile: , “./ start/stop/restart/status”

I get this error:

./ .: 5: Can’t open /etc/service.subr

when starting the services: ./ start

Any hints as to the cause of this, I’m running 2gen Drobo

Are you using the app packaged for the FS on a 2gen Drobo? If so, the start/stop scripts are not the same. Does the /etc/service.subr file exist on your DroboShare? I haven’t done much with the scripts for the DroboShare, but I would suspect that may be the issue.

Is there any way I can get Transmission to read from an RSS directly?

As a workaround, is there another program I can use to watch an RSS feed & download the torrent file?
From there (as already outlined) it’ll be a piece of cake to tell Transmission to watch that folder.