transfers between shares-big problems

I’m a very new 5N user with moderate+ OSX abilities (I’m no IT guy). This is my first NAS. First my setup: 5N (2x2TB, 2x1TB about 60% full) is plugged into an apple time capsule port. The time capsule is fed from the Comcast router (broadband) and my Mac Pro is ethernet to the time capsule.

Here’s my issue. I’ve been trying to transfer DVD files (and other large files) from one share to another. Mark>DVD Backups (share) to Public>DVDs (share). The transfer starts fine for a minute or two then stops (seems to hang). A couple things happen. #1 I get one of a couple error messages (attached). #2 the network signal seems to disappear. I can’t get on the internet with the Mac Pro, Dropbox syncing has stopped, but I can still access a good wi-fi signal with my laptop. The original transfer of files to the Drobo worked fine and was connected the same way as described above. The other thing I noticed was the folder (DVDs) I created in the Public share is “greyed out” or faded and if I click on it, it doesn’t show me the contents. The public share is mounted. So as a test, I created Public1 share and tried the transfer. Same results.

The only changes I made to anything when I set up the Drobo was in relation to trying to get Crashplan installed and working (which was a nightmare). According to instructions I found, I did change IP addresses on the Drobo and the time machine and did something with DHCP (this is pretty much over my head but I can follow instructions). I’m confident I followed the instructions correctly because everything else seems to be working except this transfer issue.

Thank you for any help, as a new owner this is frustrating.

I don’t know how to include an image.
The error reads:
An error occurred. The operation couldn’t be completed. (OSStatus error -128.)
Source: (null)
Destination (null)
Item: (null)

Also got one with error -36

Another one read: Finder can’t complete the operation because some data in “” can’t be read or written (Error code -36)

The question is: do you want a solution to your way of doing this, or the right way of doing this?

If you want a solution to your current way of doing things, then I suggest that instead of directly copying files from one share to another, that you try to copy to your machine first. This way you avoid the concurrent reads/writes on the Drobo, which can be troublesome for very large files. Second, consider doing this transfer using a wired network. Not only it will be significantly faster, it will also be more reliable.

Now, the right way of doing this requires a bit more of low-level knowledge. Let’s start with an analogy. Imagine that you have some stuff stored in a friends house and for whatever reason you want him to move some of the stuff from one room to another. What does make more sense: to ask the friend to send the stuff back to you, just so that you can send it back to him with the name of the new room attached to it, or just tell your friend to move the stuff around inside his house? And this is not even a good analogy. A more accurate analogy would be for the friend to send the stuff to you so that you can tell him to move it around the same room. As you can imagine, just moving stuff around the same room is not only instantaneous, but also much safer.

So, is it possible to tell your friend (the 5N) to move stuff around the same room (all shares are actually in the same disk) instead of sending then to you so that you can tell it to where to put it (copying from one share to another)? Yes, it is possible, but it does require a bit of effort to setup.

First you need to install openssh on your Drobo. You can find it here:
Copy the TGZ file you’ll find there to your DroboApps share and restart your Drobo. Once restarted, you should see be able to connect to your Drobo over SSH.

If you are using a Mac, then connecting to the 5N will be pretty easy. Just open Terminal, menu Shell, item “New Remote Connection”. Select “Secure Shell (ssh)” from Services, and the 5N should appear under the “Discovered Servers”. Enter “admin” as User and you should be able to log in.

If you are successful, you should see a command-line prompt like this:

bash $

(My memory is kind fuzzy on what the default prompt looks like. There should be a $-sign somewhere, though)
From now on, I’ll just use the $-sign as an indication of the prompt.

Once you have that you can type this:

$ cd "/mnt/DroboFS/Shares/Mark/DVD Backups"

Notice the presence of quotation marks. They are very important because your folder has spaces on its name. A quick “ls” command should show you all the files that you see when you access the share using your Mac.

Now do this:

$ cd "/mnt/DroboFS/Shares/Public/DVD Backups"
$ ls

You changed to the folder where you want the files to be. Make sure that there are duplicated files between the two folders.

The next step is the one you need to be careful, because this is where data loss can occur. We’re gonna move the files from “Mark/DVD Backups” to “Public/DVD Backups”:

$ cd "/mnt/DroboFS/Shares/Mark/DVD Backups"
$ mv * "/mnt/DroboFS/Shares/Public/DVD Backups/"

Two important things to notice:

  1. The asterisk means “all files in this folder”. That includes non-ISO files. If you want only ISO files, then type *.iso instead. Keep in mind that the 5N is case-sensitive, so if your files have uppercase extensions then you need to use that instead.

  2. Notice that the second parameter for mv is the destination folder, and therefore it ends with a forward slash. That forward slash is very important. Do not forget it.

If you are lucky, this should be it. The transfer will be almost instantaneous and the files should be on your public share. If you are unlucky, you’ll receive some error message about permission denied. That can be fixed as well, it just needs some more effort.

I followed right up to:

I got ssh installed but when it comes to terminal, it’s over my head. I’m thrilled to follow step by step instruction, I just fear screwing something up if there’s any guessing on my part.

I did find that after I installed ssh and restarted drobo, the dropbear app is no longer working and it looks like my Crashplan stopped uploading. I just posted another request for help with drobo before your reply to this thread, so I can add this issue to that post now.

The “next backup” to CP central never happens, it analyzes and stops

I’m so confused.

If I may be blunt, I think this is not the solution for you. If just installing openssh is giving you trouble then the odds that something bad will happen later on are just too big. I recommend that you uninstall openssh, and return to your previous configuration. Then do the first solution. It’ll take a lot longer, but at least it is something that you are familiar with.

I could not agree more, and after fiddling quite a bit, which I don’t mind doing, pretty much decided that as well. I really do appreciate your feedback though. I’d much prefer to spend my time trying to get Crashplan working!
Thanks again!

Unfortunately, OpenSSH is a prereq for CrashPlan due to the way the client connects to the engine.

I was wondering about that the other day and it turns out that the CrashPlan guys finally added the possibility for the engine to listen to any address and to the client to connect to any address. Details here:

(Mind you, I’d never do this on an untrusted network, but for the typical home user this might be a better option.)