"Too many hard drives have been removed. Please re-insert the removed hard drives"

Config: Drobo FS, 4 x WD 1.5T SATA Caviar Green. Single Redundancy. Drive Bay 4 empty

Issue: WD 1.5T Green Drive (Bay 2) msg “Drive Failed. Replace failed drive”. Indicator FLASHING RED.
1 of 4 1.5 TB drives failed in my Drobo FS. So, I replaced it with a 2TB WD Red drive and also added a 5th 2TB drive in Bay 4. The indicators are all RED and I’m getting the msg “Too many drives have been removed. Please re-insert the removed hard drives”. I’ve tried a number of things, listed in the steps below. But have never seen a flashing yellow/green indicator, which if I understand, indicates recovery has started. Thanks for any help! More detail below.

Current Status: Msg “Too many hard drives have been removed. Please re-insert the removed hard drives”. Recovery process will not start. ALL Drive Bay indicators SOLID RED.

Steps taken to-date:

  1. Replaced failed drive (Bay 2) with WD 2TB Red drive. Added (Bay 4) WD 2TB Red drive. Bay 2 indicator FLASHING RED. Other indicators SOLID RED. msg1 "Too many drives failed. msg2 “Drive failed. Replace failed drive.”
    …No change for several hours.

  2. Reboot. All indicators SOLID RED. Drobo undiscoverable in Dashboard.

  3. Remove drive from Bay 4. No change.

  4. Reboot. msg “Too many drives have been removed. Please re-insert the removed hard drive.”

  5. Re-seated new drive in Bay 4. Drive detected. All Indicators YELLOW… All indicators RED. msg: Too many hard drives have been removed…"

  6. Re-insert FAILED DRIVE in Bay 2. Bay 2 Indicator Flashing RED. All other indicators SOLID RED. Drobo not discoverable in Dashboard

  7. Insert NEW 2TB WD Red drive in Bay 2. Bay 2 Flashing RED. All other indicators SOLID RED.

  8. Stop DROBO. Re-seat NEW 2TB drives in Bays 2, 4. Re-start Drobo. All indicators RED. msg “Too many hard drives have been removed. Please re-insert the removed hard drives”

hi, i wasnt able to see that case (i think its only you when logged in and support teams who can access that area), but i think there are a couple of things that might be worth trying after finishing any current processes with support…

(please do try to finish any current processes with support so that there are no conflicting steps)

these ideas would include being able to try the following?

  • to shut all down and to unplug all cables from the drobo

  • to remove all drives currently inside it, (remembing the order in case needed later)

  • to then try powering up the empty drobo on its own
    (it should power up and then go to standby mode shortly after)

  • to then power up the computer (and to launch dashboard once computer is running)

  • to then try connecting the drobofs directly to the computer if possible (or however you usually do it)
    (does the drobo wake up shortly after and then become recognised by dashboard?)

if so, the main unit seems to be ok, in which case please power all down

  • and then to unplug all cables from the drobo
  • and then to put all the drives that you just removed, back into where they were before this post.
  • and to try powering the unconnected drobofs
    (does it boot up with the usual blue leds through 1-to-10 and then go into standby mode?)

either way, please then powerup the computer (and then dashboard)
and once those are running, to connect the drobofs to the computer
(what does the drobo fs do and what does dashboard show you?)

2nd idea)
if the same errors are there, then you could try these:-

  • to shutdown and power all off and to remove all cables from the drobo
  • to remove all drives currently inside (remembering order for later in case needed)
  • to then only put the drives inside (which were origially there from when you had the 1st problem) e.g including the failed 1.5TB where it was, as well as having an emtpy unused slot as you had before…

then to power on the drobo
and after it boots and (hopefully) goes into standby?
and when the computer and dashboard are running
to connect it to the computer
and when it hopefully is found - this time to first insert the new blank working 2TB drive into the empty slot (and to see if it starts rebuilding first after at least 10minutes) - rather than removing the failed drive first… what happenes now?


Thanks for your reply. I’ve already done the “main unit test” and it comes up cleanly with a red light on drive bay #0, Dashboard msg to add a drive immediately. So, I think the unit is fine.

Thinking thru next steps, I’d come up with your 2nd idea as well. Great to see you suggesting that as well.

I’m still slowly working thru the support process on the case I opened. Will update here as things progress.

Thanks again for your help.

ok sure - please let us know how things go.
(we can save the phrase “great minds think alike” until after you get a good end result) :slight_smile:

The 2nd idea didn’t recognize the new drive in bay #5, Recap of the steps:

  • Reboot with original disk config
  • Unrecognizable in dashboard
  • Red flashing bay #2, all others solid red. 5th blue capacity led lit. (I think this is Stanby Mode ?)
  • Inserted fresh 2tb drive in bay #5. No impact. Recovery mode not initiated.[hr]
    Support has examined log files and is recommending cloning failed drive from drive bay #2. I’m willing to attempt cloning myself. But, have a few questions I’m hoping to get some input and opinions.
  1. I’m looking for an external drive cradle (2 bay) to use for cloning. Can anyone recommend a product?

Any opinions on the StarTech HDD Docking Stations. Has anyone used any of these https://www.startech.com/HDD/Docking/?filter_NUMHARDDRIVE=2

  1. What about a HDD duplicator? Could it be used to clone the drive? Has anyone successfully used this StarTech product? https://www.startech.com/HDD/Duplicators/USB-3-Hard-Drive-Duplicator-Docking-Station~SATDOCK2REU3

  2. Support is recommending using the DEMO version of Stellar Phoenix from http://download.stellarinfo.com/stellar/StellarPhoenixWindowsDataRecovery-Professional.exe. Has anyone used this SW?

    • I’ve installed it and checked out cloning process. Only settings are source and destination drive parameters. So appears to be a sector-by-sector copy. Not quite sure how it’s handling bad sectors.

Thanks for taking the time to reply to my newbie questions!

hi and thanks for more info, its good that you now know which drive to clone,
i havent used a cloner myself, though i have used some other startech products such as bidirectional ide / sata convertors which worked fine.

that particular $90 2nd link seems like it could do the job, and seems to be the least complicated dock to use (though there seemed to be a non-dock/non-host portable version a bit cheaper about $40, but having the easier and host version might be useful).

it did mention on there page that if too many drive errors exist, it may not be able to complete the duplication (though it may be a normal disclaimer or encouragement to get another possibly more expensive model).