Drobo

Time Machine -- Full restore with 10.7

So I’ve started using Time Machine with 10.7 again since the new firmware seems to have solved the peformance issues.

I have noticed a new problem though. I find that I need to restore my entire system from the Time machine backup and I can’t.

I’ve done it with 10.6 using the steps provided by Drobo support.

  1. You create a mount point in the “Volumes” folder
  2. you manually mount the time machine share using terminal
  3. Choose “restore from Time Machine backup” and it should find your backups.

This worked in 10.6 but no backups are found with 10.7 in fact it doesn’t even appear to hit the Drobo at all while it is searching.

Can anybody out there running Lion and time machine give this a shot and let me know if it works for them?

Thanks

Check Sky’s post here

Thanks bhiga

Using Sky’s response and a bit of googling I found the additional step required for Lion.

Just in case anyone else needs it here are the steps to setup Time Machine in terminal

mkdir /Volumes/TMBackup
mount_afp afp://:<password@192.168.0.1/TMBackup /Volumes/TMBackup
hdiutil attach /Volumes/TMBackup/<time_machine_file>.sparsebundle

the new part for lion is the last line. You need to actually attach the sparse bundle. In Snow Leopard this wasn’t needed.

Thanks. Using Sky’s post and a bit of searching I found the terminal commands below which allow access to the Time Machine Backups from the Recovery Partition.

mkdir /Volumes/TMBackup
mount_afp afp://:<password@192.168.0.1/TMBackup /Volumes/TMBackup
hdiutil attach /Volumes/TMBackup/<time_machine_file>.sparsebundle

The new part is the last line. This wasn’t needed in Snow Leopard.

Hopefully this saves others some time.