Time Machine and FS

Note: As of this writing, Apple has released OS X 10.6.3. All Drobo direct attached products (Drobo, Drobo S, DroboPro, and DroboElite) are fully compatible with Apple Time Machine when using Mac OS 10.6.2 and lower. Apple introduced changes in Mac OS 10.6.3 that resets the maximum size of sparse images to the size of the volume. This behavior is undesirable when used with storage devices such as Drobo storage arrays that support thin provisioning, as the reported volume size often exceeds the physical storage space available.

Data Robotics is aware of the issue and is working on firmware changes to ensure compatibility with Mac OS X 10.6.3 and higher. Until a fix is released, we do not support Time Machine on Drobo FS in a OS X 10.6.3 environment.

For Drobo FS customers running OS X 10.6.2 or earlier, please do the following to set up Time Machine:

  1. Open Terminal in the Utilities folder:

  2. Cut and paste (or type) the following command in the Terminal window:
    defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1

  3. In Drobo Dashboard, create a share that will be dedicated to Time Machine: Advanced Controls -> Tools ->Settings -> Shares.

  4. Verify that the new share is mounted, using Drobo Dashboard, version 1.7.x or later.

  5. Download the DroboApp “Time Tamer” from: www.drobo.com/droboapps/downloads/.

  6. Install and run the Time Tamer application, selecting the share you created for your Time Machine backups.

  7. Open Time Machine and click Select Disk.

  8. Select the share you created specifically for the Time Machine backups on your Drobo FS .

Time Machine should now work as expected with your Drobo FS.

BTW, we are working on a MUCH better Time Machine support. It will be out soon.

… and thusly Apple has completely misunderstood the purpose behind sparse-files in the first place.

Will all drobos be supported? Any ETA? Just upgraded to 10.6.3 and I think I just hosed my sparebundle :frowning:

Now trying to set up the drobo with partitions and hopefully be able to use Time Machine that way …

I just purchased a DroboFS and am pretty disappointed that I cannot use it with TimeMachine - the entire reason I purchased the unit in the first place.

Will this thread be updated when y’all are able to fix the resetting sparsebundle size problem that apple changed? (Subscribing to the thread now in hopes that this is the case.)

Thanks for working on it,

-bw

Yes, I will update this thread when there is an update.

Great, thanks Jennifer.

Do you have any recommended methods for backing up home systems until you complete the Time-Machine support?

Are you updating the netatalk package to version 2.05 or maybe 2.1? Would love to see that.

-Dave

I’m not sure about “official recommended” options but the program SuperDuper will create bootable image files for you - and it’s actually free for home use:

http://www.shirt-pocket.com/SuperDuper/SuperDuperDescription.html

You can also set up DroboCopy to copy over specific folder structures within the Drobo Dashboard as a like a cron job - you set up the schedule and folder, etc. I’m not sure if this copies the structure as a diff or if it attempts to do the whole structure every time.

Thanks for the response, welchb. I use rsync and rsnapshot on my linux machines but really don’t want to write a how-to that my wife would understand. That is the beauty in Time Machine, ease of use and intuitive.

Super Duper looks interesting, but at first look it seems to be more of a cloning app than an incremental backup and restore app. I will dload and give it a go.

I’ll test out the Drobo Copy feature. Is it file based copy? I have and use 5-6 VM images and if it copies at the file level it would trigger copying the entire set of vm images each day, 8-35GB each. I might be talking myself into just using rsync and friends until DRI rolls out the updated netatalk functions.

Cheers,
Dave

Personally, since I have a crashplan account, I’m just using that to backup remotely (to their servers), and also to my drobo mounted via USB to the AEBS. Erased my time machine sparsebundle, since it hosed it with the 10.6.3 upgrade.

Time Machine and Drobo has always half-worked from my experience … not 100% reliable. Hopefully their new method will come out soon, and work reliably.

In defense of DRI, Apple changing the way that sparse-files worked under OSX was blindingly stupid.

Sparse files have worked the same way for over 30 years in countless UNIX environments. Apple did the UNIX equivalent of re-defining gravity.

Even without Apple changing their implementation of sparsebundles in the latest update … it’s always been flakey to use a Drobo with Time Machine.

http://www.engadget.com/2010/05/20/drobo-fs-gets-native-time-machine-support-we-go-hands-on/

Sounds good, wonder when we’ll be able to download it… Drobo Dash doesn’t see any updates, nothing on drobo.com either.

Also, wondering if this dope time machine support will proliferate to non-FS models… We have a Drobo v1 at work that I’d love for Time Machine to work better with.

I was coming here looking for the same thing because of that post. Hopefully that wasn’t just a “promo” unit sent to engadget. *(:

Looking for the same thing!

There’s a press release on the front page of drobo.com now. Check for updates and download page still yield nothing.

You can sign up for the RSS feed to get updates from our website.

http://www.drobo.com/support/feed/

So lots of press releases and hands on from reviewers here… but no access to the firmware by the actual users?

Jennifer, are there plans to port this over to all of the other Drobos? Specifically V1 :wink: