Thunderbolt unreliable on 2013 MacPro

I am experiencing frequent Drobo disappearing acts on my MacPro (the trashcan version), using Thunderbolt and a Drobo 5D running the latest firmware.

I used the 5D for 2 weeks before on an older MacPro with a USB 3.0 card and the issues have been similar.

The behaviour seems to be that, if the Mac was EITHER powered down, or sleeping for several hours, that the Drobo does not wake up anymore when the machine is restarted, or woken up.

Only way to get the Drobo to reconnect is to manually power it down and on again.

That seems to be a firmware issue, as, when examining the Thunderbolt bus on the MacPro, the Drobo 5D is still shown as connected. But neither the Dashboard, nor the terminal, nor the finder can find the drive.

Trying to create a ticket, but the Drobo site throws me an SSO error (and yes, i mailed them about that), so for now, i am trying to gather more information.

Is that a known/common/rare issue?



hi frank,

to be frank, ( :slight_smile: ) macs and thunderbolts and mavericks have usually been in threads with connection/access problems.
dont worry about the sso issue, i’ve been there and some others too and the team were able to sort that out for us.
as for the issue you have, i was wondering if you have been able to try your newer/current macpro via usb? just to see if it helps in any way?

(sorry for the frank jokes) - just trying to help a bit :slight_smile:

(from frankfurt) :smiley:

Hey Paul, tx for the answer. Yes, the SSO issue is supposed to be solved.

Being a German working for american companies, i love to do the " to be frank" joke myself all the time :slight_smile:

No, i have not tried using USB 3.0 for an extended period of time (just briefly to see if it was any faster/any perceivable difference). Might try that, to see if it makes a difference, but to be honest, my USB ports are full, and i bought the Drobo for the Thunderbolt port.

I will file a support ticket, to see what they come up with. But i do suspect that to be a firmware bug on the Drobo side.

Frank (from Wermelskirchen, in the Bergische Land).

hallo :slight_smile:

ok please do try another thunderbolt cable as well, just in case the existing cable has become damaged in some way, and look forward to hearing your results.

In addition to the cabling, does it help if you change the hibernation setting on your computer?

This seems to have helped some other users:

I’d be curious to see if this works, because it does seem to be limited to Mavericks. 10.8.5 had the same issue briefly until the supplemental update came out.

After a bunch of tries and a lot of diags send around, support has issued an RMA to make sure that it is not the unit itself that is defective…

I will keep this updated.


FYI - nMP + Pegasus2 = absurd speeds. It’s not a nMP issue.

In fact, i7 MacMini + Drobo 5D (TB) is damn fast.

Something in your chain is bad. It’s not a global issue.

I have 2 Drobos 5D daisy chained with SD to My Mac Pro 6.1 . I had some problems at first with the cables. TB cables seem touchy. One apple 2m TB cable gave me some problems : it had to be plugged and unplugged several times to get a proper connections. I must say that I had not the same problem with the TB cables provided with the Drobos.
Otherwise the 2 beasts work Ok now.
BTW I sent a post a few weeks ago about backing up one Drobo to the other with SuperDuper. That was before I received the Mac Pro.
I’m glad to report that I did the job without any problem. The first backup began by erasing all data on the Target Drobo, then copied about 1,8 TB in about 4 hours. After transfering 8 GB on the Source Drobo, I did a “smart backup” on the Target : it took exactly 2 minutes 51 seconds !

The exact same thing happened to me. My MacPro rebooted out of nowhere and now one 5D will not mount… no blue lights are even visible. Another 5D will also not mount. The only Drobo devices that mount are two 5Ns (network devices).

I’m NOT happy. Neither of these are visible at all.

[quote=“nashuavideotours, post:9, topic:139412”]
The exact same thing happened to me. My MacPro rebooted out of nowhere and now one 5D will not mount… no blue lights are even visible. Another 5D will also not mount. The only Drobo devices that mount are two 5Ns (network devices).

I’m NOT happy. Neither of these are visible at all.[/quote]
The sudden reboot probably left the filesystem in a dirty state. This can prevent mount of the device and is not a Drobo-specific problem.

I have the same problem using a 5S and an Apple Firewire to Thunderbolt adapter. I was thinking of getting the 5D for the speed and the direct Thunderbolt connection, but if the 5D is having the same problem, guess I’ll have to wait until its fixed, or get a Promise Thunderbolt 2 solution. Is it something inherent with the new MacPro Thunderbolt and Drobo of any model?


hi steve, what about usb3?

Hello Frank,
We do apologize for the trouble you experienced, the updated firmware for the 5D will resolve this issue - you can download from:

Thank You,

It works OK with USB (my 5S only has USB 2.0) but wakes up very slowly from MacPro sleep.

hmm, maybe the macpro is doing several things when it comes out of sleep, and then once its ready, it might only then be re-establishing/communicating with the drobo.

im not sure as i pretty much powerdown my drobo before logging off or hibernating or powering off the computer.

im assuming “sleep” is the same as hibernate? but if not, is your sleep, the equivalent of a screensaver (eg after 20 mins the mac goes to sleep?.. if so, is there a longer duration you can set it to, which might help your situation a bit more… such as if you usually take 30mins breaks from the computer, try setting it to 45mins before sleep?[hr]
also maybe there is a setting or something similar which is making the mac (recheck or reindexing something before re-establishing a ready connection with drobo again?)

have you tried it going to sleep and back, both WITH dashboard running, and WITHOUT?