Drobo

There may be troubles ahead

Whilst investigating performance problems I found a large number of events such as:
Event Type: Warning
Event Source: Disk
Event Category: None
Event ID: 51
Date: 14/07/2011
Time: 10:04:10
User: N/A
Computer: ZZZ-5F77B431C40
Description:
An error was detected on device \Device\Harddisk1\D during a paging operation.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 03 00 68 00 01 00 b6 00 …h…¶.
0008: 00 00 00 00 33 00 04 80 …3…?
0010: 2d 01 00 00 00 00 00 00 -…
0018: 00 00 00 00 00 00 00 00 …
0020: 00 00 00 00 00 00 00 00 …
0028: 1c d5 31 00 00 00 00 00 .Õ1…
0030: ff ff ff ff 03 00 00 00 ÿÿÿÿ…
0038: 40 00 00 49 00 00 00 00 @…I…
0040: 00 20 0a 12 4c 02 20 40 . …L. @
0048: 00 f0 00 00 0a 00 00 00 .ð…
0050: 00 00 00 00 78 37 56 88 …x7V?
0058: 00 00 00 00 08 25 34 88 …%4?
0060: 00 00 00 00 df a7 3e 28 …ߧ>(
0068: 28 00 28 3e a7 df 00 00 (.(>§ß…
0070: 78 00 00 00 00 00 00 00 x…
0078: 00 00 00 00 00 00 00 00 …
0080: 00 00 00 00 00 00 00 00 …
0088: 00 00 00 00 00 00 00 00 …

If that “\Device\Harddisk1\D” is what I perceive as D: then this is from my Drobo, which (as far as I can tell) says that it is “healthy” and is at the current firmware level.

Any suggestions on what should I do next?

Further details: The problem is associated with write activity. Any program which generates a reasonable write load on the Drobo brings it to its knees for up to a couple of minutes. Most of my Windows system grinds to a halt during these episodes.

Only processes that don’t access the Drobo are immune (a defragmentation runnon on C: was just fine)

The drobo is only just over 50% full, so this isn’t an extreme case of the slowdown you get when running out of space.

I get those errors frequently on my WinXP system. It too generates massive I/O slowdowns on my PC when I try to write “too much” to it at once. SysInternals Process Explorer reports a very high number of Deferred Procedure Calls.

I don’t mean to be flippant, but this has been happening for me since I bought the Drobo almost 3 years ago. Thus far, it’s been a nuisance but hasn’t resulted in data loss or crashes.

Have you run Chkdsk /f on it?
Note: DO NOT do Chkdsk /r on any Drobo. Thin provisioning and cluster-integrity checks do not get along.

If you’re asking me, yes I do them every few months. I’ve only once found a problem, and that was fixed painlessly.

Sorry, was mainly asking Switfy. :slight_smile:

The other thing you can try as a diagnostic is to plug the Drobo into a different USB port, preferably one that is has never been plugged into before. That should get a new device enumeration, if there’s something amiss with the USB enumeration.

Been a while since I ran Drobo on XP… wait, actually I never tried it on XP. So maybe it’s an XP thing…

I can try moving it to a different port. It means going behind my PC and swapping a couple of devices (there are none free).

Event ID: 51 is odd; it’s poorly documented (i.e. worse than the others). All that lovely hex data, and no way to work out what any of it actually means.

This looked interesting so I broke out the Google…

It’s here: http://support.microsoft.com/kb/244780

You apparently can’t assume that this error refers to D: because of the \D at the end. The “Harddisk1” is what is really telling you what is going on, the “\D” is a truncation of something longer due to a field width limitation.

From here: http://www.hardwareanalysis.com/content/topic/12946/#202500

Right click on “My Computer” and choose Manage (I think, don’t have Windows any more). From there go to Disk Management and see which harddisk is named “Disk 1”, that should be the disk. Maybe this error isn’t from the Drobo after all?

Aha! Thanks. whatever it is, its a SRB_STATUS_QUEUE_FROZEN. I’ve not found a way to thaw it. :frowning:

Again, thanks. The “Disk Manager” inside “Computer Management” showed that Disk1 is the Drobo.

hi Swifty - can you post any more details about your computer and drobo setup?
nice website btw

The PC is a Lenovo M58 (owned by my employer) with 3.0GHz CoreDuo. The Drobo is USB attached via a system-unit port (i.e. no external hub). I have three 1Tb and one 1.5Tb drives (varied manufacturers).

The performance is getting really poor now, but still no errors reported (other than the ID=51 ones in the system log). I just loaded a webpage from a local server which included 25 small GIF’s from the Drobo. In the past, the page would have loaded in a blink; now it takes about a minute.

I’m wondering if there are internal Drobo logs that I could somehow get to?

Listening to the Drobo with my stethoscope, it sounds quite noisy. I heard a drive spinning up despite the fact that the Drobo is in constant, if intermittent use. I can hear continual disk seeking, so I wonder why a drive spun down unless something sent it a reset?