Drobo

Strange connection problem for 5N2

I have a Drobo 5N2 attached to my network via ethernet. My MacMini running Big Sur and attached to the router via WiFi is now seeing it twice. It sees two names: drobo5n2 (kind-PC) and Drobo5N2-3 (kind-Mac). If I click on either one I see all the same files. How did I end up this way and is it an issue?

1 Like

FrankDay, did you ever find out why you are seeing the drive twice? I see that also and have never understood why, or whether it is a problem.

I’d imagine you have both AFP and SMB sharing enabled on the share, your device will see both protocols as different, hence showing up twice.

As to if it’s a problem, I don’t know how a Drobo would handle the same file trying to be opened for writing by both protocols at once, either protocol by itself should deal with such attempted dual access, but potentially some issues might arise in such a situation, I honestly couldn’t say if they’d be access denied, file in use errors, or file corruption though.

The “kind-PC” instance will be using SMB, & also accessible by Windows, the “kind-Mac” will be AFP, & would be needed by a Mac running Mountain Lion & earlier, anything later can also handle SMB.

I don’t know if there’s a means to turn off or select protocols in Dashboard, if there is & you know you’ll only be accessing with one type of device, then turning off one protocol would cause one instance to disappear.

Note: I’m a Windows user & only have direct attached Drobos, the above is deduction of what’s most likely going on.

Depending on your situation, I can think of a few ways to disable the AFP share from showing up on your devices and using SMB exclusively (I would assume you would want to use SMB as it is the faster, more efficient standard. Even Apple is deprecating AFP and moving towards SMB, if I understand correctly).

  1. You could block port 548 (the port used by AFP) from your Drobo at the network level, if your network devices allow for this

  2. Block port 548 from your Drobo’s IP address on your Mac devices.

  3. I’m not sure how safe it is to do it, but you could try to disable afpd from starting on your Drobo. You would need to do this via SSH and I’ve not figured out the details of it quite yet, but I do see the following processes running on my Drobo 5N2:
    /sbin/afpd -d -F /etc/netatalk/afp.conf
    /sbin/cnid_metad -d -F /etc/netatalk/afp.conf

I haven’t found how these processes get started (they don’t show up in init.d), so I would still need to investigate.

I only use Windows and Linux, so this hasn’t come up as a problem for me and I would have little way of testing it, but I’d be glad to help out if you wanted to continue to investigate this.