SOLVED: Root Password Recovery

For some odd reason, after upgrading to FW 1.2.0 I can no longer log onto my FS as root through SSH. I’ve tried the default “root” password and still no go and any other variation of password. I’ve tried the Drobo Factory Reset, but that doesn’t really reset anything to factory other than deleting all shares/accounts and default admin password.

Any ideas on how to get it back?

How about if you uninstall ssh and reinstall it?

Did that.

Actually researching I found the problem…

My /var/.passwd file has root using /bin/bash as it’s shell. This was a symlinked file to /mnt/DroboFS/Shares/DroboApps/bash/bin/bash. If I restore the symlink or change the passwd file for the shell, I should be able to get in. I think the symlink went missing after a firmware upgrade.

any suggestions on adding the symlink now to /bin when the permissions are root:root 755?

I’ve actually rolled back the drobo to first version of firmware and updated each one since all the way to 1.2.0 in hopes it would reset the internal host files, but it doesn’t.[hr]

Hmmm… I wonder if I can add “ln -s /mnt/DroboFS/Shares/DroboApps/bash/bin/bash /bin/bash” to a service.sh file and reboot if that will work… DroboApps.sh is run by root at bootup… worth a try!

Ouch - now I know why ricardo told me not to try and set bash as the default shell. Once you get back up and running, you might just start bash with “bash && exit” immediately on logging in - that way as soon as you exit bash, it also exist the outer sh connection. Not quite as seamless as just having bash be your shell in the first place, but safer.

Got it working. I never planned on doing the firmware upgrade. I never do firmware to a storage type of device, but my wife used the Dashboard on her laptop and saw the notice and thought she’d be kind to do it. If I apply a firmware, I have a list of things to do before. One of which is setting the root password to default and changing it to /bin/sh. However when logging in, I never got an error message about the darn shell. Oh well… forgot the service.sh files run from root and you can basically do anything from those.

how did you get it working?
i’ve got my drobo FS direct connected to a snow leopard machine, and its mounting all shares and droboapps fine (first time in a week).
need to ssh into it to regenerate my corrupt CNID db file, but it keeps erroring out with “port 22: connection refused”.
apache is running, but droboadmin doesn’t work (404 not found).
and dropbear should be fine, since its folder looks populated.
any ideas?

I ended up modifying the service.sh file and at the end writing up the code I needed to get things working. I would try there, although be careful, one bad line could cause a lot more heartache than the help it gives.

I guess, everyone is spamming out here with lengthy and not so valued content.
The answers are so lengthy, I haven’t even read the full answers.
So this time, my solution wouldn’t be that legthy.
I would suggest you to checkout this article posted on EasyTechTools Blog where they have mentioned various free and paid Password Recovery Tools. One of them is Outlook Password recovery tool
07 Best Password Recovery Tools l EasyTechTools