SOLVED: Deleting Time Machine Share Does Not Reclaim Space

Time machine sparse bundles have ludicrous numbers of files.

The recommended approach to removing them is to reformat on most communities, as even listing the bands will simply hang until your great grandchildren find your computer still running under their inter-dimensional space-planes.

I went to delete an old sparse bundle by deleting the “backup” share, but it appears it’s not properly reclaiming the space!

Despite a 700 gig sparse bundle and share vanishing into thin air, the % space used remains stubbornly the same.

It now registers the space formerly used by this share as used by my main share in ‘df’ on the terminal, but a closer analysis with du shows the files used are 700 gigs less than the reported filesystem usage.


Installed dropbear (LINK HERE) on the 5n, logged in via ssh, ran a find for the .sparsebundle file “#find /mnt/DroboFS -name *.sparsebundle”, moved it into an existing share (then disabled dropbear to preserve security).

I then created an empty directory /emtpy on my mac and executed:

rsync -a --delete empty/ /Volumes/Sharename/File.sparsebundle/

(unfortunately, rsync is not installed on the light distro running the drobo, so this can’t be done locally, you must mount it on a host machine)

This took a few hours to steadily do its work (network latency), freeing the space. (you can watch it do its work with ‘df -m’ about 20 meg a second, even though nothing is actually transferred over LAN)

(reference here: )

hi its cool that you solved the problem you had :slight_smile:

just wondering how easy it was to get dropbear, because im pretty sure a lot of users were asking about it where it seemed to have vanished off the face of the earth? :D[hr]
btw your link captured a bracket at the end and doesnt work.
if you can tweak it if possible it will be cool

it’s linked off the droboapps section (solution post updated with link). The forum post is there with the packages linked bottom-post. Just untar, drop into droboapps share, and reboot.

just be insanely careful with it. the root password is so insecure a 5 year old could crack it, and I suspect attempting to mess with the password will break other mission-critical configs drobo inc put into the device to make it “just work” (not to mention potential shellshock implications leaving it on). I’d only enable it when you actually want into the device.

cool i dont have any nas models, but thanks for info and link tweaks.
actually i think the only reason i had a drobo share was that it came free with a gen2 :slight_smile: