[SOLVED] 5D does not show up in Windows 10 File Explorer

5D is showing in Drobo Dashboard and Windows Device Manger but does not mount in File Explorer.
I was able to update to the latest Firmware using the Dashboard but the 5D still does not mount.
I tried on two different Windows 10 computers with the same results.
5D is connected via USB 3.
All drive lights are green. Power light green. Blue lights showing expected capacity.

I tried shutting down via Dashboard and unplugging power for 30 seconds, but still not mounting.

When using Safe Remove, the unmounting Windows chime sounds so the device is connected, it’s just not showing up.

Has this Drobo been formatted yet? Is it a new volume or has it worked before and now it doesnt?

hi colin, is there any other info you can see in dashboard about the drive or volume status?

also, are there any other services running such as search index/catalogue, or antivirus firewalls that you could try disabling after disconnecting from the internet, as a test?[hr]
ah nice one dslam just saw your post - good questions too :slight_smile:

This Drobo 5D has been working for years, no problem. I have done nothing to it recently; no new disks, no configuration just the Firmware but it wasn’t mounting before the Firmware either.

Dashboard looks and acts as if everything is perfect. All drives are Good except Bay 2 is “Warning” but it said that when it was mounted on Windows 8.1 too.

Just disabled Windows Defender and the Windows Firewall and no change. I did not reboot though.

First step is to try rebooting

second step is to look in windows disk management console. 1) do the partitions show up there… and if so 2) do they have drive lettersassigned?

if they do not you can easily assign a drive letter to them there and then they will show up in windows explorer

I just booted from my Windows 8.1 drive and the Drobo 5D mounted like a champ.
Same machine, same setup, same USB 3 port.
This is the original drive that the 5D was setup on - not sure if that is significant or not.

Wouldn’t this confirm that the issue is not the 5D, but rather Windows 10 on the two computers I tried?

Here is what it looks like in Device Manager. FYI, this is exactly what it looked like on both Windows 10 computers where it did not mount in File Explorer.
I do not have any partitions; it’s a single volume for video production.

In case the HTML formater fails, this is the image: http://imgur.com/lrVJ0OM

its not device manager… its DISK management

And volume and partition mean the same thing - so you do have one… you need to look in DISK management and see if:

  1. it sees the volume/partition
  2. it has a drive letter assigned (if it does - does it conflict with anything else - mapped network drives for example)

Sorry, I wasn’t paying attention.

With the 5D mounted in Windows 8.1 it does have a drive letter and mounts fine. I’ll boot into Windows 10 later today and see what Disk Management shows.

occasionally windows cant/wont assign a letter to a partition, or gives it one which is already occupied by something else.

thats the first thing i would check, can disk management see the partition and what does it say

Docchris, YOU SAVED ME!!

Unbelievable that such a simple thing fixes everything. I have to admit that I have never run into this and never even thought of it as an issue and I’ve been in technology for over 20 years!

For the record, and for anyone else you needs this fix, I Right-clicked on the Drobo partition in Disk Management and chose Change Drive Letter and Paths. Clicked the Add button and let Windows pick an available letter and just like that the Drobo mounted.

Glad it was such a simple fix!

Most of the time drives not showing up was because they were given the same letter as a mapped network drive (but i think windows wont do this anymore)

Part of the issue is that windows “remembers” the drive letter settings… so if it fails to assign one when you first plug it in… it will “remember” that that particular volume doesnt get a drive latter

That makes perfect sense as to why it happens and I’ve filed this one away in my troubleshooting tips for the next time it happens.
Thanks again so much.

nice one docchris

Hello, I am having a similar issue. I have move my 5D to a new windows 10 PC and the drive is not coming up in Explorer. I have tried lots of different drive letter but it just wont work :frowning: It is still working when connect to my original Windows 8 PC. When in Windows 10 my Drobo can be see by the Dashboard and there is a drive letter in Explore but I get an error message when I try and open the drive. In Disk Management it shows up as a “RAW” file format and not the NTFS that it is. Also in the Dashboard the volume is not showing the amount used. It looks like the Windows 10 PC sees it as an empty unformatted drive.

Does any one have any ideas what is wrong?

Many thanks

hi mike,
running a chkdsk via windows 8, might help, especially if there are any discrepancies however minor on the ntfs filesystem, and then once complete, to use dashboard there to safely shutdown the drobo, and to then fully boot up the drobo (on its own, which should then go into standby mode) and then to fully boot up windows 10 on its own, and then to connect the standby drobo to the windows 10 computer… what happens now?

btw if this does not help, would it be possible for you to create a new separate thread, just to keep it separate?
(we can still link them together etc, its just that with the original posted having marked it as [SOLVED] it would probably be best to continue further on your own post)[hr]
(edit: you may enjoy climbing, but colin may not appreciate all the extra emails with you piggy-backing on his case) :smiley:

All fixed, thank you Paul :slight_smile:

cool mike :slight_smile: