Drobo

Solution Drobo 5D USB 3 disconnect or slow data transfer

I swapped two different Drobo 5D chassis with support to try and resolve an issue. The device would randomly unmount and then remount. Also, data transfer rates were awful. It would start a transfer and then after 2 seconds it would stop for 4 or 5 seconds and repeat that until the task was finished. I decided to look at different types of USB 3 ports. My computer has a set of USB 3.1 port made by ASMedia. Those do not work well with the 5D. I have a set of Intel USB 3.0 ports and those have the same problem. I have a third set from a “Generic” card purchased from NewEgg. Those work fine.

I ran an AJA system test on the device after it was connected to the Generic port. Write speed was 280 mb/sec. Read speed was 219 mb/sec. When connected to the 3.1 port from ASM or the Intel version my write speed was 23 mb/sec and read speed was 15 mb/sec.

My speculation is that the “generic” USB card is “legacy” and works well with the 5D for that reason. If your USB hub has newer drivers they probably will not work well with the 5D.

pc

You may be onto something here, I have an older Gen 3 4bay, it has served me well over the years. I upgraded my PC to a newer Dell xps 8930 which has all USB 3.1 port. Since then, my drobo has become unusable, in the way it reads and writes data! Sometimes it crashes just trying to open a folder. After reading your post, decided to use my note book which has older USB 3.0 ports, and drobo transfers and writes at regular speeds again. So I am thing that I will need a usb 3.0 expansion card. Any other suggestions, I would appreciate .

Hi! I just want to post to say that I’ve just experienced exactly what cspvideoandmediallc posted about last November and I’ve implemented the same solution.

The TL;DR of all the below is this: I think the Drobo Dashboard/Drivers are incompatible with the USB 3.0/3.1 chipset/USB generic and ASMedia drivers on Intel-based motherboards.

I’ve come to this conclusion after a very trying, very difficult 6 weeks of crossing a hard drive and data hellscape and just today finally yielding some results.

I’m not an engineer and have no way proving the above statement, so please don’t take this as me dunking on Drobo, but I want to share my experience so that anyone else finding these issues can take similar steps and perhaps the folks at Drobo can take another look at these issues instead of just telling me to factory reset my Drobo again.

I’ve got two PCs and two Drobo units. A 5D and an a 5D3. Both units experience the same issues on both PCs when plugged into any of the USB 3.0 or USB 3.1 ports on the motherboard. One of my PCs also has an ASUS X99 Deluxe II motherboard with a USB-C port. Out of curiosity I used a USB-3 to USB-C adapter to try that one out. Same issues.

To be clear, my Drobo 5D worked fine for probably over a year, but I was getting lots of weird slowdowns that just seemed to be getting worse over time. Finally, transfers became nearly impossible if they were larger than a few GBs because of the slowdown/stop. I had to cancel transfers and sometimes relaunch Windows Explorer before I could shutdown windows. Often, when shutting down windows, I’d get an error like this:

DRoboError

This was all on my PC in my home office. Finally I brought it into work this week and tried what I should have tried a long time ago, and tried my 5D on my office PC. Same errors, same slowdowns, same results. Totally different (and old) Intel motherboard & other hardware. Clearly, I thought, my 5D was the problem. But then I took a 5D3 we have here at the office, swapped my same hard drives into that chassis, and all it did was give me all the same issues across both PCs and in all my USB ports.

Finally, I tried the USB hub in PC#2’s PCI slot. Everything is working just as it should. No slowdowns, no errors, currently transferring top speed.

Here’s my totally uneducated guess: I think Windows updates and Drobo Dashboard updates have come into conflict. The slowdown over time, either from Windows 10 updating drivers in the background or from Drobo Dashboard updates, or the combination of the two, has crippled at least some models of the Drobo DAS line under Windows 10. I suspect the reason why I don’t see 1000 forum posts with people all over complaining about this issue is that it might very well be a specific motherboard/driver combination and is perhaps an edge case.

Either that or everyone out there, like me, was convinced there was something wrong with my USB ports/drivers even though every other external drive/device that I have are all working perfectly well and have been throughout all of the above.

Anyway, unless someone from Drobo is able to track this down and fix their software (or figure out where Microsoft is breaking things if it’s not a Drobo software issue), then it seems the only solution is to get some kind of “generic” USB expansion card for an empty PCIE slot and plug your Drobo into that.

I hope this helps someone else out there avoid similar pain!

So, an update. My issue has returned using the internal PCI-E card. I bought an external USB-3 hub as a test, but the issue persists. Only a few hours after I wrote the above post, I was noticing my Drobo slowing down and starting to exhibit a “Wave” pattern in transfer speeds, constantly fluctuating between a few KB/s and climbing up to 128MB/s and then dipping back down. Eventually, the bottom of each wave dips to 0 KB/s and it sits there for 30s or so and then comes back up to maybe 60-70 MB/s for just a brief second or two before dipping back down to 0. Eventually, the connection just drops and there’s a Windows 10 error about the file not being found. Now, I’m once again at the point where any file transfer has a wave or two and then just errors out.

My only guess is that there’s something with Drobo firmware/software and an interaction with the drivers in Windows that is steadily corrupting SOMETHING. Obviously I’m not knowledgeable enough to track this down directly so I’ve written Drobo support again and see if there’s something they can look into as this has become totally repeatable for me.

I have two Drobo units, a 5D and a 5D3 and they both exhibit the same behavior across two separate PCs with very different (but still Intel-based) hardware. The only way to get expected performance back is to re-install Windows 10 and flash the motherboard Bios by removing the CMOS battery. I can then get my performance back, but only temporarily. I’ll start copying stuff to or from the Drobo as a test and the copies will run as expected for maybe 28-30 hours, but then they start to slow and over about 5-8 hours eventually I’ll end up with the behavior above (slowing to 0 and then erroring out.). I then tried what I thought fixed it–detailed in my previous post about the PCI-E USB3 expansion card. But, as I said, only a few hours later I get the same issue when connection through the expansion card.

Different ports, different cables, software removal/reinstall, setting the Drobo to read-only, etc., nothing changes. Both my 5D and my 5D3 chassis exhibit the same behavior over any USB 3.0 port that has come to this point.

It’s like the Drobo/Windows I/O interaction starts out fine, but then gets corrupted. At first not really noticeable, but then it cascades and goes down hill real fast and isn’t recoverable by simply reinstalling the Drobo software.

To be clear, any other device I plug into these ports work fine and transfer speeds are as expected. This is only an issue with my Drobos which is what leads me to (I think) a logical conclusion that the Drobo software and/or firmware are the issues.

I suppose a way to narrow it down would be to flash the Drobo back to old firmware and use an older version of the Drobo software, but I don’t know if that’s possible.

I was able to use my Drobo 5D for quite a while without any issues, so it seems like perhaps a firmware or Drobo software update is the problem. Anyway, I’m writing Drobo support and I’ll update this thread again if anything comes of it.

I am having this exact same issue… I’ve been pulling my hair out for days trying to figure out what the issue is. Started off with my older 5d - kept disconnecting from the PC as if it were unplugged… copy data on/off was impossible… Chalked it up to the drobo just dying - bought a new 5D3 (2 actually) and I’m getting the exact same data transfer issues. Starts off strong for about 2 seconds, then drops to 0, for 20-30 seconds, gets up to 10-12MBPS and then drops back to zero.

I assumed the first Drobo I got (amazon warehouse deal) was defective, so I ordered a new one - Having the exact same issue… thought it was a bad cable… bought a new USB-C / USB-A 3.1 cable… same issue… tried a second (Intel) PC - same issue. And the issues with the original 5D started shortly after the last 4.13 firmware update, and has previously given me no issues whatsoever for years now.

So… to recap - 2 brand new 5D3’s - 2 different PC’s - 2 different USB cables - and I still have the exact same problem. Also worth mentioning, I had NO ISSUES transferring data via Thunderbolt to my new Mac Mini - but, since the original array is NTFS, I can’t do anything with the Mac. Definitely seems to be a Windows / Firmware issue.

Just decided after reading the above posts to test my Surface Pro 4. 200+ MBPS and no issues whatsoever transferring 6+gb movie files - they all transferred almost instantly. I’m not sure if it matters, but the SP4 does not have the Drobo dashboard software. Now to test my original “dead” 5D

Thanks votava63 for posting your issues as well! It makes me feel a lot less like I’m taking crazy pills over here :).

I did neglect to mention that I, too, tried my Dobo 5D on my MacBook Pro. Mine are also formatted NTFS so while I can’t write to it from my Mac, I can copy from it just fine at max USB 3.0 speeds. I did this test back in the middle of my other issues over the past 6 weeks so I’d actually forgotten this until you mentioned it here and that reminded me I’d done the same thing. So thanks for posting! I haven’t tried this on the 5D3, but, as I said, similar results with my 5D<->MacBook Pro.

If you don’t mind, I’d suggest writing Drobo customer support as well and linking to this thread. It’s one thing having a single person with this issue (even if I have two units and two PCs to test with), but having another person with a bunch of Drobo chassis and a Mac all exhibiting the same behaviors I think has gotta be compelling enough for them to look into this at an engineering level instead of just a CS level.

Is there anyway to roll back the firmware? I noticed they don’t have any previous versions posted… at least not that I’ve found thus far.

Not that I can find, either. I’ve read a few forum posts where the replies were “you can’t” roll back firmware with a Drobo. Firmware updates might just be one-way for the end user. There might be something similar to a CMOS battery-removal in the hardware somewhere, but that would require opening up the unit and voiding the warranty.

You cannot roll back firmware updates.
On the USB 5D issue… my accidental findings were:

  1. The 5D is considered a legacy device
  2. It was not made with USB 3.1 or any later revisions in mind
  3. The more generic the driver the better
  4. It does not work with Intel usb 3.0 drivers or ASM drivers.
  5. It only worked with an off brand, out of date, legacy 3.0 card. Might be a Star Tech card.

The thing on my system, though, is that I have an old/legacy PCI-E expansion slot with drivers that aren’t USB or ASM. Of course they could just be afflicted with this same issue so it might be a moot point, but I’m somewhat unwilling to just keep buying expansion cards until one works. Perhaps that’s the only way out of this, though. It takes a couple business days for Drobo support to get back to me, so still hoping that they’ll see this thread as a sign that this bears a closer looking-into.

So I heard back from Drobo CS and while there aren’t any real updates at this point, my CS request this time was at least interesting enough to be “forwarded on to management” so I suppose we’ll see if something gets tracked down.

FWIW, it was also confirmed that “This seems to be an issue with the USB drivers that Windows or the Motherboard/USB hardware manufacturers provide - Drobo Dashboard does not install USB drivers.” Which makes sense but doesn’t exonerate Drobo hardware/software in my mind. It’s a good tidbit of information nonetheless.

Yes it makes sense, but doesn’t the 5D3 eliminate the problem? So they basically know the solution and can’t implement it by firmware in the 5D. And, yes, it is all about the Motherboard chipset.

No, unfortunately. Both myself and votava63 area having the same problems with both our 5Ds and our 5D3s. vorava63 even bought two 5D3s recently and is having these issues, so recent hardware isn’t a solution.

Hey cspvideoandmediallc, do you happen to know what kind of extension card you have? I know you said StarTech, but wondering if you know which model since they seem to have a ton LOL :slight_smile:

PEXUSB3S23 is the model on the card

Thanks much! I’ll order it and see if I can get similar results.

UPDATE: I can’t get this card to work with my PC. Tried various drivers (both from Startech and from Etron which are apparently the root manufacturer) and no USB device shows up. I can get the card driver/card to show up in the Device Manager with the proper driver version apparently detailing it, but none of my devices work when plugged in. I suppose it could be a bard card.

I did get someone from the Drobo team reporting this issue to other folks for a deepr dive into it, partially thanks to the folks on this thread. Anyone else have any results to speak of yet?

Hi. I just sent a support ticket facing similar issues as described here. My 5D3 was working fine until I re-installed Windows 10 last week. Now the Dashboard is having trouble discovering my device. And when it does, transfer speeds go in waves, dipping all the way down to 0 and averaging less than 20. Other devices plugged into my Intel USB 3.0 ports work fine.

I’ll update when I hear back from support.

1 Like

I stumbled upon this thread after attempting to figure out what the heck was going on with my Drobo 5D (purchased 2013) and my new 2019 iMac and thought I’d leave my experience for posterity in case anyone else has the same issues in a similar setup.

I recently upgraded from a 2012 iMac and was connecting the 5D via Thunderbolt 2 and connection and performance was solid as a rock. After upgrading I switched to a USB3 cable (as my 2x thunderbolt ports on the new iMac were already taken) and found that after ~24 hours, or so, the iMac went to sleep and awoke I’d encounter upwards of 50 notifications stating that there was severely low disk space on the Drobo although there was >75% available capacity.

That would occur until the Drobo would eventually dismount entirely, and I could only get it back by either rebooting or removing the USB cable from the back of the iMac, waiting a few moments, and then plugging it back in. I thought perhaps the issue was the brand of USB 3 A to B cables I purchased, so I bought 2 more cables each a different brand. After days of testing, both followed the same pattern of erroneous notifications that there was extremely low disk available and then losing connection entirely.

After seeing discussion here about potential USB port driver/compatibility issues I’ve attempted plug the USB connection not directly into my iMac, but into my Anker USB 3 hub, and so far so good. We’re now >72h without any of the previously experienced behavior that would have occurred many times over by now.

tl;dr: if direct USB 3.0 cable connection is regularly dropping out and a change of cables isn’t working. First, try a different port, and then attempt to connect via a hub.

Bought a Drobo Gen 3 2016 and was very happy till … the day before yesterday. That’s when I updated to the latest Drobo firmware. Since then I experience the same wavy speed horror. It drives me crazy.
Does connecting through a USB 3 hub instead of directly to the ASMedia USB 3.1 really solve the problem?