Drobo

Slow transfers for some files, but not others

I’m experiencing this strange issue where certain files transfer very slowly (around 5 MB/s) from my Drobo FS to my PC or Mac, while others transfer as fast as they should (around 30 MB/s). The ones that transfer slowly always transfer slowly, and the ones that transfer quickly always transfer quickly, which makes me wonder: Is it possible that the files that are transferring slowly are being stored on a drive that’s about to fail?

I’ve got 3 new WD 4k sector drives (2 x 1.5TB and 1 x 2TB) and 2 old 500GB drives, so maybe another possibility is that the mixing of 4k sector drives with non-4k-sector drives is causing some sort of conflict that’s slowing things down?

Probably to do with type of files and how big or small they are.

There is a difference depending on these two properties, on all types of storage, even on SSD’s.

That’s what I thought initially as well, so I tried testing files of the same type and similar sizes, and I’m still getting discrepancies in transfer speeds. i.e., Even if file A and file B are of the same type and similar sizes, A will always transfer at 5 MB/s, while B will always transfer at 30 MB/s. The only explanation I can think of is that file A is being stored on a faulty hdd.

I am seeing the exact behavior as well and my plan is to send in a support ticket, though i haven’t got around to do it yet. Good to see that others experience the same thing.

My drive array consists of 3 WD 1Tb new drives of the same kind.

Cheers,
Mattias

I have a support ticket in now, anyone have any response from them on this yet?

Not yet. Could you please let us know when/if you find a solution? Thanks.

More likely, it is related to internal Drobo fragmentation : your “fast files” are properly splitted over all drives, while your slow ones are improperly so. This is more likely to happen when your Drobo is >50% full and/or has been formatted a long time ago with multiple writes/deletions since.
Read those threads about similar problems :
Old files transfer fast, while new files transfer painfully slow
Report Your Drobo (V1, V2, S, FS, …) Performance !

Good luck with DRI support on that one : this fragmentation issue is supposed to be taken care of on the fly by the Beyond RAID algorithm, but obviously it does a poor job of that when the Drobo fills up and performance wears down.
And DRI is unlikely to admit it until they find a better solution…

I’ve just submitted the log files they asked for as well as the read/write tests.

the tests they had me run were getting about 25 MB/s read, and 15 MB/s write.

I’ve got files that transfer off the drobo at 5 MB/s.
can get the same file over the same network from my ubunutu server box, off a USB2 drive at 30MB/s

5MB/s is really pathetic.
it’s one of the earlier files i copied to the drobo (went in on the initial load), and even now, i’m only at 50% fill (2TB of data on 3-2TB drives)

Did you have a look at jumbo frames if ur entire network supports it?

Hi.
Any updates on your support ticket?

After a couple rounds of tests, their answer was “change the ethernet cable”. I’ve been working stupid long hours at work so haven’t really had a chance to follow up past that.

But it’s getting unusable at times, i’ve seen speeds as low as 1MB/s. My torrents are on the drobo, and when hashing folders with several large files, some fly through, others crawl, no rhyme or reason. similar sized files ( around 1GB) will take 20 seconds or 3 minutes (or more).

Don’t know if it’s related to being in “constant use” but there are periods of downtime and most of the time there’s only light reading going on if anything.
I also don’t know if the drobo will re-optimize itself. I’m not sure how long of time, if any, it needs to do that. Wish there was a way to force it to re-lay itself out.

waw74,

I too am back to getting around 1 MB/s (sometimes less) for no apparent reason. I’m experiencing some serious buyer’s remorse right now…

By the way, what router are you using?

So a small update, i think my problems stem from using rtorrent. Apparently the way it handles file writes leads to serious fragmentation of files. There is a patch available, but i haven’t tried it out yet.
http://libtorrent.rakshasa.no/ticket/460

There’s no way (that i’ve found) to check file fragmentation on files on the FS, but one file on an external drive that rtorrent saved was in over 5000 pieces for a 1.3 GB file, So i can only assume the Drobo looks the same.

after talking to support, there is no way to manually force a defrag on the FS, just let it sit idle, and it will fix itself, but you’ve got no indication that it’s doing it (without sending a diagnostic file to them, or possibly hearing disk activity when you’re not doing anything) or how long it will take.

the reading of a fragmented file, will slow everything down, so even files that aren’t fragmented are slow. as soon as you stop the read the speed jumps back up.
Which also might lead to some explanation why sometimes apple sharing is slow, as it’s trying to do something with the “slow” files, so it has problems reading the .AppleDB file that it needs to read.

One workaround to this i’ve found is to copy the slow files off the drobo, delete them off the drobo, and then put them back on. after that they go at “normal” speeds of 30-40 MB/s.
Also just did a test, and copying (not moving) the file to another folder, instead of to another drive, on the drobo also worked.

This is very important news for me, since I’m a heavy user of rtorrent. Thanks very much for the info.

Also, I second the motion for some tool to check fragmentation levels on the Drobo storage pool.

Everyone who is experiencing this issue please open a support ticket.

I just opened a support ticket. Will keep you posted on any progress.

The problem, when you have tens of thousands files on the Drobo, is that you may randomly access multiple “slow files”, with great detrimental effect on average, but little reproducibility.
This points again the lack of a “deep defragmentation” tool for the Drobo, since the “on the fly” built-in defragmentation does not do a very thorough job.
And yes, I opened a cause with DRI support months ago about poor performance, likely related to residual fragmentation, getting worse as Drobo fills up, and got no clear answer.

The only apparently fail proof solution seems to be a full copy of all files outside of Drobo, Drobo reformatting, then copy back of files.
But if you are like me, you bought a Drobo because you needed lots of storage, and you have not 100% more at hand, just in case… :frowning:

The support asked me to do a couple of transfer tests using a recommended app and attach the output and a Drobo diag. file to the ticket. After some days of investigation the reply came.

  • Your unit needs to be replaced because of a internal power distribution issue.

Hope next will perform better.