Slow Transfer Speeds and Disk Warning

I am having a speed problem with the speed of my 5N. It has 2 WD Red Drives and 1 WD Green, all at 2TB. I also have a 128GB SSD in the accelerator bay yet the best read speed I have ever seen was a burst of 40MB/s for 5 seconds when I was directly plugged into the 5N with GigEthernet on a MacBook pro. After that 5 seconds it leveled out to around 20MB/s which seems to be the most I can get out of it when hardwired. Big files vs small files doesn’t seem to matter. I have tried moving a 2GB folder of pictures and I have tried moving a 10GB folder of larger videos and it always levels around 20MB/s. AFP vs SMB doesn’t seem to matter either. I restarted the Drobo to see if that would affect speeds but it did not either. I have also tried from Server 2008, Mac OSX and Windows 7. The MacBook I tested with has a SSD in it as well so that should not have been a limiting factor. I have no DroboApps are running either and havent turned on jumbo frames or edited MTUs.

I also have a disk warning on drive bay 0 according to the software but the light is still green and I just want to see if I need to get the WD Red drive replaced while it is under warranty. Does anyone know how to see if the “warning” is a smart failure or what is going on?

Im on 3.1.1 firmware.

So, went through a bunch of testing again… apparently the 2 ethernet cables I used to test with were both Cat 5 and couldn’t move the full gig. I tried it with cat5e and i burst at 104 and leveled at 80 which I am much less upset about… though I do have the msata drive in there.

My question about the warning for the disk on Drobo Dashboard still remains though…