Slow read speeds when copying from drives

Drobo second generation was unmountable after power failure. Migrated drives to new 5D enclosure. Bought second 5D enclosure and filled with new drives for copy of 6.5TB of data. The copy is reporting it will take 1511 hours (62 days) and the read speeds are reporting 1.5MB/sec using Data Rescue 3.

I need to figure out how to make this copy go faster.

Details from dialog with tech support:
Almost in the home stretch I hope. Here’s the situation. To expedite the copy of the files I migrated the 4 drives with my data into the 5D that has the defective fan and connected the new 5D I received yesterday and installed all new drives.
Both drobos are connected via thunderbolt (the new drive) and USB 3.0 (the old drives) respectively. In order to ‘see’ / mount the old drives I first have to kill the process fsck_hfs process from activity monitor before it will mount the old drives.

Per earlier calls I purchased DiskWarrior and Data Rescue 3.
Here’s the thing. The reading of the old drives is taking tremendously long. As you can see from the screenshot below. I initiated a data recovery and the predicted time is 62 days (1511 hours) which just isn’t viable or realistic to keep that uptime to completion.

You can see that even though we’re running over USB 3.0 the Data read/sec is only 1.5MB/sec where we should be seeing 10x that throughput. It does occasionally increase by a few MB/s but usually closer to the number shown.

So…I could really use some expert help on how to best get the data off these drives and on to the new drobo. Is there anyone who can help?

hi adam,
a few things worth bearing in mind, are these:

  • if drobo is doing something else (re-arranging new data on it, or rebuilding, or settling etc) it will always be slower at other things too.

  • if something else is accessing the drobo, such as an active virus scan, or an indexing tool, that will slow things down too.

from reading your post above, (and i might have misunderstood something) :slight_smile: are you able to help clarify somethings please…

  1. you had a gen2 which was working (and then stopped working) but the disk pack was ok?
  2. you took the disk pack and put it into a new 5d (which was working properly and all green lights, or was it with a faulty fan?)
  3. the 5d worked and you were able to access your data correctly?
  4. you then got another 5d (which was working correctly and all green lights, or was it with faulty fan?)
  5. you then could see both 5d’s on your computer, and tried a copy and paste from one to the other? but its taking ages?

im not sure about the fsck_hfs and where the faulty fan came from, but it seems that it is part of a prior issue or an ongoing issue with the support teams? if so, it seems like you actually didnt have any working access to your data since the gen2 stopped?