Drobo

Sharing: DroboFS Performance problem (kind of solved now)

Wish this can help people with similar situation.

I bought a DroboFS to replace my DroboV2+DroboShare, as it claimed to have a much higher performance. But what I got is far far behind what is claimed.

My DroboFS was having firmware version 1.0.5 . My router/switch is Linksys WRT-610n, with DD-WRT firmware. I have used both Mac (OSX 10.6.6, over 802.11n and GB-Ethernet) and Win7 (over 802.11n). Read performance is around 3MB/s (Yes! more or less the same as my old droboshare, if not slower.). Used AFP and SMB and performance is more or less the same.

After searching thru the forum and someone talked about updating the firmware. Got 1.1 firmware it from http://www.drobo.com/support/updates.php and install, and Boom! performance boosted to around 40MB/s over GB Ethernet. However speed over 802.11n is still not that fast (still 3MB/s, and around 7MB/s using 5GHz… I bet that probably due to my router setting)

One weird thing is, I tried SSH to my DroboFS, tried
#cat some.file > /dev/null
to see the ‘non-network’ performance of my DroboFS. Tried several files, some works file but several of them simply keep running forever (waited for several minutes, while they are only 700MB-1.5GB)
Anyone can give some direction what may cause this? I just feel a bit not comfortable on the strange behaviour… :slight_smile: thanks :slight_smile:

i get about 7-8 MB/s using 5GHz, so that’s probably about right,
any number you see for wireless is only a guide, you can take a setup from one place that works great, and in another it will not, there are a lot of outside influences that come into play.

also…
are the files that keep running forever always the same one, so fileA.xxx always works great while fileB.xxx is always slow? if so copy fileB off the drive, delete it, and copy back on, and see if that helps. i had some serious fragmentation issues on certain files and it was killing the speeds anytime it tried to access those files.
the fragmentation was caused by the way rtorrent writes files. can’t check on the drobo, but on a local drive, some 1.1GB files were in close to 15,000 pieces.

In dealing with tech support he said he put in a request for a defrag utility, which the drobo does do on it’s own, but only in the background when the drives are idle. It would be nice to be able to manually start that.