Share Size Limitation

I’m trying to determine if the share that I’m using for my backup solution (AppAssure) is being limited in size due to the Drobo or a function of backup software. I have a 5N that acts solely as the repository for my backup software. The file system is NTFS. The total size of the 5N is 5.4TB (4 X 2GB). I have a shared folder for the software, and I have it mapped via UNC \Drobo5N\AppAssure\Repository. But instead of all 5.4TB being available, the backup software shows 2TB available. If I map a drive to the share (net map z: \Drobo5N\AppAssure\Repository), the mapped drive, z: in this case, shows all 5.4TB of storage available. I’ve opened a ticket with support of the backup software/. Thought I might fish for answers here as well.

hi, is your drobo empty and new, and do you know how much free space does dashboard actually show as free for your drobo?
and is it just 1 volume that your drobo has?

The Drobo is not new - we’ve had it for a while.
1 Volume, 5.4TB total space, 1.88TB used, 3.52TB free

hmm, have you tried a test backup (with a few files), using the mapped drive to see if it works?
if there are not any major drawbacks to using that method, and if it works, then maybe that’s the way to go?

So to follow up, in case anyone has a look at this thread, here is what I discovered. It turned out NOT to be a SHARE size limit, but a FILE size limit. This has something to do with the functionality of the Drobo 5N.
In the backup software, when you create a ‘repository’ where the backup database resides, the application immediately provisions that space in the form of a db file. The backup software asks you what size your repository is going to be - so in my instance, I had 3.5TB of physical storage space available on the 5N. Every time I tried to create the repository and define the size a 3.5TB, it would throw an FILE SIZE error. The max size I was able to define was 2TB.
This is interesting, because the Drobo presents the share to the OS as NTFS file system (map a drive to the share), which (depending on version), has a file size limit of 16TB to 16EB. FAT32 has a 2TB file size limit. Makes me wonder.
My solution was to create multiple repository directories and combine them into one single repository (within the software itself). So the total physical (usable) space on the Drobo 5N is 5.4TB. I have two folders, Repository and Repository-2, both of those folders have 2TB backup software db files in them (again, the file size limited by the Drobo itself). Within the backup software, I have in a sense ‘combined’ these two folders into one Repository so that I have 4TB of backup storage presented to the backup software.

well done for finding a way forward, i hope it continues to work for you