Drobo

Seemingly Dead Drobo

My 5Dt keeps turning off after about two or three minutes. This is a used unit I bought from a guy on Facebook, as my former 5Dt bricked! I wouldn’t have bought a new drive but I can’t find any in stock anywhere. As soon as it arrived (yesterday) I had to replace a failed 6tb drive (slot two) with a new 8tb. But currently, my space is critical. I have four 6tb drives and one new 8tb drive. The unit boots up long enough to give me a red light stating “critical” for the 8tb drive. But after a few seconds, all the lights turn yellow and then it tells me data protection is in progress. But within two or three mins of turning yellow, it shuts down.

Then it took about four or five tries at using the on/off switch to get it to reboot. I saw “took” as now the whole unit just stopped working except the fan. It won’t turn on now. I think I might have waisted the money buying this unit. I have tried pulling out all the drives and restarting, but nothing, no lights. I have tried different power bricks, nothing. I am at a loss.

I am open to ideas as to what’s happening and how can I fix this?

Just a few hopeful suggestions than a fix:

  • If it is a 5Dt, remove any mSATA from the bottom (power off first!) and try a restart with 2 spare HDDs installed and see if it powers up and initiates them (and keep a tab of your HDDs order that you removed).
  • Ensure your power brick (love your typo) is directly connected to a wall socket.
  • Turn off your Mac/PC and restart, then restart the Drobo.

Let us know if anything worked!?

Hi, Thanks for the suggestions. I tried these but nothing. Actually, it has gotten worse. While it used to at least start, now it will not start at all. It acts like it is dead, no lights anywhere, not even the power switch. But I assume it isn’t dead as the power BRICK :wink: has a light and now the fan spins continuously.