Drobo

RTorrent Setup Issue

So I followed all the instructions on here http://www.droboports.com/app-repository/rtorrent-0-8-9 to install rTorrent and everything seems to have installed fine but when I click the configure link from DroboApps Admin I get a “Oops! Google Chrome could not connect to 192.168.1.77” issue. Is there something I am doing wrong? The URL it is trying to hit is http://192.168.1.77/rutorrent/ which is the correct IP adress for my droboFS.

I also installed all of the necessary other applications before installing rtorrent or rutorrent.

Any help would be great, I am not a huge linux guy so I am learning as I go.

Also I am still restarting after an install since I can not seem to get installing over SSH to work either :frowning:

Instead of the IP address, try to use “drobo-fs”, “drobo-fs.local”, “drobofs” or “drobofs.local”.

With a bit of luck, one of these should work. Can you access http://192.168.1.77:8080/ ?

Using drobo-fs.local or any of the other work. If I go to http://192.168.1.77:8080 I see "This is a placeholder page for apache. Place your webpage content in DroboApps/apache/www.

If you are looking for droboadmin, you can find it here."

Okay, so the apache server is running, but lighttpd isn’t.

The fastest way to fix this is to SSH into the FS and type “/mnt/DroboFS/Shares/DroboApps/lighttpd/service.sh restart”.

The simplest way is to just reboot the FS.

I tried both and am having the same issue.

dropbear (Not Available)
rtorrent (Configure)
screen (Not Available)
curl (Not Available)
unrar (Not Available)
php (Not Available)
apache (Not Available)
lighttpd (Not Available)
wget (Not Available)
fuppes (Configure)
rtorrent (Not Available)

Above is the list of apps my DroboApps Admin says is installed just fyi.

What about http://192.168.1.77/ ? Does that show anything?

No that does not show anything.

Okay, so it seems your lighttpd installation is not working at all. I suggest removing the following apps: rutorrent, rtorrent, php, lighttpd. Once you do that, then restart your FS. Once the FS has rebooted, then install lighttpd again. If you do not see anything at http://192.168.1.77/ then there is no point going further.

Alright to uninstall them do I just remove their folders from DroboApps?[hr]
So I did all of that and still see nothing at http://192.168.1.77/ so what do I do now? Just for reference I am installing this version http://www.droboports.com/app-repository/lighttpd-1-4-30

FYI, there are some issues with lighttpd-1.4.30. Among others, make sure the config file is called “lighttpd.conf” and not “lighttpd.conf.default”.

That is weird. lighttpd.conf.default should be copied over to lighttpd.conf automatically if there is no lighttpd.conf available. I introduced that check to prevent overwriting the configuration file during upgrades.

It’s a sensible check; however, I tried installing fresh copies a few times, and it wouldn’t start until I’d renamed or copied the file. I don’t recall seeing anything in the service.sh script to handle that, but I’ve since downgraded to 1.4.29. Check the original forum post for 1.4.30 - I summed up my findings there.