Drobo

rtorrent install

Hi, I am interested in setting up rtorrent on my drobo. I am a complete noob when it comes to Linux. I am reading all these guides on how to install rtorrent, but all the info about compiling and dependancies make y head hurt! :slight_smile: I tried to install ubuntu on my mac using virtualbox… that just ended in a black screen.

Is there no way to get a pre-compliled version and just drop it in and run a few commands to set it up?

I am also interested in being able to get to my files when I am away from home. What app do I need for that?

Hi Mbeck,
If you have a look on Ricardo’s pages, you’ll see he’s got a an ‘install’ section, that has a link you can click on to download and install rtorrent without having to go through the compiling process.

The link is http://drobo-fs:8080/droboadmin/index.php?task=install&install=http://commondatastorage.googleapis.com/drobofs/rtorrent.tgz

You will also need to have to PHP and lighttpd already installed.

For remote file access, all you need is OpenSSH, and pureftpd. Then you can download files using an SFTP client. (I use Cyberduck on my mac).

Oh! lol, I feel Dumb! :slight_smile: I see that stuff at the bottom now. Thanks![hr]
I do have one more question though.

I want to install the DroboApps Admin Utility, and it says that Apache is required. Do I need Apache if I am using lighttpd?

OK, I got the admin utillity up ad running.

I cannot get rtorrent to work though. I installed it, and it seems like everything is OK, but I can’t access the web interface by going to http://192.168.1.101:8080/rtorrent/ (or http://192.168.1.101/rtorrent/)

I can get to it via file:///Volumes/DroboApps/rtorrent/www/index.html But it doen’t seem to really be working.

Is there anything I am supposed to do once it is installed?

That’s because rTorrent won’t work with the default Apache server from DRI (short explanation: their PHP module is incomplete). You need to use lighttpd and PHP from DroboPorts for that.

I have tried to make it so that these components “just work” together. In other words:
[list=1]
[]download lighttpd.tgz to the DroboApps share, install it
[
]download php.tgz to the DroboApps share, install it
[*]download rtorrent.tgz to the DroboApps share, install it
[/list]
After this, you should be able to see the ruTorrent interface at: http://your.drobo.address.here/rtorrent/

Notice that there is no :8080. I have pre-configured lighttpd to run at the default HTTP port.

Also, you should be able to reach the DroboAdmin webapp using lighttpd as well, at http://your.drobo.address.here/droboadmin/ (i.e., you can remove the DRI-provided Apache DroboApp - saves you memory and boot time).

Hi ricardo,

I have setup rtorrent & rutorrent with your tgz files, but it keep compliant reorient isn’t running.
How do I get retorrent in the background? I also see rtorrent asking for ~/.rtorrentrc while opening with screen.

Which version are you using?

that’s the latest one , r torrent 0.8.9

I am not sure why, after reboot the machine, now it’s running :slight_smile:

Ricardo,

I’m new to the droboports. I’m having issues seeding a torrent that I have in one of my drobo shares. When I add the torrent it just says Pausing. I assume it’s an issue with folder permissions but I’m not sure what to do with that. Any advice?

Thanks!

Edit: To clarify the file is in /mnt/DroboFS/Shares/[ShareName]/Etc/Etc/Etc

If this is related to permissions (which I’m not sure, since I’ve never had that problem myself), then what you want to do is this:
[list=1]
[]Login via SSH
[
]Go to the folder in question, by typing: cd /mnt/DroboFS/Shares/[ShareName]/Etc/Etc/Etc
[]Change the owner and group of the files to “nodoby”, by typing: chown -R nobody.nobody *
[
]Change the permissions of the files so that everyone can write to them: chmod -R a+rw *
[/list]
If this doesn’t solve it, then your best bet is to ask the almighty Google.