Drobo

"Replaced to many drives" error when replacing only ONE drive?

Hi
I have an original Drobo (1st gen).
4 disks inside: 2TB, 2TB, 1.5TB, 1.5TB
Formatted for 16TB

I passed the 85% mark and a yellow light went on on my 3rd drive (the first 1.5TB) suggesting a replacement.

I have two other 2TB drives and was planning on putting them into the Drobo to replace the two 1.5TB drives.
So I put my Drobo into stand-by and took ONE drive out, the third one, and replaced it with a 2TB drive.

Turned on the Drobo again and, after the boot process, all lights go red (steady). Drobo dashboard pops up saying I replaced ‘too many drives’!
I only changed ONE drive, and all the data has been protected for a while now (it wasn’t laying out data or so)

The drive I used came from a 2nd gen Drobo I have, but I had reformatted the Drive in OS X first before putting it in.

So now, for some reason, I can’t put a new drive in and I am running out of space.

Would anyone know why my Drobo won’t accept a drive replacement?

Thanks in advance

Hey, I experienced the same thing, and it turned out that Drobo did not like the new replacement drive. I was confused at first, because the new 2 TB drive was supposed to be good, but Drobo kept spitting it back out at me. I suggest trying a different replacement drive or putting the original drive back into the unit and letting it reset back to stable. I had a bad 2TB drive out of the box.

I’m going to take a flyer here…

It is possible that when the Drobo booted up it saw hidden sectors on the replacement drive, referring back to the V2 array. If it used that drive as the “reference” drive, then it might consider the other 3 drives all replacements and your replacement drive as the last used array.

It is possible that when you formatted the drive in the Max that the original Drobo markings were not removed. I think we have established that formatting a Drobo drive does not necessarily remove all the old Drobo signatures, such as when a drive is marked as “bad”. Since this is all proprietary and undocumented I think we would all be guessing at this issue.

I think we have had discussions previously and decided that it is better to hot swap a bad (or end of life) drive than to shut down and replace it, ESPECIALLY if the replacement drive was previously in a Drobo array at any point in it’s life. If you shut down and install a drive that has never been in a Drobo it probably does not matter. But we have seen reports here of confused Drobos when a drive previously installed in a Drobo was inserted as a replacement when the Drobo was shut down. When you hot swap the drive then it is clear to the Drobo that the replacement drive really is a replacement.

I also don’t like hot swapping out a perfectly good drive that is just being upgraded. My feeling is that pulling a good drive (that is spinning) out of any device is just not a good thing to do. Pulling a failed/dead drive is different because in principle you don’t care about the drive anymore (although with a Drobo it may still be good for some other uses but that is another debate). However, I don’t think I ever upgraded with a drive that was previously in the Drobo (and that is somewhat abnormal atypical?). Knowing what I know from what has been posted here if I were to reuse an old Drobo drive I would hot swap it, being the lesser of two evils.

Does that make sense?

If it were me, I would contact support for a recovery procedure. If I couldn’t do that, I guess I would shut down the Drobo, then restart it with only the 3 good drives. Then if it looks Kosher I would install the new drive while it is up and running. But a mistake here could hose the array,which is why it would be better to get tech support at this point.

I don’t understand yoyama’s suggestion because if he had installed a bad drive then only that one drive should come up Red. In your case all the drives are Red, which indicates a failed array. He may want to clarify that he also got 4 red lights, etc., exactly as you describe.

[quote=“NeilR, post:3, topic:2570”]I don’t understand yoyama’s suggestion because if he had installed a bad drive then only that one drive should come up Red. In your case all the drives are Red, which indicates a failed array. He may want to clarify that he also got 4 red lights, etc., exactly as you describe.
[/quote]

It was a year ago, I might be fuzzy on the details. Sorry. I was more posting to suggest that the OP put the original drive back into the Drobo and see if it comes up stable. Better to have Drobo over 85% with one Yellow lamp, then to have it not able to protect your data from a disk failure.

All,

First of all my apologies for taking such a long time to respond (been busy rebuilding!) and thank you for taking the time to have a look at my problem.

Neil, I think you absolutely nailed it with your explanation. I also do believe that when I plugged my V2 Drobo drive into my V1 Drobo array and cold booted the whole thing it simply thought that this was actually a V2 array and that I was trying to replace three drives at at time in the V2 array rather than one drive in the V1 array.

Because my Drobo wouldn’t recognize my first replacement drive, I tried with my second replacement drive, hot swapping it this time. Initially things seemed to work OK, the Drobo hard at work rebuilding the array, indicating 130 hours of rebuilding time! (By the way, why is that always soooooo long?!). So I left it overnight doing its magic, but when I checked the next morning, all lights were flashing red, and Drobo said that my second replacement drive (2TB) had to be replaced with a higher capacity drive! Even though my replacement drive (2TB) had actually a higher capacity than the one I was replacing in the first place (1.5TB)! The available space on my drobo had also come down to zero. So either I was sooo unlucky that both my replacement drives, which were working just fine before I put them in the Drobo, failed at the same time, or something else is wrong here!
Now I’m back to reinstating my original 1.5TB drive just to get the Drobo out of his nonsecure states (the estimated rebuilding time being another five days!).

So, what are the results so far?

  • I am putting back in my original drive not knowing if that will work or if somehow that drive will fail too
  • I don’t know if I will get back to a secure state where my data will be somehow safe… the answer in 5 days!
  • My two replacement drives are now literally dead! After their Drobo experience I just tried to reformat them in my Mac and both won’t even format anymore (I now get I/O errors when trying to format them in OS X even though the drives formatted and worked just fine before).

I don’t know if this is because my two Drobos belong to the first generations and hence are more unreliable but over the years I’ve had so many issues with these devices that I think that if I manage to recover my data I will just copy them on a regular drive and sell the Drobos.
I’ve lost a full Drobo array once before (for no good reason) with all my data on it… and from the looks of it I haven’t learned my lesson.
Even though they are super convenient, I just don’t trust them anymore. Unless someone tells me the newer generations are more reliable.

Thank you so much for your help and in five days from now I can let you know if I managed to secure my data.

Two more questions if I may:

  1. While it is securing the array, can I turn the Drobo off? Into stand-by mode I mean? or do I need to leave it running uninterrupted for the next five days? I’d like to keep the Drobo in its current state while I order new drives.

  2. Can I copy data off the Drobo since it is still accessible while it is securing the array? Current status being: Red lights flashing, Data at risk. Drobo cannot protect your data against HD failures…etc.
    I’d like to save as much data off the Drobo as I can before something else goes wrong.

Re 1) Yes, in principle, you could turn it off while it is relaying, and then restart it later. However, that would not be a good idea for two reasons… first, because it is in the middle of a relay, you MUST let it complete this relay and get back to a green state before you replace any drives, even the one you last installed. Second, turning it off is just tempting fate- testing DRI’s backup battery circuitry. It is supposed to recover from a loss of power during a relay (that’s more or less how you have to stop it). But I think you’ve been through enough that you should not be testing their backup battery at this point in time :-).

  1. In principle, you can copy the data off while it is relaying. However, personally I would not, for a couple reasons. First, the throughput performance will be terrible. It might be something like 4-5MB/s. If you have a few terabytes of data it will take a week to get the data off. Second, the relay, by itself, is very stressful on the drives. It seems to me that forcing the Drobo to do two very stressful things at once (a relay and a bulk copy) is just going to make it thrash harder. And third, it will probably take the same amount of time to get the data off either way because the drives are already working full bore.

Now, if you have a relatively small amount of very critical data that you want to pull off while it relays, that’s fine (in my opinion). The above is just my personal opinion regarding a full bulk copy during the relay. I would just use common sense to decide how much, if any, to pull off during the relay, considering what I just said, and what I am going to say below.

How much data is on your Drobo? When I last upgraded a couple of drives I had 3TB of data on the Drobo and each relay required about 63 hours. My number is consistent with other numbers I’ve seen.

It is likely that the majority of Drobo users do not back up their Drobo arrays. Your case is a good example of why even a Drobo is not fail safe. And personally, I think these Drobos (or at least my Drobo V2) is probably as close as you can get, considering all the possible things that can go wrong with any Raid-like technology. My V2 has been running 24/7 for over 2 years. I have never lost a drive but I have done at least 4 upgrades without a hitch. My Drobo is not very fast (I have performance issues with it) but it has been reliable. Your mileage varied.

The biggest problem with the Drobo, in my opinion, is the 65 hours of relay time (for me, YMMV) during which the Drobo is working the drives at 100%. If a remaining drive is marginal, this is when it’s going to fail. And this is why these can never be fail-safe devices. We live in a world of sub $100 drives that are built to a price. Just reading hard drive reviews on NewEgg or Amazon, you’d think it would be a miracle any of them work at all.

This may not be as true with a 5 bay unit run in dual redundancy but there are other things that can go wrong.

It was not clear to me if you tried to hot swap in the first 2TB drive that you first cold booted. It sounds like you tried it too, in a hot swap, and it failed? And is now unusable in your Mac?

One of two things happened here:

  1. You were unlucky and actually had two drives fail quickly.

  2. The Drobo has a hardware defect and killed the drives.

If #2, then you would expect the Drobo to kill the 1.5TB drive you are now adding to the array. So logic dictates that if this 3rd relay attempt succeeds then you just had two drives die at an inopportune time.

Once the Drobo recognizes the old Drobo drive and starts relaying the data, that old Drobo drive is no different than any other new or used drive (except for any wear and tear from prior use). Just in case you were thinking along those lines.

If you do not do so already, I would put an UPS between the Drobos and AC. I think power fluctuations are behind a lot of otherwise unexplainable problems with computers, in general. Evan an inexpensive $50 APC UPS will go a long way to providing clean power. The Drobo doesn’t pull much power although the associated Mac may so you should size it accordingly. I suggest an UPS because you say you have had many issues with reliability (which most of us don’t seem to have).

You can also see why the time to backup your data is not when you have a problem. Especially considering the amount of time it takes to relay and/or backup terabytes of data. Backup is something that needs to be kept up to date, daily if the data changes daily. Then, when you have a problem, a quick sync is all that’s needed to get it fully up to date. Even if you dump the Drobos, your next disk array will not be fail-safe either.

You should try to test the two drives with the drive maker’s test app. I use WD drives; they seem to have a decent drive diagnostic utility. They should also still be under warranty if the drive has a 3 year.

Neil
First of all, thanks again you for your extensive answers. I appreciate you taking the time to do all these write-ups.

  1. the reason why I was asking if I can turn the Drobo off during that five day array rebuilding period is because I am worried about the overheating of the hard drives. I thought that by turning the Drobo off, be it only for a couple of hours, might help cooling the drives down and give them a break. It was certainly not to replace any drive before the relay has been completed. In view of your reply I am assuming that the Drobo wouldn’t even let me turn it off by attempting to put it into standby mode and so the only way to effectively stop it would be to remove the power plug, which, I agree, is certainly not a good idea at this stage. Point taken, my drives will suffer through 5 days of data rewriting!

  2. Yep have to agree here too. It didn’t seem like a good idea but thought I might ask anyway. My Drobo currently has 4TB of data and the transfer times you are mentioning are consistent with the data transfers I have experienced myself before. Therefore the game plan will be to let it finish the array rebuilding, turn it off for a day to allow the drives to cool down and recover, then transfer the data off the Drobo (Hurray, here come another few days of data transfers).

To clarify my initial attempt:
1)For my first replacement, I put the Drobo into standby mode, then switched out one drive, then turned the Drobo on again. That was when the Drobo recognized the array from my other Drobo and decided I had switched out three drives from that other Drobo instead of just one from the Drobo I was working on.
2) For my second attempt, I did as per your indication, and hot swap the drives, this time with my second replacement drive, which seemed to work okay. However, my second drive seemed to have failed after a few hours into the rebuilding process, which is why I made my third switch
3) For the third replacement I switched back to the original drive that was in the Drobo in the first place, and that is the one the Drobo is currently rebuilding.

The first two drives that I swapped are now dead: One is not even recognized by my Mac anymore (as a drive) and the other one fails when I try to format it (input/output errors).
All my drives are Western Digital Green drives (various capacities)

All I now hope for is that my drives will survive the remaining days of intense disk activity. If they survive that I can get the data off over several instances (and let it cool off in-between).

Thanks again for all your input & advice. Very appreciated!

Sounds like you have a plan although it will just put you back where you started :slight_smile:

For what it’s worth, I have used WD Green drives for two years and never worry about heat. That’s the main reason (aside from cost) that I use them in the Drobo. They were made for devices like this with limited ventilation (all quick swap multi-bay devices have heat issues, although the Drobo may be better than many since it actually has some vent holes in the backplane). I never shut my Drobo down during the 120 hours or so that it took to relay the last two drive upgrades (back to back). The drives probably reach max heat within an hour or less anyway. I have never seen any complaints here about real heat issues with GP drives, except where there was a fan or sensor failure.

It is interesting that those two drives failed right off the bat after working for some time in the other Drobo. It’s the horror story you don’t expect to happen to you but hear about on forums like this.

It is a testament to the Drobo that that array is still alive :slight_smile:

I’m going to guess that your backup copy will take about 55-110 hours, depending on the read rates you get. That’s based on 10-20MB/s sustained read rates and of course depends on your target but there aren’t many that can’t keep up with a Drobo The people that can’t wait for 16TB arrays on a Drobo V2 to be reality should be careful what they wish for :-).

I usually try to do 24 hours of sustained surface scanning and error checking (various utilities) when I buy a new drive. Probably isn’t a bad idea to do that with older drives too, if going into a Drobo, since the rebuild times are many times that if the disk goes south.

I have one point of confusion left. On your first attempt, you put the 1st 2TB drive into the shut down Drobo and tried the cold start. Our theory here is that the Drobo got confused and thought that drive was the reference drive. Our theory says there was nothing wrong with the drive itself, it was just inserted “improperly” in retrospect. You then shut down the Drobo and tried 2TB disk#2, which apparently failed while the relay was in process. Nowhere did you suggest you tried to hot swap the 1st drive after the cold start did not work, yet now the drive is mysteriously dead. That initial cold swap should not have killed the drive. You should have been able to try it again on a hot swap. How or when did that first 2TB drive actually fail?

IOW, if 2TB drive #1 is dead now, was it dead when it was first cold swapped into the Drobo???[hr]
Just for a sanity check… when you say one drive cannot be read at all in the Mac, you are aware that after removing a drive from a Drobo that the drive looks something like a factory new drive- it has to be partitioned and then formatted? If the drive is just put into a machine the machine will find no partition. I don’t use Macs but in Windows I use Disk Manager to partition the drive, and then format it, just like a new drive that is delivered without a partition.

Just doing a reality check here since I am so confused about how that 1st 2TB drive mysteriously died :slight_smile:

Let me retrace those steps again

  • have a Drobo v1 with four drives in it (2+2+1.5+1.5 TB). Over 85% full. Drobo says replace the first 1.5TB. Close to 450GB of free space remaining at this stage in the array.

  • have a 4-bay Drobo v2 with 4 drives in it, recently reformated, no content, all drives working OK.

  • take out 2 drives (let’s call them Drive A and B) of this v2 Drobo in order to replace two lower capacity drives in my v1 Drobo. Both are 2 TB.

  • reformat both drives A and B in OS X by attaching them directly to my Mac

  • they both format OK. No problem detected.

  • I turn off Drobo v1. Take out one drive (the one indicated by my Drobo)

  • Place replacement drive A in it

  • Turn on Drobo v1.

  • After boot up. Drobo has all 4 lights red (steady), says I replaced too many drives.

  • Put Drobo back into stand-by and power off

  • Put my original drive back in (the one I was supposed to replace) and boot up again.

  • Drobo recognizes my original drive and boots fine. No rebuild. All is OK my data is still protected and accessible. (Very relieved at this stage!)

  • Take my replacement drive A and try to format it again in OS X. Do now get an I/O error and Disk Utility interrupts formatting.

  • Put drive A aside for now

  • Take Drive B and do the hotswap switch

  • Drobo starts rebuilding the array

  • A couple of hours later it fails (all red lights flashing) and the array free space is down to zero even though I replaced a 1.5TB drive with a 2.0TB

  • Take out drive B and put back in my original drive

  • Now the array is rebuilding since it had started laying out the data with drive B.

  • Take drive A and B to reformat in OS X

  • On first format attempts both drives generate an I/O error and Disk Utility interrupts the formatting.

  • Second format attempt: Drive A is no longer recognized by my Mac. Meaning when connected it doesn’t even show up in Disk Utility anymore. Even after multiple reconnects. Drive B still interrupts with I/O errors.

Maybe I was just really unlucky… maybe the Drobo precipitated some events… I really don’t know

Sounds like at this point drive B failed during the layout. The volume was still intact, but unprotected and drive B was excluded. That’s probably why you had zero free space at this point.

Definitely sounds like both drives A and B have issues. Definitely RMA them - might’ve been a bad batch, or perhaps they were handled roughly in shipping.

One more question before I make an observation (we have approximately 75 hours to kill while the 1.5TB drive relays :slight_smile:

When the Drive B failed after relaying for a couple of hours, you got FOUR FLASHING RED LIGHTS. Correct? What did Dashboard say when the four lights were flashing red?

One more very idle question… how much use had the 2x2TB drives had previously? Were they brand new and just stuck in the Drobo or did they hold data for some period of time?

yes four flashing lights indeed for the second one (as opposed to steady red lights for the first one)…
To be honest I don’t remember now what the dashboard said… Having tried all these combinations and writing all these posts combined with the stress of potentially loosing my data strain my memory (yes that one too is subject to failure!) :slight_smile:

The two 2TB drives have had some use for a while but have been inactive for a couple of months now (meaning my 2nd gen Drobo has been stored away unplugged for about 3-4 months). And yes that can have an impact on their life span if I’m not mistaken.

Hey I’m down to 72H now… only 3 days to go :slight_smile:

OK… my observation is that 4 flashing (or solid) red lights is Very Bad because of two reasons:

  1. It is not actually documented anywhere as far as I know. To the best of my knowledge 4 flashing red lights means “Data gone bye bye” or “you’re screwed!”. IOW, some undocumented (and thus somewhat generic) total array failure. Because it is undocumented I was curious what Dashboard reported at the time.

  2. Because all 4 lights were flashing, you actually had no reason to believe it was the 1.5TB drive (just inserted) that failed. It could have been any of the 3 other drives. Of course, if it were one of those drives then your array would be a total loss.

The Drobo apparently handled a “double drive failure”… a special case where the replacement drive also failed, during the relay. Just an interesting factoid. I don’t know if this has ever been reported here before- probably has, but maybe this is the first time I thought about it in this way.

Logic dictates that your apparent outcome is less than a miracle. A logical assumption would suggest that when a drive fails and is relayed then only the replaced drive is written to, either rebuilding the parity or data striped zones from the other drive. But assumptions are always dangerous; I guess your case proves that “common sense logic” prevails.[hr]
P.S. I am suggesting here that 4 flashing red lights in the case where there is a recoverable problem (by swapping drives) is A SERIOUS BUG in the way Drobo reports this situation because the user has no clue which drive needs to be replaced. and since a relay can take a week, I, for one, could forget which slot I worked some days (if not hours or minutes) later!

In “View Todays Posts” there are 9 threads listed.

Three of those threads have a common thread (pun intended):

http://www.drobospace.com/forums/showthread.php?tid=2460

http://www.drobospace.com/forums/showthread.php?tid=2461

http://www.drobospace.com/forums/showthread.php?tid=2467

That common thread is this: for, in this case, 3 very different reasons, a Drobo inadequately reported a serious operating problem, such that only a log submission to tech support could determine that a drive needs replacing and only tech support could adequately determine which drive needs replacing.

We can come to several logical conclusions:

  1. The Drobo email alerts, blinking lights and Dashboard reporting is totally inadequate, in many cases (3 in discussion today!) for a user to self-diagnose many apparently routine problems.

  2. If you do not have Drobocare you are screwed

  3. Most importantly, from my point of view, I have previously discussed (arguably complained) that DRI’s Drobocare policies are such that we, as customers, can expect, at most, 3 years of Drobocare. In some cases perhaps as little as one or two (for a Drobo V1 purchased at the end of it’s sales life). DRI promises only that Drobocare will be available “as long as a product is currently sold”, no more. Any more is a “gift”, not a promise or a commitment.

If you own a Drobo V1 you understand this because you cannot currently renew your Drobocare and therefore cannot support your Drobo if it experiences what these three users experienced within the last few days. If you just bought a Drobo V2 you were not given the option of a 3 year contract and you cannot be sure that Drobocare will be offered when your 1 year current contract expires. If you own any other model you just have to hope for the best, I guess, the best being that your model is not replaced in the intermediate future?

I am cross-posting this to those three different threads because they are three different models, all with the same problem, and unless you read every post here you may not notice this pattern. I am posting this because my previous complaints/discussions are not theoretical- they are real world problems and the fact that there are 3 cases in current discussion illustrates it is a common problem. For this reason alone, I would be very hesitant to throw more money at a Drobo.

I’ve had all drive bays flashing Red once.

It was when I accidentally kicked my Drobo and more than once drive got loose.

I panicked, powered it down, reseated all the drives, and it came back up. But it did go into relayout (even though in theory it shouldn’t have needed to). Not sure if this was just some sort of sanity check or what, but it did a full data protection rebuild that took short of 3 days.

So while the root cause was different, my result was the same as yours - data still there with original drives, but full rebuild happened.

I think you lucked out and Drobo rejected the drives before it started doing any real redundancy-removing operations, so logically it was the same as me “kicking out” two of the drives within short time of each other.

I just wanted to post a quick update and unfortunately the news are not good.

After letting the Drobo laying out the data for the past two days now (at some point I only had two more days left to complete its recovery), it suddenly jumped up to 15 days… since then the Drobo has been had various estimates, in the range of 12-15 days, but now there isn’t even an estimate anymore, it’s just in progress.

About an hour ago, the Drobo started disconnecting from my Mac quite regularly, the dashboard now shows my file system as being “Unformatted” and whereas before I could still browse my Drobo, it no longer appears on my desktop now.

I’m slowly but painfully accepting the conclusion that my data (4 full TB) is most likely gone for good now!

Since the Drobo is still rebuilding in the background, I’m not even sure what to do now. The drives have been active for several days and are just waiting to burst too. I’m assuming I can’t even try any recovery at this stage since the rebuild is still in progress…

Are there any pointers regarding data recovery on a Drobo? Any software or special things I can try?

This is all speculative, of course, but if it were me, and I needed that data (presumably no backup) I would give it at least a couple more days to rebuild in peace. Then, assuming it completes the relay, I would work on the mounting problem.

From what I’ve seen here, Drobo relays are far more reliable than it’s time estimates :-). The estimating logic is kind of funky. Just trying to give you a ray of hope here :slight_smile:

I don’t want to get into a Mac vs PC debate, but Macs seem to have more mounting issues with Drobos, especially with the latest firmware (see this thread). That being the case, and considering that most or all of the users having mount issues (in that thread) are not losing their data there may be a good chance that you have two somewhat unrelated issues going on.

You may want to log a support case at some point. You probably should NOT attempt to pull a diagnostic log during the relay unless DRI specifically suggests you do so. Pulling a log during a relay can cause problems, according to the advice I have gotten from DRI support and also seen repeated here by others. Likewise you probably don’t want to be running file system checks or recovery software during the relay, so your only good option is to be patient and let the Drobo try to complete it’s task.

Thanks for the ray of hope! :slight_smile:

Over the past days I was still able to browse the file system while it as doing it’s recovery. What really worries me now is that the file systems seems to be gone and it is still relaying the data… so wouldn’t it presumably start overwriting the existing data?

Well anyway… time will tell now… I need to sit back, put the axe down, relax and wait :slight_smile:

PS: Since it is a Drobo v1 and am way past the offered Drobo Care support.

Docchris has argued quite strenuously that we all have free lifetime tech support. I would test his theory :-). They won’t shoot you if he’s wrong(*), they will just decline to help (IOW nothing to lose). Let us know how that turns out (I’m very interested, if you have kept up with other recent posts here).

(*) I’m pretty sure they can’t shoot you in the EU, where Docchris resides. They have good consumer protection laws there. If you’re in the USA I can’t guarantee the outcome :slight_smile:

I’d be worried too, but not enough to make things worse :-).

My personal assessment is that relays usually complete unless a 2nd drive fails, which is not terribly unlikely given the number of hours of stress put on the drives. But if a second drive fails you will end up with something like all flashing red lights and a “too many drives removed” status on Dashboard. I don’t recall hearing about relays that truly never end, so as long as the relay seems to be proceeding and not too many months have elapsed, there is much hope (statistically speaking).

If the dismount is due to data corruption that means the relay logic is somehow flawed, or… somehow Drobo has not dealt with a bad drive properly… something along those lines. I’m not aware that anyone has demonstrated here that that actually happens, but on the other hand I’m not sure how anyone could even determine that for sure.

That’s just a bad attempt to elaborate on my logic. Have patience. Have hope :slight_smile:

Let us know how it turns out. Log a support case.

I’m going to go with a watched pot never boils on this one…

When I “kicked my drives out” and had to go through relayout, even on my Vista (at the time) machine, the Drobo would be either extremely slow, or simply not be found.

Eventually I gave up and disconnected my computer from it so I wouldn’t go crazy “watching the pot.”

After it was finished (almost 3 days later), all was well.

Do keep in mind that pulling the diagnostic log will restart the relayout process, so I’d unmount and disconnect it from the computer, walk away and give it another 4 days at least. It’s like a wound - the more you mess with it, the slower it’ll heal.