Drobo

Replaced one bad drive (red light), now all drives are red

Hi All,

Hoping somone can help me…

I replaced a bad drive (red light) with a new drive…Now all the drives are appearing red, and I cannot access any data…
The dashboard is saying…“Multiple drives removed please re-insert the removed drives.” So when I insert the bad drive again, it still saying that message…

The Drobo was working fine with the bad drive, ie I was able to access my data as all the other drives were okay. So I thought that if I reinserted the bad drive I could at least get back…

I’m on a MAC with Mojave OS

Drobo FS with 5 drives.

Any help would be great…

Hi,

You can check the link below and hopes that it will solve the issue:
https://supportportal.drobo.com/retrieve/s3/knowledge/AA/AA-01388.html

Regards,
Nerd

Thanks, tried all of this…still not working…All red lights…

Did you try to shutdown the Drobo, reseat all disks, then try to power on again the drobo?

Yeah, frustrating…As I was able to access all my data before even with the one bad drive

Worst thing is that another disk may have also failed therefore all drives bay went all red lights. You may create a support case in Drobo support portal and maybe they can help you.

thanks, done that…appreciate your help

I have a 5D3 with exactly the same issue - My Drobo was near full so I added a newer bigger drive and now after a 20 hr rebuild - all are steady red and the dashboard tells me I have too many drives out and to re-insert - air dusted inside and re-installed all drives - gets half way through startup process and stops dead - I’ve raised a ticket with Drobo Support but they haven’t got back to be yet

Same issue, I have 1 Drobo usb 3gen and today all the lights go red, no rebuild, power off and all lights keep red. my other Drobo 5c network attached did the same. I think one update will cause this. I bought new disk but don’t arrive until tomorrow. This is so frustrating 2 drobos died at the same time.

Same problem here with my FS. Seems like it has happened to many people recently. Is it specific to the latest firmware/software? If it is, they should fix it instead of asking us to pay $99 for a one time incident support.

I’ve swapped out a bad drive a few times and it has never been a problem.

We have the same problem :frowning:

And… the same thing has just happened to me. I had one drive showing amber, so I replaced it with a bigger (6TB) disk. Suddenly all the lights changed to red. I left it running for 2 hours but nothing changed. I’d just bought a new iMac (Model 20,1) so I hooked up the Drobo 5C to my old Mac Pro to see if that would make a difference… after switching on again all the lights went into flashing amber/green. Ah… at least no red, but they’ve been flashing that way all night… 12 hours continuously now. The 5C does not appear on Drobo Dashboard at all.

Clearly something is wrong with the Drobo.

Have any of those who wrote on this thread earlier found a solution??? Please let us know if you have.

The issue is solved for me…I bought a one off incident ticket…

Basically, it was a dual disk failure…apparently, when one fails it is common for multiple failures…I had only single disk redundancy…

Basically had to run a diagnostic report for the support team to work out which drives were the issue, then need to block clone that drive…

Once I cloned it I had to put the Drobo FS into Read only mode (RO), see below

1. Whether you have the drive professionally cloned or clone it yourself you will need to flush the Drobo’s internal cache for that drive as follows :

  • With the Drobo powered off eject all of the drives EXCEPT the drive to be cloned.
  • Power the Drobo on
  • Once the Dashboard recognizes Drobo, use Shutdown in Drobo Dashboard > Tools to Shutdown Drobo.

Note: Please ignore any warnings about too many hard drives removed.

2. Cloning :
If you decide to proceed with cloning the drive yourself, you will need;

  • A known good drive that is the same capacity as the problem drive.
  • Make sure there is no data that you need on this new drive as it will be overwritten during the cloning process.
  • To clone the problem drive you will need to connect new drive and problem drive to free (empty) drive bays in your computer or into external drive docks that can be attached to the computer.
  • Do not format or initialize the drives .
  • You will need software that is capable of performing a block level clone. (You can use any cloning software that can-do block level clones and supports drives larger than 1TB.)
  • For Mac, we suggest that you download and install the DEMO version of Data Rescue 3 . Instructions for using the software can be found here:

Note : The cloning process can sometimes take hours or several days to complete depending on the condition of the problem drive.

3. Once the cloning process is successful ;

  • Power on the Drobo without drives installed.
  • Go to Drobo Dashboard > Tool and do key stroke command:
  • Put Drobo into Read Only Mode as follows:

Simultaneous Keystroke command :

Ctrl+Opt+Shift+R

Restart the Drobo as prompted from Dashboard, if not prompted power off the Drobo using toggle switch on back of Drobo then power back on.

  • After the Drobo has restarted go to Drobo Dashboard and verify that you see RO next to the name of the Drobo in the Status tab.
  • Once RO has been verified, power the Drobo off
  • If not in RO mode, do NOT proceed
  • If in RO mode, Insert the good cloned drive into Drobo along with the remaining original hard drives
  • Power on the Drobo

4. Reply to this email with the following information :

  • Status of all Drobo lights:

Drive Bay Lights (color, solid or blinking)
Capacity Lights (solid or blinking)
Power Light (color)

  • Does the Dashboard detect the Drobo?
  • Generate a diagnostic file so Support may confirm it is safe to take out of Read Only (mode)
1 Like

Well thank you so much for that, Z. I’m afraid I’ve already gone off in a different direction and (because I can, not because I want to) have re-initialised all the disks, lost my backups and plan to start all over again… but… I’ve taken a copy of your reply and will keep it ready for the next time - which there surely will be.
Thanks again and good luck.