Replaced 2 TB drive with 4TB drive in my Drobo 5D

I’ve had a Drobo 5D for a while and it was initially set up with five WD 2TB drives. My drives are NOT set up for dual-disk redundancy. Recently, one of the bay lights turned yellow (low on capacity), so I decided to replace that one 2TB drive with a new 4TB drive. That happened again a few months ago; I now have two 4TB drives, and three 2TB drives. When I click on the Drobo in the dashboard, it says “There is a new volume on your Drobo device that needs to be formatted. Would you like to format it now?”

If I say “yes”, it proceeds to ask me for a new volume name and wants to format another 8TB.

I’m confused. I thought when you hot-swapped drives in a Drobo, it automatically formatted the new drives. I’m reluctant to let this proceed for fear that it’s going to reformat everything and I’m gonna have 5 clean drives. Obviously, I don’t understand how all this works.

Under “Volumes”, it shows the volume ID=0 as HFS+ (I’m using Mac) with 6.44TB used, 8TB max. Under the new volume ID=1, it shows “not formatted”, nothing used, and 8TB max.

Can someone shed some light here before I click “next”, and lose everything :slight_smile: ?

Also, I’m planning on swapping out two of the other 2TB drives with 6TB drives to boost capacity and give myself some breathing room for a while.

Please advise.

First… selecting NEXT won’t hurt anything. What your experiencing is called ‘thin-provisioning’ and is normal.

Sounds like during your initial setup, 8 TB volumes was the specified default, so anytime your physical disk capacity grows beyond 8 TB the device creates another volume.

If you are on the latest firmware, you can reset the Drobo and configure it for 64 TB volumes instead, but that WOULD erase all your data so make sure you have a copy of everything.

Ok, I have reset my Drobo with the latest firmware. I cannot figure out where I configure it for 64TB. There must be a setting somewhere. I’m fine erasing the drives; I have backups. I just want to be able to allow for up to 64TB (I have 22TB today), but the dashboard says i’m configured for 16TB max so it wants to create two volumes.

Expanding your volume size requires re-initializing (ERASING) your existing diskpack.

This may help…

What are the steps to re-initializing (erasing) the disk pack? I ran “erase and factory reset” on the disk pack.

Never mind… got it… .I redid the “erase/reset” and now it shows 64Tb max.