Repair and migration

I’m having a really old Drobo (gen1 or 2, how do I tell?) that seems to be partly dead. The LEDs are looking as usual and the disks are spinning nicely. The ‘only’ problem is that I can’t connect to it using either USB or Firewire.

It is old and slow so it is time to upgrade anyway. I have been looking at the Drobo 5N because I rather have it connected to the network. As I understand, it is not possible to migrate the disks directly from the old Drobo to the 5N.

As I see it, I have 3 options:

  1. Try to repair the old Drobo so I can extract the data and move it manually to the new storage. Does anyone have any idea about how to repair it? I can easily buy and replace any component at the board if someone got an idea about where the problem might be.
  2. Try to borrow/rent another Drobo and copy the data using this. Does anyone have a clue about how to do this? I live in Sweden.
  3. Buy a directly connected device such as the Drobo 5D. That allows very easy migration. The drawback is that I would have preferred a network attached device.

I’m thankful for any other ideas you might have.

Have Fun

hi stb, if you have firewire then you have a gen2
thats the slightly easier part of your questions :slight_smile:

do you have some more info about the drives you have, make/size and usage (as fas you can remember), as well as what the capacity leds show and slots, and which operating system?

as am not sure of your ecurrent setup, ill mention quite a few possibles to try (sorry for long list) :slight_smile:

a few things you could try are these:

  1. to try a different usb cable

  2. to try a different usb slot

  3. to try a different usb cable in a different slot

  4. to try the above steps with firewire

  5. to confirm if you are using firewire (or have used) firewire pass-through conectivity to another device

  6. to confirm if you are using (or have used) any usb hubs/adaptors/convertors, or if you have always been plugging a cable directly connecting the computer and drobo?

  7. if you are on windows (or mac) you could try to check the firewall permissions (especially since recent mac updates have been known to reset and block the permissions for ddservice)

  8. to try the drobo and cables on a different computer, just in case.

9a) to power all off (computer/drobo etc)
9b) to unplug all connection cables from drobo
9c) (and with drobo still off, to unplug all drives as a diskpack and keep the safe somewhere in the same order)
9d) to power up the drobo without any drives, and see what happens.
9e) to power up the computer and then once fully booted, to connect the drobo with usb first.
and to check that dashboard service and app are both running.

IMPORTANT - after step 9 tests, if you want to put drives in as you had them, you must power all down, and ONLY put your disk pack back into drobo when the power is still OFF otherwise you can lose your data. (ideally to put the drives back into the same slots if possible)

(what happens now?) :slight_smile:

Thanks for your long answer Paul. I really appreciate all the effort you put into this.

  1. Not working
  2. Not working
  3. Not working
  4. Not working
  5. I don’t have another firewire device.
  6. Always connected directly to the computer
  7. I’m using Win7 64 and I have tried disabling firewall.
  8. Bingo! I got all files visible and everything seems to be working when connected to a laptop!
  9. Not done now, but I tried such things before I wrote first post.

It makes me wonder what went wrong in the first place. The problem seems to be located in the Win7 computer and it has been working for months before. I’ll spend some more time with it and pinpoint the problem. The computer has been a bit unstable and losing connection or sometimes totally frozen so it has never been working perfectly with the Drobo.
The computer is a few years old and has been working flawlessly without the Drobo so I still think it is related to some Drobo hardware or software.

Thanks again Paul!

This is really strange. I tried with another power supply and it still didn’t work. I have taken the Drobo apart and looked for any components that could be broken. All looked fine. I assembled it again and tested with another computer. It worked fine so I supposed it was something wrong with the old computer.

Right now I have the Drobo connected to the old computer and everything seems to be working perfectly fine. It has been working for a few days while I have been moving the data to my new unit. I have not done any real changes with either the Drobo, the power supply or the computer. The only real difference is that I have disassembled the Drobo and assembled it again. I cleaned it too since it was a bit dusty, but not too bad.

I am confused. Could it really have been a thin layer of dust that messed it up?

hi stb, sorry i was away last week - ive been looking at the answers you gave, and was quite pleased to see your answer 8) but equally puzzled by your latest post too :slight_smile:

i think if it was a hardware problem, that the problem would have followed you to the other computer as well, but thats just me… i was about to suggest trying the following software changes below, but now that you have it working on your other computer again its probably not worth changing anything, unless you have the same sort of problem again though.

possible 1) to uninstall all drobo dashboard software from the computer
possible 2) to check usb drivers in case not having latest appropriate patch for your computer model
possible 3) to check history of windows updates (in case a particular kbPatch had a conflict with usb/fireware connections, that was somehow installed just prior to your problems, yet somehow overwritten by another update just prior to them being fixed?)
possible 4) to try the connections again
possible 5) to reinstall your dashboard version again to see.

am not sure about the dust, but if its working fine now though, you might as well leave it working as is, and have a kitkat or something :D[hr]
edit: btw can i ask which OS you had on that other laptop?

Thanks for your help Paul. I’m very puzzled too. I hate when stuff starts working for no apparent reason because it usually means that they still have the problem and will stop working again sooner or later.

I reinstalled Win7 64 and all drivers at this Dell desktop computer about half a year ago and used it as “server” at home. It is just used for connection to the Drobo and as printer server. I also have an FTP server so I can get my files if I’m not at home. Nothing fancy at all. I have blocked all other internet access so it is not possible to connect to internet or even to update windows. It should have been steady as a rock. However, it has been a bit unstable and once a week or so, the Drobo has disconnected itself. A few times the computer was totally frozen too and had to be restarted using the power switch.
Because of those problems I installed a firewire board. (It didn’t work at all until I found the Unibrain drivers.) When I finally got it working, the same issues of instability continued.

When it stopped working completely, I tried all of the tests Paul suggested and some more, including disassembling and cleaning. Now, everything is working well. It might still be a bit unstable, but it has been working for a couple of days now.

I must add that I did change the network cable between the computer and switch about 1 day after the Drobo started working again. It apparently reduced the connection speed to 100Mbit. Theoretically, it could have caused some instability but it seems unlikely.

To Pauls suggestions:

  1. Did that one day after I got the Drobo working again. The previous version was just half a year old so it shouldn’t have been an issue.
  2. They were half a year old too, and it is now connected Firewire so I suppose they don’t matter.
  3. No internet connection, no updates. This is usually the key to stability.
  4. Working well with both firewire and USB now.
  5. Working just as well before and after the upgrade.
    Q: The laptop got Win8 but I think it is unrelated to those issues.

I will now use this Drobo as secondary backup equipped with some useless old drives. Never hurts to have another backup even if I doubt the stability. It will be offline and unpowered 99% of the time.
The new Drobo 5N is so far doing a great work but the fan is a bit noisy.

Nice work Paul ! Thank you.

ok cool :slight_smile:
yup it never hurts to have extra backups. usually i keep my gen 1 active most of the time i use the computer, and my gen 2 only sometimes (or especially when i do backups) then i power down the gen2 and keep it unplugged / offline so to speak, so in case of a power surge (or pets on the keyboard) its safer.