removed drives report wrong capacity in OS when connected directly to computer

I recently removed a 3TB drive from my Drobo FS and replaced it with a 4TB drive.

The removed was perfectly good so I connected it to my PC; Windows partition manager reports the drive’s unformatted capacity as only 847GB (that may not be the exact value but is ballpark) with only a single partition. There is no unallocated space.

I get the same when connecting to a Mac. I have not tried using the drive on a Linux but may try later.

That’s not all. I have an older Drobo S and put it in there and Drobo Dashboard reports the HD as being 3TB capacity.

This is a Seagate, but I’ve had this happen before on another removed 3TB harddrive, exact same wrong-capacity reported by the OS, but manufactured by Hitachi. This one was under warranty so I RMA’d it for a replacement.

Because this was Seagate, I tried booting to the Seagate Tools CD that came with it to see if I could get the 3TB capacity back, but the Tool reported the same wrong-capacity.

Any ideas what’s going on?

hi ive read something similar, and i think some versions drobo were marking a flag (setting) on the drive, which remains present.

if you do not need any data on the 3tb drive you took out of the drobo, then you could try to format it and see if it lets you choose a different larger capacity on a format after that

or you can also try using a drive wiping tool, such as DBN (boot and nuke) to see if that can clear the flag. (you need to ideally do this on a computer without any other drives, in case you wipe the wrong one)

alternatively, if you have easy access to plug it into a spare computer/bios, then the motherboard there might be able to format it to full capacity?

just thinking about this, there must be a way to reuse a drive, even if its been in a drobo. it could just be that certain hard drive models are having a problem themselves, but it would be good to know from the main drobo dev team if there is an easy way to reclaim a drive, possibly via the dashboard.

Don’t quote me on this, but I think that if you reflash the firmware (either manually or normal update) you can reuse a drive. I mention this because I had a drive like that (considered bad by the DroboFS), and a few months later (and a few firmware revisions later) the FS accepted the drive again.

hi ricardo, thats (without quotes) useful to know :slight_smile:

for ken though, ithink he was actually aiming to remove a good drive, and use that good drive as a standalone attached to a pc, rather than to get the drobo to accept a badly flagged drive. (unless your method clears that flag and shows it at full capcity to a stand alone computer as well?)