Drobo

Reformatting Drive taken out of Drobo to Mac

I took a smaller (400GB) fully functioning drive out of my Drobo, and want to reformat it and give it to my Dad for use with Time Machine via a USB to SATA device.

I can format it to Mac OS Extended (Journaled) with Disk Utility, and write to it and access the info fine. However, I want to secure erase it with the 7 pass option, and it always fails. Even backing off and trying to write over it one time with zeroes fails, with various errors. It cranks for a while, typically an hour or so, before failing. Have tried using it on 3 different Macs, Leopard and Snow Leopard, and two different USB cables.

Any idea what’s going on? Wasn’t able to find anything on Apple support pages.

Thanks!

No offense, but don’t you think you might, just might be a little tiny bit too paranoid? :wink: I mean, data security awareness is good and all but… come on… :wink:

agreed, two things to keep in mind -

  1. your data was storedin that drive in what is essentially an unrecognisable format

  2. your data was actually stored across many many drives, that drive will, in all likelyhood, only have tiny portions of any given file, making everything totally unrecoverable

people have spent a lot of money trying to recover data (and failed totally from what i can gather) trying to recover data from almost complete disk packs, and here you are giving away a single disk

a single wipe pass is more than enough, and a basic way to do that, would just to be pick a single file (a very very large file)_ and just fill the drive with multiple copies of it

then all they could recover is that one file :slight_smile:

(even the NSA would struggle after that)

Well, may be your problem has nothing to do with Drobo, nor with security paranoia, but is just related to the fact that your drive has low level surface errors, which the zeroing reveals (just rewriting the disk directory does not ensure the media surface is clean).
Remember that contrary to Drobo-S/-FS/-Pro/-Elite, Drobo-V1 and Drobo-V2 do not support continuous data scrubbing, and thus can be totally unaware of a media error until you try to access something at that exact place.
May be something like the Drive Genius scan tool would be worthwhile to try, in case the hardware errors can be reallocated to cleaner sectors.

On the other hand, if you don’t already own Drive Genius or a similar tool, and considering the price of a 400GB drive, it is probably cheaper to buy a new one… :wink:

I just wiped a disk or three from my Drobo using dd in Terminal.

Format the drive in disk utility, and mount it.
Assumptions

  • it’s called yourdiskname
  • somenum=(free space on disk in decimal)

In a terminal:
dd if=/dev/random of=/Volumes/yourdiskname/random.txt bs=1024 count=somenum

If you have a 100G disk called mydisk

dd if=/dev/random of=/Volumes/mydisk/random.txt bs=1024 count=100000000000

should write 100G of random data to a single file called random.txt on the drive /Volumes/mydisk

This is enough for most of us.

Thanks for all the great tips. I guess my main question was if there was something with a Drobo formatted disk that would cause this behavior, and the answer to that was no. I don’t have Drive Genius, but do have Disk Warrior, however it’s the old version and doesn’t work on Leopard or SL.

I made one more try using disk utility, but swapped the USB to Sata hardware before trying Spiney’s method with Terminal, and it worked. So it looks like the problem was with the original USB to SATA device. It’s been sitting around for a while with no drive in it. Maybe some dust in the connectors or something?

Thanks again for everyone’s help.