Drobo

Recycle Bin

I’m using XP. When deleting files on the FS they don’t seem to go to the Recycle Bin. Is my understanding correct?

Do I have to be extra careful with what I delete?

I don’t think there is anything you can do. does anyone know if there is any kind of recycle bin? I would love to have to confirm a deletion twice. Especially since this in my main backup.

When you delete files off any kind of network share they won’t go into the recycle bin, not just on the FS.

On the Mac you get a warning like “This file will be deleted immediately. Do you want to go ahead?” if you do that. Can you configure Windows Explorer in XP to do that?

XP has similar functionality by default.

I’d still like to have something to fallback on. Anybody know of a 3rd party recycle bin?

Undelete from Diskeeper is supposed to do this, but my primary share is now on a Windows Home Server with shadow copies and versioning, so to be honest I haven’t actually used it lately.

I think you need to explicitly tell it which network shares to monitor, but that shouldn’t be too difficult unless you have tons of shares.

I’ll try it & post back for those who are interested.

Thanx.

Okay, had a chance to check the Undelete help.

Seems the machine the share is on must also be running Undelete… which then puts the FS out of the running unless Diskeeper Corp releases Undelete for Drobo FS (might be a good request to send them).

[quote]Computers running Undelete Server, Professional or Client can access deleted files from mapped network shares (if the computers where the shares reside are running Undelete Server Edition). Computers running Undelete Server have the added capability of being able to access the full Recovery Bin on remote computers running either Undelete Professional Edition or Undelete Server Edition.

Recovery Bin
With Undelete, deleted files aren’t really deleted — the deletion request is intercepted by Undelete and the deleted files are actually stored in another location, called the Recovery Bin — so recovering these “deleted” files is only a few mouse clicks away. Note: You must have adequate permissions and ownership of a file in order to recover it from the Recovery Bin.

To view the contents of the Recovery Bin, double-click the Recovery Bin icon on your desktop. The files shown in the Recovery Bin display are files that have been deleted by any of a variety of methods, including the Windows Explorer, File Manager, or any other application capable of deleting files. It also includes files deleted via the Windows command prompt. (Note, however, that long filenames may be shortened to the DOS 8.3 file naming convention when files are deleted from the command prompt.)

You can have more than one Recovery Bin on your computer. By using the Recovery Bin Properties option, you can specify individual Recovery Bins for each disk volume, or choose a single location to where “deleted” files are moved (known as a "Common Recovery Bin ").

Undelete Server Note: Using a Common Recovery Bin on a network server will cause the deleted files on the server to be copied into a single location. If a large number of deletions take place into the Common Bin, this can add considerable I/O overhead. This overhead is apparent not only on the disk where the Common Recovery Bin is located, but also on the disk from where the files are being copied. For this reason, a Common Recovery Bin is not recommended on a busy server. Instead, enable the Recovery Bin individually on each drive.

So you’ve deleted a file from a network file server (or another computer on your network) and now you need to get the file back. What should you do next? There are several way to recover the file, depending on the Undelete edition you are using. (Keep in mind the computer from which the file was deleted must also be running Undelete.)
[/quote]

I saw that but…

I’m hoping that Undelete only has to be installed on the other machine to intercept deletes made directly on that machine. Then you can browse them from the network.

Maybe Undelete will still work if it is on the PC that does the mapping?

Either way I can’t get any mapped drives to show up in my Undelete.

There is a 30 day free trial. I’d appreciate it if anybody who can get it to detect their mapped drives let’s me know if it works or not.

If PC A is sharing a folder (\PC-A\Stuff) and it has Undelete installed…
and PC B deletes a file from the network share \PC-A\Stuff
then my understanding is Undelete on PC A will move the deleted file into its Recovery Bin.

Thing is, if PC B isn’t running Undelete, then you won’t be able to browse the remote Recovery Bin and hence won’t be able to recover the file from PC B. It should work to recover the file from PC A’s local desktop though.

I have both Undelete Professional and Undelete Server - just haven’t gotten around to trying to install it on my WHS machine. I’ll try a few tests.

My drive mapping doesn’t seem to be working, but I’m in the middle of uninstalling a nasty firewall (Symantec Endpoint Protection’s Network Threat Protection - the rest of it is great, but the Network Threat Protection firewall blocks too much, I know it blocks WoL, wondering if it’s blocking Undelete too).

Will follow up with more details, but right now, it looks like machine the file exists on needs to be running Undelete.

Which unfortunately takes it out of the running for Drobo FS and DroboShare.

UPDATE: Drive mapping works, but only if the machine sharing the folder is also running Undelete.
More info later…

According to this you should still be able to see the drives. I can’t. Can you?

I can see shares on other computers that are running Undelete Server.

EDIT: A client running Undelete Professional can see/add shares on a server running Undelete Server.
I have so far been unsuccessful getting a client running Undelete Professional or Server to see/add shares on a server running Undelete Professional.[hr]
Okay here’s some test results for Undelete 2009 Professional and Server, build 163.

Notes:
[list][]Undelete 2009 by default is set not to protect zero-length files. The option can be changed in the Recovery Bin properties. This screwed up my testing on the first round, so I’m noting this in case anyone tries to confirm my results.
[
]Firewalls can block Undelete’s network capabilities.
[*]I think I may be doing something wrong with respect to the Connect to Network Folder function, as the Undelete help implies that I should be able to Connect to Network Folder from a client running Undelete Professional to a server (not Windows Server OS, just a workstation hosting a share) running Undelete Professional. Also, the Connect to Remote Computer function on Undelete Server tells me it could not find domain information (I’m just running a workgroup) and doesn’t list any machines. I think the two failures may be related.
[/list]

Anyway, here’s what happens on my workgroup…
The machines running Undelete Professional are Windows XP, Windows Vista x64, and Windows 7 x86
The one machine running Undelete Server is Windows Home Server (based on Server 2003 x86)

Scenario 1: Client running Undelete Professional deletes file from share on server not running Undelete
Recoverable from server: No
Recoverable from client: No

Scenario 2: Client not running Undelete deletes file from share on server running Undelete Professional
Recoverable from server: Yes
Recoverable from client: No

Scenario 3: Client running Undelete Professional deletes file from share on server running Undelete Professional
Recoverable from server: Yes
Recoverable from client: No

Scenario 4: Client running Undelete Professional deletes file from share on server running Undelete Server
Recoverable from server: Yes
Recoverable from client: Yes

So, the machine where the file is being hosted needs to be “protected” by running Undelete (Professional or Server).
To remotely undelete files from the client side, the client needs to run Undelete Professional or Server and the server needs to run Undelete Server.

Thanks for your testing. Undelete showed a lot of promise.

Maybe some genius can create a DroboApp?

You’re running shadow copies ON Drobo? Have you ever used the shadow copies? e.g. restored an old version of a file after changing some data on Drobo?

I’ve used it too and it worked when I tested it after I’ve set it all up. But few days later when I needed it, almost all restored files were blank!

Thinking about the fact that shadow copies perform block-level operations on Drobos virtual disk, it’s obvious that they will fail!

So please check if it’s really working!

I’ve reported this issue a year ago but didn’t get any response:
http://www.drobospace.com/forums/showthread.php?tid=93

@skywalka:
You’re welcome. It was a good exercise, and made me realize I should just bite the bullet and renew my Undelete Server license for use on my WHS machine (Diskeeper’s been talking about an Undelete WHS version for over a year but so far it hasn’t appeared).

@RFZ:
Undelete definitely works - it stores the undeleted files as files in the filesystem. I once had a problem with an older version where it was continuously adding to the Recovery Bin cache and never flushing out. I quickly ran out of disk space and couldn’t find where it all went until I realized it was the Recovery Bin - so the “save” files Undelete uses are real files that take up space like any other files.

VSS, at least at-a-glance, works. I’ll have to take some time for more rigorous testing to say 100% that it works.

Well, after a large amount of running around chasing my tail, I can confirm two things:

  1. Shadow copies work reliably on my system, though it’s still not my preferred file-protection method as it’s not real-time (changes between copies can’t be rolled back), doesn’t support mount points and is full of caveats, including yet another new one I just discovered below.

  2. I can’t test shadow copies on my 32-bit Windows with GPT 16TB Drobo. Not because of Drobo, but because volumes > 5TB cannot be shadow copied on 32-bit Windows.

So I’ll need to reformat my other Drobo to MBR (2TB volumes) in order to test shadow copies with Drobo… which will likely take another week to complete testing.

For those interested here is a trick to get the Recycle Bin on your FS if you’re using Windows 7.

http://forums.mydigitallife.info/threads/16974-Tip-Network-Recycle-bin

I’ve tried it and it seems to work.