Reboot loop after firmware update

Alas, my Drobo S has developed a case of the reboots that it just can’t seem to kick. While I have an open support ticket, the rep seems disinclined to help, as the Drobo S is not under warranty. So I thought I’d open a thread, in the mean time, hoping some generous person might give me some hope.

Here’s the setup and sit-rep:

Drobo S (Gen 1)
Mac Mini w/OS X 10.6.8

I finally caved in to the Dashboard’s badgering for me to update the firmware on the Drobo. The dashboard went through the normal download and apply motions, then the Drobo reboot itself…then reboot itself again…then reboot itself a couple doesn’t more times before I put a stop to its madness.

A quick search of the internet shows that this seems to be a…notorious problem. My particular incarnation seems to have these symptoms:
[]The boot process restarts after the power light goes green where the blue lights should start filling up. It’s identical to the behavior captured on the video in this article.
]Reboot looping happens even when all the drives have been removed from the drobo.

Among suggested solutions, I’ve tried the following (a number of times):

[] The official 14-step “What should I do if my Drobo storage device keeps rebooting?” procedure. The Drobo does not boot with the disk pack removed so it becomes irrelevant after step 6.
] Booting it without the data cable
[] Pulling the power plug directly (as opposed to using the power switch
] Leaving it completely unplugged for a day, and trying again
[] Toggling the power switch while it’s unplugged (suggested in the commentary of the “TechKnight method”)
] Yelling at it

There are a couple things I have yet to try, mainly because I wanted to get input from support, but we’ll see if that pans out. These are said things:

[] Doing a pinhole reset with the drives removed. I mainly haven’t done this because I can’t find conclusive evidence that this won’t, in fact, make things much worse–possibly eradicating access to my data.
] The “TechKnight method” – while this applicable to DroboPros, I found a photo disassembly of a Drobo S and can see the battery that I would want to remove.

Unfortunately I didn’t note the firmware version (upgrading from and to), but I might be able to trace through various logs and hazard a guess if it becomes necessary.

I’m hoping that my only recourse to save my data won’t be paying $700 for a new Drobo. I’m a software engineer, so I know its painful or impossible to support legacy products, but, as you may note, my entire setup was circa-2010, so it’s the same technology the Drobo was designed to work with. I was only upgrading at the suggestion of DataRobotics, so I don’t think it’s entirely out of line to hope for a cost free fix.

So, suggestions or advice? Can anyone confirm that a pinhole reset on a Drobo S with the disk-pack removed is relatively harmless? You’re my heroes.

pin hole reset WITHOUT Drives

slot flush each drive

check which drive behaves differently when it’s being flushed (read step 6). It’s likely a bad drive and may need to be cloned.

Thank you for the response! I have since tried a pinhole reset, but that did nothing. The Drobo still reboots itself, even without the drives, so I can’t do the slot flush either.

Haven’t heard anything from support, so it’s looking like the firmware update has permanently incapacitated the Drobo… I hope I can figure out a way to retrieve the data.

hi have you asked the support rep if you might be able to use your disk pack, with a different, working drobo?
eg if they say its possible, (and if they have one for rent ideally, or if not) then you might be able to borrow one from a friend or possibly another authorised retailer near you, or at worst, to buy one second hand from ebay or similar, to get your data back?